Yaw problem on micro pusher


#1

8.5 mm motors
650 1s lipo
skisky f3 board with interrogated rx binds with d9x taranis naze32
no fpv
set up with motors pointing down and props pushing
the whole thing with battery weighs 59.4

fly’s level and has good lift but spins rapidly to the right with no trim
adjustment. adjusting the trim to max will make it soon left, how ever it cant be trimed not to spin.

Th


#2

Sorry I accidentally posted that and see no way to deleat it.

1m
8.5 mm motors
650 1s lipo
skisky f3 board with interrogated rx binds with d9x taranis naze32
no fpv
set up with motors pointing down and props pushing
the whole thing with battery weighs 59.4

fly’s level and has good lift but spins rapidly to the right with no trim
adjustment. adjusting the trim to max will make it soon left, how ever it cant be trimed not to spin.

The board was taken off a normally working quad.

all the motors and props are knew and bought as matching sets.

I reset the accelerometer in Beta Flight.

only two things make sense to me now.

  1. maybe you cant push with regular props
  2. the prop rotation needs to be changed.

Any ideas?

Thanks


#3

CW Motor upside down turns CCW and CCW Motor upside down turns CW. So make sure to install the motors the right way.
Also you have to drill through your props so you can stick the shaft through the top. Hard to explain with my bad English, hope you understand.
Here’s a pic. CW motor upside down with a matching CCW prop.


If you have it like that maybe post a pic of your quad for further diagnosis.


#4

What Chrisdo said is true, but judging from the spinning behavior you described, you need to reverse yaw direction. If this is not set correctly you will get a spinning behavior because the PID controller tries to compensate the yaw error by adding more yaw, which is in the wrong direction it expects, then adds even more yaw in the wrong direction, and so on. It spins rather fast though… :joy: Although using a lot of trim might slow down the spin.

There is a checkbox ‘reverse motor direction’ on the configuration tab in newer betaflights, or use the CLI commands:

To make betaflight understand this change, the command given is (as of betaflight 3.2):

set YAW_MOTORS_REVERSED=ON

For older betaflight:

set YAW_MOTOR_DIRECTION=-1

Note - setting these values will not make the motors spin the other direction. It simply tells betaflight that the motors are reversed so it can control the yaw accordingly.


#5

thanks for the answers.
Probably due to me beaning a super newbie.
I have made some irritating error.

i made some changes to the yaw settings and now it wont
bind. I went over all the settings and noticed that for some reason it
changed receiver type to one that was not compatible. I did not flash
it at this point. I set all settings back and the red light will stop blinking when the radio turned is turned on but when I move the stick to the lower left the green light wont come on… So it wont bind.

after that i flashed it. dont know if the flash worked or not but it does the same thing.

only thing i can think is that i used the wrong configurator
the board is supposed to have naze32 I used Beta Flight.
Been reading about it. maybe i should have used clean flight.
A browser extention app?


#6

chrisdo
What your saying is the prop wont be as efficient when it is turned backwards? or does that also change yaw?

JBFPV
So it wont hurt a dc motor to turn it backwards?


#7

What would help here as always is a couple of clear pictures of your set up. Once we can see what you have then we may spot your problem. The naze will be fine with Betaflight it just needs configured to suit your build.


#8

I been reading about it all day. The situation is vastly more complex than
I realized. From experience in other hobbies I know I need to simply learn how the entire Beta Flight, board and Trannis work. Otherwise I am throwing darts at a moving target blind folded. I figure a couple of months of serious part time study. Might get me in the ball park. When I bought my first 29 dollar drone I never would have thought it would go this far. I feel a little relived when I look at the learning curve that I have a little experience with command line as I used to do the old Red hat. Electronics has always been my hobby and I am interested in physics. I need to develope the ability to do micro soldering, Periods of intense concentration, hand eye coronation, the ability to diagnosis problems that span many different fields of science and to repair such problems. throw in a couple of specialties in the field of math. Now a 50 dollar toy upside down drown i becomes a diabolical nemesis. LOL by the time i get this drown to fly ill be able to get a job at NASA lol


#9

I feel you mate, there is a lot to this hobby but on the other hand it’s not rocket science. The problem you described in your first post (quadcopter lifts, but spins because I mounted motors inverted) should be fixed by simply turning on a checkbox in Betaflight. Should take no more then 10 seconds.

However I’m a bit lost, what is the problem at this time exactly? You tried to flash the firmware but it failed? Can you still connect to betaflight? I’m sure we can work things out if you could clearly describe the issue, that’s the nice thing of this community, we all help eachother :slight_smile:


#10

Yep, same here. First issue was yawing, should be solvable with @JBFPV’s suggestions if props and motors are installed correctly.

But now we first have to figure out second issue of flashing and binding combined with correct setup (ports, receiver mode and serial receiver provider).
You have a Scisky F3, right? Not one of the old F1 Scisky boards. That’s crucial, because they use different firmware for flashing.
If it’s F3 and if I remember correctly it should work with spracingf3evo.

But for now please answer @JBFPV’s questions and follow @Chaotix advice to post some pictures of your quad and setup. I’m sure you’ll get help here to get this thing flying, especially because you already flew it somehow ;-).


#11

Ok thanks guys but I did see the problem of how complex this is :slight_smile:

This is the board.
https://www.getfpv.com/oversky-scisky-micro-f3-brushed-flight-control-built-in-rx-option-frsky.html

This is the frame. I don’t use the camera guard since I don’t have a camera on it.

8.5 mm dc brushed motors and a cheap 1s 25c 650 lipo

This is the radio.

The problem is that it will no longer arm.
the board will quit blinking when I turn the radio on but the props wont spin. The reason it wont arm is because the Channel inputs will not work with the radio in beta flight. And I cant connect the battery because the props spin when I do.

I flashed it with a old version ob Beta Flight 3.0.1
Then I read that might cause problems so I used the
newest chrome Beta Flight …and it won’t flash.
No response from boot loader.
The flash files had different names so it may be I am trying to
flash the wrong image.

Here are some picks of my plastic nemesis.
There are some motor wires off now I credit my Chihuahua
for his assistance.


#12

Cool looking rig!!! Id love to try something like that out soon


#13

So now we’re taking. Thx for pics and details.
Let’s start from scratch.
First thing is to flash your fc with the correct BF firmware.
If you get no response from bootloader you have to bring your fc into dfu mode for flashing.
Easiest way to do that is using impulserc driver fixer. Download it here https://impulserc.com/pages/downloads
Plug in your fc via usb and run the driver fixer. If successful you have to open BF and you’ll see dfu instead of the com port (top right).
So now you should be able to flash the board with newest stable SPRACINGF3EVO firmware.

Let us know when you have done that successfully and we’ll take the next steps.


#14

haha :joy:
Do as Chrisdo said and I’ll be awaiting response. But I just wanted to say it’s always good practice to take your props off. Even though this size isn’t dangerous, it can be annoying if it decides to go full throttle on the bench.


#15

Hint:
If @ is written before the username without space between @ and name
It looks like that @JBFPV and @markp1313. So the one tagged will get notification.


#16

Thanks everyone for the comments and help.
My nemesis now has the latest SPRACINGF3EVO firmware.
Loaded to it :slight_smile:


#17

Nice.
Now let’s bind it to your TX.
Go to ports tab in BF. Enable Serial RX for UART2.
Go to Configuration tab. Receiver - select serial-based receiver (Spektrum, SBUS… - select SBUS as Serial Receiver Provider.
Press save.

(As you’re in Configuration tab right now, let’s solve the issue of spinning motors when battery is plugged in before going on with binding.
ESC/Motor Features - select BRUSHED - activate motor pwm speed separated from pid speed - set 16000 motor pwm frequency - activate Motor_Stop - set 1000 Minimum Throttle, 2000 Maximum Throttl, 1000 Minimum Command.
Press save.)

Back to binding:
Now try to bind your FC’s build in receiver to your transmitter and verify in BF receiver tab that you get correct stick movements.
Report back when done or problems occur.


#18

It will bind but not arm. The pic that represents the drown spins wildly in all directions. The sticks do have some control but it is erratic. Moving a a stick will cause the channel indicator to move them it will move back on its own without moving the stick.


#19

Looks like this with the radio on.

and like this when I turn it off


#20

Select SBUS instead of SPEKTRUM1024 as Serial Receiver Provider.