Trying to configure a Taranis QX7 with an irangex 4 in 1 multimode plus


#1

Hey all,
Just got my new QX7 radio and a 4 in 1 module. I looked at several videos to set this up to talk DSMX but to no avail.

Updated radio to latest OpenTX 2.2.1
Configured radio and module as per info. Multi - DSM - X22 (and x11) Number 8 on the rotary switch on the module.
FC is just flashing…
If I use PPM mode, the FC binds but all the channels seem to pulse on there own without input from me.
I’m not sure if I have to update the multimode also…

UPDATE:
Got it working but AIL and ELE are reversed - in other words when I try to roll, I pitch - and when I pitch, it rolls. ???


#2

Set the module to 0 and use the TX’s external protocol menu to select DSM. You’ll probably need to remap some channels either in the tx for that model or in betaflight.

I was able to get it to go using Bayang that way, it took a bit though.


#3

Thank you @Bobnova!

Yes that’s what did it - setting it to 0.
Yes 2 channels need to be remapped - AIL and ELE…
How to do it?


#4

I’m loving the feel of this radio compared to my DX6i. Just hate having to hold the ON button for 3+ seconds to have it latch on, though


#5

In betaflight on the receiver screen up top it will have a box with “aetr1234” in it, that’s the channel order. Change it to taer1234 (I think) and you’re golden.
Alternatively, on page 5 or so of model setup on the TX you can set which inputs feed into which channel, and map it that way.
Personally I do it in betaflight, but one way isn’t better than the other or anything.

Enjoy your new radio! I really like the taranis units I’ve used.


#6

Thanks Bob! I’d rather do it on the radio than in BF. I do have TAER1234 selected but doesn’t seem to correct the problem.
Just trying to find out how to do it on the QX7


#7

Ok - Figured it out and so far so good.
swapped AIL and ELE on page 5 and also assigned AUX 1 and 2.
Works well, I think I still have to go into BF and enter the rxranges because I’m not getting full travel ATM


#8

Yeah there’s always something to do, lol.
I think there’s a scaling option in the TX too, but I don’t know where as I haven’t had to use it yet.
It’s arguably a little better to adjust it in the TX if you can, but I don’t know that the difference is noticeable.


#9

Yeah - updating the rxrange values in CLI did the trick. Amazing that even though the multimodule/QX7 combo works flawlessly, the setup procedure is definitely not ready for primetime.
Well anyway, I got my DSMX fleet going and now I’m ready for some Silverware…hehehe

First Impressions on this QX7

I love it - The gimbals are superior to those of the DX6i - Switches galore. Once you get past the STEEEEP learning curve, it’s only limitation is my imagination. I kinda don’t care for the dual antenna look - I’d rather the module share the host antenna than kludge another out of the back.
I highly recommend this unit even though I haven’t discovered 3/4 of what this thing can do.

@Bobnova - Thanks man for pointing me in the right direction.

Silverware, Here I come!


#10

Awesome! Glad you got it going and glad you like it!


#11

To adjust travel go to outputs page on qx7. Select wanted channel. Press wheel. Select edit. Now you can adjust (ppm)center and min/max values to get 1000/1500/2000 in BF receiver tab. If you can’t go further than 100, you have to activate extended limits (e.limit) on page 1 or 2 ( where you set up your model name, used module etc.)
I prefer to adjust travels on my TX instead of messing with rxrange in cli.


#12

Thanks @chrisdo - I’ll try it on my next build. As of now, I did do the rxrange on CLI for all my current models and it really wasn’t too bad.
I don’t know if it’s the placebo effect, but I really love this QX7! To me, it feels so much more precise and predictable than my previous TXs.

FWIW No, I don’t work for them nor do I get a commission but I’m just so stoked at how much of a “feel” difference I get vs my old TX that I just can’t help it.
I’m most happy about the fact that my 6mm BOSS feels even more locked in and predictable.


#13

I just picked up a QX7 as well, I really dig it so far…but was bummed to realize I can’t bind it with my Inductrix. I didn’t realize there was a module that would allow me to do this!

Would you mind sharing where I could find the module? I’d like to give it a shot.


#14

@Drew, I got it from here. I got the “plus” vs the original just because I thought it was more updated - come to find out thanks to @Bobnova that the little rotary dial just stays at 0, so basically its superfluous on the QX7 since it is programmed and bound from within the TX. Otherwise, it’s rock-solid.


#15

Thanks @chime13!

Looks like the “regular” version is a couple bucks cheaper - maybe I’ll check that one out.


#16

Is there no need to flash a special version of OpentX to use the software for changing protocol? I remember having to do that on my Taranis in order to use the software to change instead of the hardware buttons. I have a different multiprotocolmodule though.

Oh wait now I remember it is now integrated into the newer versions of OpentX if I remember correctly!