Micro Motor Community

Silverware Tools for macOS - new version!


#45

I’m in the same boat. I could test by early next week sometime :- )


#46

I’d love to test it, I’m keeping Parallels on my Mac just for Keil :slight_smile:


#47

The beta software has gone out to everyone who has shown interest in testing.

Thank you guys!


#48

Container testing done! I have a hex file… Tuesday I am going to test the hex on a real quad.
Can’t wait :star_struck:


#49

Will the new version be able to compile NFEs fork without strange behaviour in the resulting hex?
I’d love to test it out, getting tired of having to fire up my old dell just for Keil.


#50

Yes it will. It uses the same compiler as Keil.


#51

Great to see you still in guys, seems like a Mac is soon the preferred thing to compile Silverware. Carry on :slight_smile:


#52

I started a new gig this summer. Money is good, but it doesn’t leave a lot of time to tinker with micros.
My plan is to be a bit more involved in the community now that the new whoop season is starting :wink:


#53

I’ve tried couple of different setups over past few days using the new beta tools (all with E011C board because that’s all I have other than one Zer0 which I am scared of touching because it flies perfectly :slight_smile:) with different 6 and 7 mm motors, stock and devo tx and different filters and PIDs and everything seems to work flawlessly so far. Great job @sier, thank you! Mac users rejoice!


#54

Hi @sier could I get a test version link please? I need to use NFE’s fork in connection with Zer0 support and would love to be able to offer Mac compatibility to some of the more intrepid new Silverware users.


#55

Red Hat Linux user here :blush:
Flashed some code that did’t work in in gcc and now it works perfectly.
I didn’t expect anything else… It’s the official compiler :smiley:
Thanks sier! I will send you my CentOS version of the Dockerfile.


#56

Version 1.0 is out!
This is the first version that is able to compile Silverware NFE without any modifications.

https://simonernst.com/silverware/

A lot of work went into this one. Please let me now if anything is broken or unclear.


#57

Thanks for all your hard work. I have an old MacBook Pro that can’t be ungraded past OS 10.11.6. I am bummed.

For those interested, compiler requires OS 10.12.


#58

So sorry about that. It’s the new version of Docker that requires 10.12. I tried to mitigate that during testing, but the only option is installing Docker Toolbox, which brings loads of other dependencies. It’s just not worth it in my opinion.


#59

@sier, No problem, it just means it is time for a new MacBook :grinning:! I do have a windows desktop computer, but was hoping to use the Mac, as I am sure you know, it just seems so much easier on the Mac.

Thanks for your reply, I do appreciate the time you spend helping others by developing the tools for us Mac users.

Christopher Potts


#60

Thanks for all your hard work on this @sier

@Chaotix told me that you had done some more work on it and I am keen to give it a try. I also use Arduino for MultiWii so I have to be careful which OSX I update to because there can be issues with the later OSX versions.

I am using Sierra 10.12.6 so I assume I can use your tools OK ?


#61

You should be fine :slight_smile:

My tools run on every macOS version by the way. I currently depend on Docker to run the ARM compiler (which is only available for Linux) and that’s requiring newer macOS versions.


#62

Thanks Simon I’ll let you know how I go when I get around to trying if :slight_smile:

EDIT - that’s some very nice flying in your video too Simon


#63

Simon, I am using your Docker-based tools (which have been awesome, by the way!!) and am having trouble working with multiple versions of the code.

I have multiple copies of the code in different directories for different models. I’ve tried to change the contents of the .compilercfg file to point to each directory I want to compile, which kinda works, since if I move the directory indicated away, the Compiler tool offers to download Silverware again. But sometimes the tool appears to be stuck on a previous directory because the .hex file doesn’t match the new directory I set in the .compilercfg file. I can check this by modifying a file in the new directory such that the compile should fail, but the compile succeeds.

So my questions are: how can I make this work? Is there some other than the .compilercfg file that specifies which code directory to point at? Is your tool caching some content somewhere? In the Docker container, maybe? Can I force a flush of that somehow (without resetting the Docker disk image)?

Thanks!


#64

I just keep some folders labelled with identifiers for each version, brushed, test, experimental, brushless etc. Then i move the NFE_Silverware folder into the tool as necessary.