Micro Motor Community

Silverware Tools for macOS - new version!


#21

Viewer tested and working fine on High Sierra! :ok_hand:
Thank you for your work @sier !


#22

I just released version 0.6

If you had a bug where the tools couldn’t connect to your board no matter what, that’s fixed now :+1:


#23

Beauty something else to try, like I haven’t got enough future projects already :slight_smile:
Nice work @sier


#24

Beware of using with NFE silverware, the gcc copliler doesn’t handle some filter code well and results can be dangerously random. Sbus Zer0 full speed motors on lipo plugging being the worst case.


#25

Thanks @Chaotix forearmed is forewarned :slight_smile:


#26

I have a version based on Docker, that uses the official ARM compiler. It compiles NFE Silverware without any issues. It’s not quite ready for public release yet, but I’m working on in!
My current work situation doesn’t leave much free time, bear with me here :stuck_out_tongue_winking_eye:


#27

That’s a creative use of docker, I like it!


#28

Trying to flash my first Whoop! I have downloaded v 0.7, but am getting this error:

in procedure ‘ocd_bouncer’
** OpenOCD init failed **
shutdown command invoked
Flashing failed. Are all cables connected correctly?

Any thoughts that might help me fix this?


#29

As the error message states, check that all of the cables are connected correctly. ;- )

You get that message when the three cables aren’t connected to the correct pads or when the processor chip is still locked.

Can you give more information? What board is this? What ST-Link pins are connected to what pads? A picture or two may help.


#30

Thanks for checking into this Brianquad. Its an E011 board. It doesn’t match either the old board that some have posted or the new board. It doesn’t have the 4 pads positioned in a box formation that so many others talk about.

I have been trying to flash it through the 4 ports at the top. They are labeled just well enough to see. I have tried different cables, soldering cables, connecting cables to pins… No luck with it. Here are two images of the board:


#32

That’s an E011C board (a Santa Whoop):

It should be flash-able, though I don’t have one myself. It is the same as the JJRC H67 and BWOOP PRO: http://sirdomsen.diskstation.me/dokuwiki/doku.php?id=bwhoop

There is a video to walk through flashing this one. Maybe it will help?

It does look like the pads are labeled correctly, but sometimes the ST-Links aren’t apparently. Oh, but you said you tried swapping DAT and CLK already…


#33

More thoughts:

  • Are you connecting a battery during flashing? (you should)
  • How quick are you to try to erase/flash? The first time, you sometimes have to be fast and erase within a couple of seconds of connecting the battery (at least it seems like I had to do that on one of my boards). After erasing, that doesn’t matter anymore - unless you flash it for an Sbus receiver, then that comes back :- )

#34

Thanks! I’ll give it a try and let you know.


#36

@sier I’m very interested in trying the Docker version out, good thinking!


#37

How dit you transfer the 32KBytes license? Now I have to run (Windows) Virtualbox for keil MDK Lite to use official ARM compiler, really like to try the docker version and official ARM compiler with 32Kbyte limit or some other free license model!


#39

FYI, that is exactly the text I get when I run the Unlocker utility with the ST-Link inserted in the USB port, but no board connected to the ST-Link (except the Target voltage was slightly different).

Do you have access to a Windows PC to try using the Windows ST-Link Utility or Keil?

My best guess is that you need to be quicker to get the unlock in time (or…just get lucky one time). Plug everything together except the battery, launch the Unlocker app, then wait to press “Yes” on the “Are you sure?” warning box until right after you connect the battery to the quad. If it doesn’t work, do the same setup again and try again at least five times in a row, trying to get a faster plug-in-battery to click-Yes time each time.

I know at least one of my boards, I had to try a bunch of times and I was sure I got a dud board until it worked one time - and I didn’t think I had done it anything different that time!

There was a recent discussion on RC Groups that mentioned the same thing - having to try again and again to get it:
https://www.rcgroups.com/forums/showthread.php?2876797-Boldclash-bwhoop-B-03-opensource-firmware/page196


#41

To be honest, the biggest problem I have with releasing this version is the licensing.
I could just ship the 32kb free license with the tool, but I’m not sure if I’d be violating any of their rules with that.


#42

I think that would violate their rules, Maybe insert the license with the “volume -v” option.
Than I can extract the license from the official software myself and insert it in the image with the -v parameter.
This way you don’t have to ship the license with your image and it will still be easy to use.
If you only want to insert a file then you first need to create a dummy file in the image else it tries to create a directory.