Micro Motor Community

SciSky Micro F3 FC - Bound but no Rx on previously working/arming FC


#1

I will try to write out everything that I went through today with this FC in trying to get it to work. I’m attaching a picture of the exact flight controller for clarification’s sake.

I was able to bind my FlySky FS-i6 to the FC by switching from AFHDS 2A to AFHDS. Red LED changed from blinking fast to blinking slow. After reboot of the Tx, solid red light came on and Tx was successfully bound. In CleanFlight I could see my Rx channels working.

I set up arming using SwB and flight modes with SwC (3-position)

I found that arming (green light on solid) with battery power in Air Mode caused the motors to spin up immediately, however switching to Horizon or Angle mode stopped the motors. Returning to air mode spun the motors back up.

At this point my Rx was receiving fine from my Tx. I then removed the battery and plugged in the VTX board http://www.getfpv.com/oversky-scisky-video-transmitter-vtx-40ch-25mw-on-scisky-board.html http://d1b5yzykmxw6e8.cloudfront.net/catalog/product/cache/1/image/9df78eab33525d08d6e5fb8d27136e95/o/v/oversky-scisky-video-transmitter-vtx-osd-40ch-25mw-on-scisky-board_1.jpg

When I plugged the battery back in, the motors spun to full, so I removed the battery ASAP. The quad was not armed at this time. In fact, my Tx was not even powered on. I have checked for shorts or burns and found nothing unusual. I then removed the VTX board and powered back up. The motors spun very slowly every few seconds.

I plugged in via USB and was going to investigate what was happening, and found that while I have a solid red light when my Tx is on (good bind, it will go back to slow flashing when Tx is turned off) I have no Rx signal on my channels in CleanFlight. I reset my configuration and rebooted the FC, but it did not fix the issue.

I am afraid to change anything else for fear of breaking something else. This is my first time setting up an FC and I put 4 hours into getting it to actually bind, setting up aux channels on my Tx, setting up modes, etc. This thing is such a headache and I’m setting it down for now and will come back to it later.

What should I try next?


#2

Can you expand on binding settings? I have been attempting to bind FS-i6 and OverSky SciSky F3 Micro for over a week with absolutely no luck.