Micro Motor Community

Ok - how can I get my point across without sounding like a dweeb? (hahaha)


#1

I tried posting my question at the GitHub and unfortunately, I didn’t have the patience to press on. Those of you that have gotten to know me through posts here and (mail-posts) could come to the conclusion that I’m a better builder than a pilot, but overall something above the novice level. I would appreciate if one of the seniors here at the MMWF would take a stab at trying to interpret my intention into proper GitHub terminology - Hahaha

In previous posts I’ve noted that the Airmode minimum throttle is “at times” too high, causing the craft to float, and/or rise in altitude - WITH THE THROTTLE AT ZERO (not yelling, just trying to make a point).

While I understand this could be an anomaly with 2 of my lightest but, most powerful builds, I would like to be able to set a fallback or minimum throttle for Airmode (such as an ‘idle up’) to a value between 1000 and x.

If we already have Enable Airmode @ 1350, why not have the ability to set the minimum throttle for Airmode when throttle is @ zero.
Can anyone put it in a language where either I can understand why not, or, how to ask this question properly.

Thanks all!


#2

I may be misunderstanding your question, but digital idle percentage does what your asking. That is if I understand your question correctly, if not, sorry.


#3

Brushless or brushed? If it’s brushless and dshot try lowering the idle, if it still gains altitude you’ll need to either drop the PIDs or change to less aggressive props.
For example: I found that the dys 304t triblades flew really nicely in my spintech 8000kv build, but hovered (mid air, not ground effect) at 9%, which meant that it was nearly impossible to lose altitude with them without print it into a gnarly dive.
The minimum motor speed to not stall was simply too close to the hover speed.

Prop selection makes a massive difference, especially at the small quad scale.


#4

Might be normal!
When in airmode, if the quad is on the ground it’s normal for the motors to spool up faster and faster. It shouldn’t take off though.

Also, when you’re flying close to the ground you’ll get a bunch of extra thrust due to ground effect.

It could be a mix of these things.


#5

What happens if you lower min_throttle?


#6

Probable reasons:

  • too high P and “powerful” setup (my lightweight 2" builds on 4S show these symptoms with BF default PIDs)
  • too high min_throttle (non DSHOT) and/or bad ESC calibration.
  • too high digital idle (DSHOT)

Additionally, adjusting the throttle expo/mid in BF might sometimes help on very powerful setups.


#7

i believe u are just rocking brushed atm, right @chime13 ? your fleet of 6mm nano style fliers was rather impressive!!! Or have you dove into brushless yet ? :smiley:

I also would try would benedikt had recommended if you haven’t already… I thought airmode was based off your set minimum throttle value…


#8

No idea what that is. I only fly brushed protocol.

@Bobnova - I fly strictly BF brushed quads in ACRO mode.

Similar issue but with 8520 MMW Darkies - don’t matter the props - I float like a butterfly

@Benedikt - min_throttle is 1000

@las - PIDs too high is the only thing that I could think of but loosening them definitely shows up during flight.

I guess I’m still confused on how Airmode works - I thought it would have some setting where I could tell it that, when I cut throttle with air mode enabled, set min rpms to x.

If Airmode is programmed to kick in and latches at 1350 rpm - what is the fallback rpms? Does this mean that my min throttle is 1350?

Why can’t it be setup like an idle-up and manually set the desired rpm at min throttle?

Thanks all!


#9

Yep - strictly brushed 6 - 8.5mm builds. I don’t have the money or space to dive into brushless. I’m kinda happily stuck on my 1s brushed builds. My new favorite motors - 0816s. Might just stay here unless @Benedikt comes up with some comparable 0716s…wink, wink, nudge, nudge…


#10

Could be noise from the extremely high d values we run in our brushed tunes. I have lowered airmode idle by messing with filtering if min throttle is already at 1000.


#11

I’ve been successfully flying with all my builds set to Dynamic Filtering and all notches turned off. Could very well be my hi D values…
Currently,
P = 120 - 140
I = 50-70
D = 120 - 170


#12

Drop your d way way down (like 70) for a quick hover, punch, and throttle chop. If it drops better… you know it’s noise. If so, put your notches back. Make sure d is on biquad… and restore your pids.

I often have to sacrafice the pids I want in the interest of managing noise for brushed.


#13

Rainy day - couldn’t get out but played around in my living room and FWIW, I have my baby tuned so it flies like an air puck 1 inch off the floor without the slightest bump or oscillation. Back and forth, all around like a hovercraft - unless I totally wrong (boring Saturday night) this little guy is well tuned… :blush: