Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


#1450

Hey guys- looking deeper into the rabbit hole here- I fly mostly in angle mode, what can I expect by turning on: **// ***********throttle angle compensation in level mode
//#define AUTO_THROTTLE on my 716 e011c test whoop?


#1451

You can expect a compensating amount of throttle to be added for you as you lean your whoop


#1452

I’m having issues flashing a Santa Whoop, it’s one of the JJRC H67 versions. The board does look a bit rough, the printing is so bad it’s pretty much illegible, certainly not as clean as the E011c branded boards I’ve seen.

I’ve flashed a Beta65S Lite in the past with zero issues. I’m using a 3 pin adapter on the pins and continuity seems fine between the board and the contacts on the inside of the STLink adapter. I get a link from the contacts on the middle of the board as well, so soldering to those instead should make no difference. Slightly baffled.

I just can’t get STLinkUtility to detect it at all, I’ve tried 2 different STLink adapters at this point, both flashed latest. It’s definitely got an STM32F030 chip on it, so there must be a way of getting to it. Has anyone had similar? I know someone mentioned something about the same boards a while ago, was there a solution?

The board powers up, binds and arms fine, so isn’t toast.

Thanks!


#1453

I assume you are starting with stlink utility to crack the write protection? The pads may be labeled wrong while the pins are labeled properly. What message do you get when you click connect in utility? Does the table populate?


#1454

I went via STLink last time, so assumed it was the place to start. It can’t detect it at all, in the settings page I just get “Detection Fail”. The STLink device is being detected as the serial updates and I can flash it fine. It does just look like it’s not attached, but I can’t figure out which bit is incorrect. I’ve had a fairly thorough look over the board and can’t spot any shorts, I’ll dig a bit deeper.

If no one else has had similar I’ll probably just clear everything off and start again.


#1455

Have you got any pictures of the board? Top and bottom


#1456

Sure - https://photos.app.goo.gl/cTT4Hxi8B9kdQNun8

As I say, I’ve checked the solder for continuity and it all seems fine. Nothing is touching the +v from what I could see either. I can take some better photos later if it helps.

Thanks!


#1457

Yeah thats a santa board… Bwhoop flash. Pins up front should be labeled correctly and should connect in stlink utility when you click connect.

Did you check continuity all the way back to the f0?


#1458

Yup, check the continuity.

I’d also check the first two pins for continuity on the first two pins on the connector on the top of the board, SWDIO and CLK, those solder blobs are big


#1459

I checked from the solder blobs all the way to the pin inside the STLink, sliding the case off it. I’ve checked the continuity between each blob as well and the other set of CLK/Gnd pads on the boards, which seemed fine. I’m doubting it all now though, I might actually strip it all off and just solder to the board quickly.

Given the responses that does sound like the likely issue here.


#1460

“Did you check continuity all the way back to the f0?”

Good idea, I’ll have a look when I get home.


#1461

Just in case you want to …


#1462

Note that you need to be QUICK after plugging in the battery and clicking connect in STlink utility. About 1second. Once time is exceeded, you cant connect to the board.


#1463

Since I’m having a few vibe problems with a 70mm LOS quad, I thought I’d give silverxxx’s automatic notch filter code a go, it’s listed here. If you set the telemetry in a Devo to holds you can see what freq the notch is centered on (well I think that’s how it works). Early impressions seem promising to good, but it’s too windy to test further right now. Just mentioned it as it seemed to “slip under the radar” at the time, and with winter, I guess a few of us have a bit more time to test indoors.


#1464

I tested it extensively at the time and could not get it to play nice. It caused oscillations for me that I attributed to excessive latency upsetting my p gains. It may be worth another look now again.


#1465

Yeah but what about setting the frequency the notch centeres on at the new filters you implemented? Probably it can be used to detect the needed resonance frequency :slight_smile:


#1466

Thanks for the help. I stripped the old solder and went straight on the bigger pads, much easier. Clearly my ability to check continuity it’s lacking!


#1467

Notch filters can be rather hefty for the mcu to handle and it may have been extending the loop time lowering all the filter cuts - which could have explained my oscillations at the time. To be honest I don’t remember if I checked that or not. It may have been before I overclocked as a standard too making a little more room in the loop.

One of my ultimate goals is a simple neural net to adjust pids and filters for us. And the old dynamic notch code has been on my mind for some time now as a useful tool in that process. I agree it’s worth another visit to both see if I can sort out whatever issue I had with it before and find something useful in it for future endeavors.

For the time being I am stuck on sorting out the crossfire radio protocol. So I will put that next in line. It’s coming along well but not without it’s challenges. I am getting data, but my framerate is slow and I have a bug somewhere that’s crashing the system if the fc is powered up before the tx is turned on when the first packet comes in. Otherwise with tx powered first at least I have clean data. Free time has been scarce … Need to step through the debugger again to find it.


#1468

@NotFastEnuf Dunno what you did with the new filtering , i keep testing different setup and things . Today ive tried Biblades on 716 19000kv before it was not flyable at all but now … wow ^^ Don’t even drift …


#1469

I tried the same 716/19000kv/bi-blade setup outdoors today with the same reaction- totally blown away! I use salvaged TBS 4 blades cut down to bi-blades and they were so snappy and fast