Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


#1308

It does work fine for me (One plus 2) … sometimes i lost TLM connections but nothing special.
Didn’t test this values enough but best so far my best results:

#define TX_POWER_GENERAL 7
#define TX_POWER_ON_TLM 6
#define USE_ALL_BLE_CHANNELS

Tomorrow i will explore the modes available, since the acro is too crazy for line of sight
Thanks you guys and Happy Birthday @NotFastEnuf if it is still the case :smiley:


#1309

And yet another noob question…
( right-right-down for level mode)
// *************Toy transmitter mapping is CHAN_5 (rates button), CHAN_6 (stick gestures RRD/LLD),
//**************CHAN_7 (headfree button), CHAN_8 (roll trim buttons), CHAN_9 (pitch trim buttons)

Trying to go to level mode i only get the blinking lights… am i doing something wrong ?
(seems to be a debug mode for throttle calibration or stick position)
So far i was only able to use acro


#1310

Disable stick travel check mode in config.h by commenting it out and reflash. What’s happening is stick travel check is already assigned to the rrd/lld gesture channel. So you can’t use it for activating level mode with ch 6. Alternatively use a different channel number/button for level mode.


#1311

// *************start in level mode for toy tx.
#define AUX1_START_ON

I did what you told me and used this one as well, but i doesnt do anything
Only acro mode seems to be working


#1312

What happens when you enter the right right down or left left down gesture? It should blink to confirm, and if you have use toy tx selected instead of multi or devo, and you left chan_6 assigned to levelmode… it should switch and blink. Zip up your config.h file and post it here for review if you like.


#1313

it doesnt do anything … it blinks for acro but not for level.config.zip (6.1 KB)


#1314

Before boring you guys, i just downloaded a new Clone from github and made only the essencial changes to make it work with the Ble_app and stock_tx. All the rest is default, thats why i dont understand why level mode doesnt work


#1315

Zip your config.h and post it. I will be able to easily guide u then.


#1316

i just did one post above, but here another one config.zip (6.1 KB)

Just remembered that i also commented
//#define INVERT_YAW_PID
Cause of the initial spin in acro mode


#1317

sorry, I’m watching a 2 and 3 yr old and a bit distracted. I’ll go over it this evening and let you know what I see.


#1318

Dont need to apologize :smiley:
Im the one who have to thank you, Family first!


#1319

Change Level channel to CH_AUX1 and try that?

#define LEVELMODE CH_AUX1


#1320

I give up for today …
As i saw your answer i’ve made the change and placed my st link v2 to see that the windows 10 no longer detects it as a usb… other pc the same error … long day … ill try to fix it tomorrow or buy a new one if this pen is dead.
Thank you anyway


#1321

Just wanted to drop in and say thanks to everyone here, especially @NotFastEnuf. I got some Santawhoops last week and finally got my ST-LINK yesterday and flashed them today after a few failed attempts. It was a bit challenging since I had issues with channel mapping and full throttle on arm, but fixed it all by searching through this topic. I haven’t put cameras on them yet but from what I can tell LOS they are gonna fly much closer to my Zer0 that I also got a few days ago than to their stock firmware :slight_smile:

Btw I am an iOS developer so one way I can give back is by creating an iOS version of SilverVISE app, if there’s any interest in that. Funny story, I recently learned via AirVüz that SilverAG is from my wife’s hometown :slight_smile:


#1322

So I’ve got NFE Silverware on a E011c and I’m running into issues. It’s flying but not well. The biggest issue is on roll left or right it will start a yaw as well. This happens leveled or acro. Using strong filtering and the default Alienwhoop PIDs. I’m guess the Alienwhoop PID’s are the problem since I’m not using Alienwhoop?

It also has throttle issues at times, it’ll run a much higher throttle than what I am giving it at times.

Any ideas? Anyone with a good E011c config?


#1323

There are only 3 changes I would make if flashing an e011c.

  1. Change target to bwhoop
  2. Change transmitter type to devo or multi based on which multi module i was using so aux mapping is correct
  3. Change receiver type to bayang telemetry autobind.

Nothing else. I suspect you changed up some stuff that did more harm than good. Recompile and flash and report back!


#1324

I went ahead and downloaded a completely new copy of NFE Silverware and then made your 3 changes plus commented out inverted yaw. I changed to Bwhoop, Devo and Bayang+telem+auto

Verdict is it is still yawing on rotate. Oddly enough it yaws the same direction no matter which way I rotate. In level mode if I correct the other direction it then levels out. Otherwise it continues yawing


#1325

Mechanical issue not software or maybe you got a bad fc .


#1326

Well that 4th change was unnecessary. Leaving it active allows you to perform a stick gesture to switch between both props in and props out. So that way you can test both. Take some pictures of your rig top and bottom. Let’s have a look at it just in case for something obvious.

You could also try an accelerometer calibration if you haven’t. Down 3 times gesture.

I read over your description of the yaw rotation a few times. Not sure I am totally understanding you. Maybe your yaw transmitter command is telling it to always spin? What radio are you using?


#1327

I’d love to see SilverVISE in iOS to fiddle with the gestures PID tuning!

I would discard a bad motor issue listening to them individually, as in

I am actually using a E011c board with “6mm & 7mm Abduction Pids (Team Alienwhoop)” and “VERY_STRONG_FILTERING” defined, and flies flawless