Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


#1287

thank you so much :smiley:
I would fix it as well … but still one week before i get the betafpv 19000kv motors
Both modes give the same problem… but i know that is because one of the motors malfunction


#1288

could be your gimbals not centering. bump up the sticks deadband and see if that hides it.


#1289

if deadband helps, then you can lower it again and try using subtrim in your transmitter. You can also go into debug mode in keil, and add rx variable to watch window 2… there you can see if your sticks are centering to zero or not.


#1290

hmmm… im not sure we are speaking the same language anymore :smiley:
im using the stock tx, i think i will receive a new e011 this week and i can see if the problem persists on the new one. After coming from work a can film the drone and explain a little more the problem on the motor.

Thanks a lot for all the solutions … and let me tell you that i only choose this drone because i saw your “Racemode” video :smiley:
Mind telling me how many years did you practice so far to race like that ?


#1291

CH_TO and CH_EMG are already in the bayang_protocol_telemetry… files, but looks like they are missing from the straight bayang_protocol.c and _ble files still.

They need to be added to the USE_DEVO and USE_MULTI for ease of use, though. I did that on one of my commits to the analog aux channels branch.


#1292

Well there is the problem! You need a good radio. Find something that runs deviation TX. If you can fly that thing on a stock radio, you’ll probably fly better than all of us once you get quality in your hands. :slight_smile:


#1293

Its the problem of living in Portugal … i have a flysky i6s lost in costume services about half a month
Still waiting for the multiprotocol as well.
It was supposed to came faster than the drone … so i could train in the simulator …
At least i got something :smiley:

BTW a video of the motor


#1294

Using the iRangeX6 module for the Flysky I6x. Finally got it to bind and then was able to figure out that arming was actually on Channel 6 with this multiprotocol module and not channel 5. Also figure out that Channel 10 (LED_ON) was actually channel 5. However that’s were it ends. I cannot seem to figure out how to get channel 6 (level mode). I had it when using the toy tx but now it’s gone. Tried stick gestures and also tried all remaining Aux channels (I have 10 total with this controller) Any help would be appreciated


#1295

Sounds like wrong tx type, devo might be what you want rather than multi in config.h


#1296

Any idea why my telemetry voltage on a1/a2 reads over 8v? I know about voltage calibration but it does seem a bit far off. Or do I have it setup wrongly on my taranis somehow (just ran discover sensors)

Edit: One more question, I am bit confused about stickAccelerator and stickTransition. Code says:

stickAccelerator and stickTransition are a more detailed version of the traditional D term setpoint weight and transition variables that you may be familiar with in other firmwares."

However further done there is also

#define ENABLE_SETPOINT_WEIGHTING
//            Roll   Pitch   Yaw
//float b[3] = { 0.97 , 0.98 , 0.95};   //RACE
float b[3] = { 0.93 , 0.93 , 0.9};      //FREESTYLE

Are both of these active on top of each other? it


#1297

Yes both active but on different terms in the pids. Setpoint weighting here is on the P term… and stick accelerator/transition is on the D term.


#1298

I have A problem.my Jjrc h67(stock motor) lose control when turning at high speed!

How to fix? Thank!
Video: https://youtu.be/IIGQftnMxxA


#1299

Set A1 and A2 to (Ratio = 10.4 and Offset = -2.6) under the sensors.


#1300

can anyone tell me if it is possible to make this fork work with the stock_tx ?
I’ve made a few tests already … and got 2 more e011c and now i know that so far the only way to make the stock tx work is to use the silver13 version… but the problem of “1 weaker motor” also comes from it.
Two new e011c and the problem is the same, and they work well with default firmware =/


#1302

Most recently in Post #1269 above.

[ #define RX_BAYANG_PROTOCOL ] in combination with [ #define USE_STOCK_TX ] .


#1303

By default there are only:
#define RX_SBUS
//#define RX_DSMX_2048
//#define RX_DSM2_1024
//#define RX_NRF24_BAYANG_TELEMETRY
//#define RX_BAYANG_PROTOCOL_BLE_BEACON
//#define RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND

and even with those … i only get a crazy fast spin that is uncontrollable
It seams that channel 5 and 6 do the same thing btw

Edit: i’ve test it and i get the crazy spin as soon as i use throttle


#1304

Yeah, comment all those protocols out and add
#define RX_BAYANG_PROTOCOL

As for the spinning, NFE is “props out” by default now, which is backwards from stock E011, etc. There is a gesture to change to “props in” (the propeller spin direction):
Down-Up-Down to switch and then
Down-Down-Down to save
(or, less recommended - comment out “#INVERT_YAW_PIDS” in config.h)


#1305

:smiley: Hahahha Finally
It does work, didnt know about the inverted props
I dont want to be boring can you just tell me if i can still use the:
RX_BAYANG_BLE_APP

To use it with the silvervise app ?
Thank you so much for the help


#1306

I think so, but I’ve never messed with the app honestly. Try it out and report back!


#1307

I think so, but I’ve never tried it (I don’t have a compatible phone). More info here:
http://sirdomsen.diskstation.me/dokuwiki/doku.php?id=silvervise