NotFastEnuf E011 / Bwhoop Silverware Fork


#1247

Yup, that was it. I had gone looking for how to configure that but couldn’t really find anything about it or how to change the inversion settings so thanks for pointing this out. Changing Inversion to 0 in rx_sbus did it. And as you predicted when I throttle up the RX browns out and disconnects. So is there a point on the board where I can get power to feed it at 3.3? Or is this a futile effort?


#1248

proper 1s brushed fc design is to boost lipo voltage to 5v, then regulate it down to 3.3 volts. These toy boards skip that to save money and use a lower 2.8v regulator to feed the mcu. This works cause our batteries just sag down to about that point and the mcu will just barely run on 2.8 volts. So of your rx happens to agree with 2.8, you may be good. You can tap into it on one of the programming pads. Otherwise you may be able to bypass the 3.3 regulator on your rx so it isnt follapsing from undervoltage and feed it regulated 2.8. It might run that way. Option 3 is an external 5v buck boost.


#1249

Heads up guys, 15% off in our Silverware shop using code LEAF18

Don’t miss: Oct 22-24 free shipping! Code SHIPFREE18

Edit: Link changed to international Site - for a better understanding :smiley:


#1250

@notfastenuf I’m just experimenting with torque boost and following your instructions you recommend dropping P gain by a few points. How much are we talking about as we’d like to keep P quite high? Is there a percentage that you like to go by?


#1251

For torque boost, you drop P a couple points - not much… but what you need to lower a good chunk is D. Torque boost is a derivative of motor outputs, so you need to keep over amplified D response low and clean. That’s when it works best. It re-apply amplifies the D response in a sense adding into its gain.


#1252

Yeah, the D gain is fine, was just wondering how much P to lose before it changes the flight behaviour to be as nice as it was. I’m running it on a whoop but I didn’t reduce P gain and it flies really nice apart from a tiny bit of bounce back on quick rolls. I suppose I could just drop P down after seeing how it flies after the halving D. Thanks


#1253

After some time way not figuring out the issue I’m trying to give this another go. I now have a cheap multiprotocol module (MTX9d) confirmed working with a stock E011.

Still can’t get bind to my Bwhoop, here is the relevant code I’ve tried:

// *************Radio protocol selection
// *************select only one
//#define RX_SBUS
//#define RX_DSMX_2048
//#define RX_DSM2_1024
//#define RX_NRF24_BAYANG_TELEMETRY
//#define RX_BAYANG_PROTOCOL_BLE_BEACON
//#define RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND
//#define RX_BAYANG_PROTOCOL_TELEMETRY
#define RX_BAYANG_PROTOCOL

(have tried bayang plain above, nrf24 bayang and bayang telem)

// *************Transmitter Type Selection
//#define USE_STOCK_TX
//#define USE_DEVO
#define USE_MULTI

When I power up I have solid LEDs and no reponse to any stick or aux channel inputs with the tx


#1254

Have you set your arming channels on your tx?


#1255

Yeah, just the defaults: Channel 5 is arming I believe. Even before I get to that stage I see know change in the LEDs - they are solid on from the moment I plug the battery in.


#1256

Are you flashing the correct board in config?

Have you tried downloading another copy of the repo and trying a fresh flash?


#1257

Try putting the arm switch on Channel 10 or setting the channel mapping to DEVO instead of MULTI. If you’re getting a solid light the binding process should be working, it’s just your arm switch is on the wrong channel.

UPDATE: Missed that the light was solid from the moment the battery was plugged in - that’s definitely not normal.


#1258

This.

I suspect you’re not selecting the right target. Cause solid light from the moment you plug in the battery is not a successful flash


#1259

Thanks for the response all

Sorry, time difference. I did try a fresh version chosen from GITHUB with Bwhoop as a target and same result but will try again tonight. Just to be really clear, can you please confirm the receiver I should be choosing for the Bwhoop B-03 pro (controlled by taranis with multiprotocol)?

If no success I’ll just to an old e011 board I have - in which case which receiver do I choose there?

As plan C, when is the zero board with bayang available :grin:


#1260

Curious. I have a redundant Bwhoop board that used to be solid LED on plug in. It had an AIO attached to it and it was causing some weird behaviour. Probably not helpful but something to think about.

Before you flashed the board was it working correctly? Is it worth zipping your files up and posting on here to see if we can see a problem?


#1261

Bayang protocol for the board and the tx (RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND).


#1262

Sorry and thanks to everyone who helped me. Sorry it was a stupid mistake where I fogot to remove the alienwhoop_zero hardware when I added the bwhoop definition.

For anyone else RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND is definitely the right receiver type on the Bwhoop B03 pro.

Now for the thanks - really appreciate the help here and here is my layperson’s first impression on NFE sliverware: This firmware is amazing, makes me actually want to fly whoops

  • When I donk into things it doesn’t get confused, just keeps going
  • It doesn’t have the ridiculous propwash I found with betaflight that I came across a lot
  • Has moar power?
  • I can actually do rolls now even with stock motors and a heft 25g weight without battery
  • Flying in pure acro makes me feel like I’m a half decent pilot!

To properly say thanks I’ll write up an article on how to set up for the Bwhoop in particular to hopefully help others in future.


#1263

Hi guys i am currently using this Tx module to fly a BetaFPV lite - https://www.banggood.com/Multiprotocol-TX-Module-For-Frsky-X9D-X9D-Plus-X12S-Flysky-TH9X-Transmitter-p-1097688.html?rmmds=myorder&cur_warehouse=CN

what is the correct way to get this to work with the [NFE Silverware master] flashed? Im stuck and unable to bind it to my Qx7,I have tried every related combination of the following -

// *************Radio protocol selection
// *************select only one
//#define RX_SBUS
//#define RX_DSMX_2048
//#define RX_DSM2_1024
#define RX_NRF24_BAYANG_TELEMETRY
//#define RX_BAYANG_PROTOCOL_BLE_BEACON
//#define RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND

// *************Transmitter Type Selection
//#define USE_STOCK_TX
//#define USE_DEVO
#define USE_MULTI

So far its stuck in Binding mode and there is no information to what stick position i have to use to bind???. I have now re-flashed it back to stock which works. I think this needs a video tutorial as this is process is very unpredictable to say the least.

Cheers


#1264

A bit new to Flashing Silverware. Just got a betafpv lite board to replace the e011 board i destroyed when soldering battery plug in backwards. Anyway had this issue with the E011 and still have with betafpv board

I can’t seem to get it to go into LEVELMODE with toy tx. works fine in ACROMODE Using left, left, down for acro and it arms fine with rate button. But with Right,Right, Down the LED’s just start flashing and can’t get it to arm. Any help would be great.


#1265

Solved my own issue: didn’t see this originally in the code
// *************SPECIAL TEST MODE TO CHECK TRANSMITTER STICK THROWS
// *************This define will allow you to check if your radio is reaching 100% throws entering <RIGHT-RIGHT-DOWN> gesture
// ************* will disable throttle and will rapid blink the led when sticks are moved to 100% throws
// *************entering <LEFT-LEFT-DOWN> will return the quad to normal operation.
#define STICK_TRAVEL_CHECK

had to comment out#define STICK_TRAVEL_CHECK