NotFastEnuf E011 / Bwhoop Silverware Fork


#1227

Hi, there
I am flying my e011 with Jumper T8sg v2 plus.

For acro mode,
-In case of T8sg, Which mapping between Devo mapping and Multi mapping is right ?

  • Could you tell me how to compile the config. h for T8sg (Tx, Channel …ect)?

Tks vm


#1228

Jumper = Devo
Protocol = Bayang autobind & telemetry

jumper%202


#1229

Thank you vm for your reply.
I will try to flash and compile.
NFE Silverwere is for e011 flashing, isn’t it?


#1230

I flashed E011 with NFE_Siverware and compiled config.h as your saying
but I failed, only channel5 for arming, ch10 for led are ok. other channels not ok
after arming, if i up throutle, e011 is whirling.
what shall i do ?
how can i upload my config.h file for checking?
Thanks vm


#1231

Do with the right stick : DOWN UP DOWN wait for blink then save by doing DOWN DOWN DOWN and try again .


#1232

Thanks for your attention.
I will try.


#1233

I tried but failed ,same symptom goes on
With Down up down no blink, with down down down blink ok
Tks vm


#1234

Go into config.h and uncomment

#define INVERT_YAW_PID

if you’re gestures aren’t working. You may need to be on higher rates to get the gestures to work.


#1235

Does your jumper run deviation firmware? Or do you have the open tx version of the jumper. Should be a splash screen when it starts up that tells you. I’m sorry I’m not up to speed on my jumper model numbers to know for you so I figured I’d just ask. If It Says Deviation when you turn it on, then devo is the right setting for you. In that case you’ll make 3 changes to config. Define e011, define devo, and define bayang radio. Then compile and flash.


#1236

Thanks for your helping.
i will uncomment "define invert_yaw_pid.
i set my rate 600, 500 each, should i set higher than those?


#1237

Thanks for your attention’
my jumper runs deviation firmware. I made 3 changes. define E011, define Devo, and define bayang telemetry and autobind. then comfiled with Keil and flashed with STM32


#1238

no need to uncomment that. it is switchable via stick gesture. so first boot it will start in props out mode… but then you can do the stick gesture DOWN UP DOWN… it will blink once indicating a change to props in… then do the gesture DOWN DOWN DOWN to save. This way you can change your build up without reflashing in the future. I’d also suggest you fly the default settings/rates before changing them. If I thought there was a better option to progress your flying skills, it would be my default.


#1239

sweet, then just do the 2 stick gestures and you’ll be set!


#1240

Thanks for your help.
as i said , gesture DOWN UP DOWN did not work.
Then "uncomment ‘define invert-yaw pid’ with reflashing is best solution, is not it ?
and which rates are default ?
300/300 rate?
For the better works of Gesture, what shall i do?


#1241

yeah just uncomment it then.


#1242

I did flash my E011 sucessfully with uncommenting “define invert-yaw-pid” :grinning::grinning:
Thank all of you for helping.


#1243

Does anyone know, Can the E011/E011c board be used with a frysky SBUS micro receiver or does that only work on the alien zero boards? I have tried switching to the SBUS settings on my santa whoop board build and I can get it to bind to TX but it doesn’t seem to communicate with the FC. Before I keep trying at it, or try me E011 board I figured I should ask if I am barking up the wrong tree to begin with. I have the cheap multi module with internal PCB antenna and its range is terrible. I’d much rather run it with the Frsky fishpepper RX I picked up.


#1244

It works with all the boards. But your Issue is gonna be battery sag causing brownouts powered directly by lipo, or using the on board 2.8v regulated power in which case your rx may not work at all on a voltage that low. You may have to bypass the RX 5v to 3.3v regulator. Or use 5v buck.


#1245

The RX I have accepts 3.3v - 5v. I am actually currently powering it from the + pin on the header connector maybe that’s a bad idea. It does power up and connect to the TX & I get RSSI telemetry to my Qx7. After fighting it for a while I went back to the stock RX. I will have to try it again.

I’m using one of these: https://www.banggood.com/OpenSky-8CH-SUBS-Super-Micro-Compatible-Receiver-for-Frsky-X9D-Plus-p-1165368.html?rmmds=search&cur_warehouse=CN

Its got uninverted sbus, its apparently a clone of this: https://fishpepper.de/projects/usky/


#1246

Well that’s why you are failing to connect. Code is expecting inverted unless you go into rx_sbus and change the inversion variable to 0