NotFastEnuf E011 / Bwhoop Silverware Fork


#1084

Hi there !

@Ian444 : thanks, yes I’ve seen it. I don’t really know how to use it, I’m not under Mac OS.

@silver13 : If I understood well, you suggested me to use the boldclash’s makefile. I tried it and the only change is that after flashing, instead of the 5 blinks, it is now some funky blinking that I don’t know how to describe !

So I tried on an other computer, reinstalling the tools and git stuff… and same. As tetramonium (who posted on rcgroup about flashing under linux) made it on an older version than mine, it seems that mine (ubuntu 18.04.1) is not able to compile the same way that ubuntu 16.04 did.

So the way I made it to work is to set an ubuntu 16.04 liveusb and use it to flash the board. and that works great !!

Thank you Silver13 and others for your support until now.


#1085

If i wanna give a shot to DSMX , do i need to define sbus + dsmx 2048 since my dsmx rx is sbus ?

or Maybe i shouldnt talk about it but im so excited about it ! Delete if its not ok ! :slight_smile:


#1086

If the rx actually puts out sbus, then I’m pretty sure you’d set the firmware to sbus only. I’m really excited about the DSM2/X too, as NFE wrote some DSM2/X code to use with standard silverware firmwares as well, he did a really good job of it. I’m stoked that people who love the DSM/Spektrum gear can now fly silverware. I flew a quad yesterday with DSM2/NFE silverware and could not tell any difference at all due to the different rx. The DSM2 worked every bit as well as a stock XN297L rx.


#1087

Im currently using a lighter one 0.8g dsmx but no luck ! Everything is set , the orange led on the rx stay steady and the fc is pulsing cant get it to bind ! Im lost !

defined Dsmx 2048
and TX multi as Charlies said on discord but nothing and now i can’t reflash xD


#1088

What pin of the board (and what board) is your rx connected to? Another thing to try is DSM2 instead of DSMX.


#1089

Yes, I mentioned that to @tarkux also. The Betafpv rx outputs SBUS not DSMX.


#1090

Yea im not using the betafpv dsmx rx sbus , instead im using the one i linked above , all it does it steady orange light and fc is pulsing .

Rx signal to clk V to 3.3v pad and ground on ground classic .

Defined dsmx 2048
Tx multi

I wanted to flash again but no luck i know have like a 2 sec to connect it on gyro phase but no luck …thx i have a bunch of these fc . So dsmx tonight .


#1091

Sounds like the problem is your rx is not bound to your tx. Once that is done, it should be all good.

2 ways to do that, one is connect the rx to a BF FC and follow the instructions on the web page.

The other way is to use your silverware board but you have to first connect your rx signal line to pin 3 of the processor (possibly an LED depending on what board you have), bind the rx with your tx, then move the signal wire over to pin 20 (clk pad). That is how it’s supposed to work, I haven’t tried that yet as my 2 rx’s were previously bound to my tx.

If you still can’t bind try DSM2, sometimes they claim DSMX but it simply does not work, and DSM2 does (happened to me recently). Actually, just realised, this forum should have a heap of DSM experts on it, much more knowledgeable than me…


#1092

Lol, you’re pretty knowledgeable! I’m not sure what’s going on really. I can say this… I am using the exact same receiver and it is definitely dsmx. It will not do dsm2 correctly (I think) even though most are backwards compatible. I did try to make it connect to a beta lite at about 3am last night on my current repo … I had no luck either. Lmfao!!!. I developed all this on a breadboard formatted for the alienwhoop zero… and it works like a charm there. Ian I even tried a stock repo copy and that file I posted on rcg for stock silverware (with and without rx/TX swap) … no luck either. HA! So, there must be something simple I’m missing. Would you try loading a current copy of my repo on your test rig @Ian444 and report back?

@tarkux … we will get it sorted for the toy boards soon. Keep testing and trying stuff. I will too. It’s gotta be something in the way I’m handling pin assignment and port initialization on the toy boards. Cause at least we know the base code is good.


#1093

Just woke up and got to go to work, so will test for sure after work. There’s often a few glitches with new stuff, it all gets sorted eventually. Not a problem.


#1095

Hello NotFastEnuf and All,

After few day of struggle against my linux computer I’m now able to build and flash proper Silverware on my E011 board.
As you made some changes these days, I have both new and older version of the entire folder. And as you suggested in the first post I tried to do my work on config,h before to build and flash. But on previous version I’m able to fly angle, and with the new version I can bind but then leds blink fast until I put the throttle in middle position. Motors don’t spin until I do the gesture to switch to acro mode which seems to work. Is there something obvious that I forget to activate ?

As new to config.h I can say that your new organization and more over the explanation added inside the file helps me to understand both yours and standard version of config.h, making me more enthusiast and curious ! I would have many questions about what does what in pid.c but I don’t want to bother you.

And whow !! what hard it is to fly acro !!


#1096

Thanks Ian, I figure since you have a known good setup, it’s a good point of reference to if I have a mistake in my fork or not for the toy boards.


#1097

This is a confusing report. I have safeties in place that require throttle to be all the way down or it fast blinks if you try to arm. Curious that the safety is clearing mid stick for you. Also I don’t have a gesture to switch to acro, only a switch. I can’t say I am totally clear on which version you are flashing. You can disable the arming feature to disable safeties in my fork. That may help out in determining what’s going on. Maybe transmitter not scaled properly?


#1098

Just a quick lipo in the rain with todays Zer0 fork on an old H8, the original SilverWhoop board in fact.


#1099

My rx was already bound to my tx ! I did test them before same for the betafpv one which is sbus both work as intended . But with the toy fc betafpv lite there pin assignment that need to be sorted out . Ill just keep testing and see …and wait for nfe if he found the fix . :facepunch::sunglasses:


#1100

@tarkux - I just tested on a beta lite & I’m using the same RX that you pictured. It is working for me. I was testing last night however with no luck … but I was also soldered on to the 3v pad for power in the flashing pin header … and its not really 3v - its 2.8. That may not be enough voltage to run this RX. Tonight I started off with power for the sat coming direct from vbat and it linked up first try. It’s late now (3am), but tomorrow I will move the power feed back over to the pinheader and see if it stops working for confirmation the issue is voltage supply related. I have found DSM receivers particularly sensitive to voltage fluctuations. They brownout pretty easily… so 2.8v may be no good and I expect that fluctuations in vbat will be no good in the air either.

Fortunately the ZER0 has a nice 2 amp+ 5v buck feeding a true 3v3 … so its working like a charm there! We may have to get creative on the toy boards. But I can say for sure the code is working.


#1101

Thank so much for that feed back ! Ill try tomorrow too and ecer if doesnt work it doesnt really matter (for me ) at this point , i should receive my ZERO soon . But it would be if we could still use our toy grade fc for something and with a decent or real tx .

Thanks
Night !


#1102

Yep !

I figured out :
I did clone from your repo few hours ago and just modified config.h. The symptom was the same.
Then comparing with old config.h and trying different things, it ends up that your stick travel check is activated on start by using the “starting in level mode” option (AUX1_START_ON). Because of this, I was starting into calibrating mode and had to enter Left Left Dow to get out.

(I’ve see also that my stock tx doesn’t reach 100% throws on pitch/roll axes moving left, up, down).


#1103

With the very latest NFE firmware, it works fine on the H8 mini board on the bench (after I select DSM - the default is sbus and that caught me out!)

With standard silverware like B03 firmware, I’ve had it working reliably, then stop working. I was using the other rx_dsm.c file you posted in the H8 mini thread. Strangely enough, it started working when I uncommented the swap pin command, which is the opposite of what I originally did to get it working. I also added the dummy spi placeholders into the rx_dsm.c, which made it start working again, but they can be taken out and it still works. Overall, I’m a bit confused on that one, but will keep testing and see what I find.

The quad I actually flew with DSM had an E011 board in it, no issues with older NFE firmware from June 2, the DSM radio works really nicely. But the rx was getting too close to a prop and I could hear ticking noises so I put it back to the standard XN297 rx. Unfortunately time is short during the week so not much testing can be done.


#1104

With the DSM protocol selected, I tested the bind function of pin A3 to bind a Redcon DSM2 rx to a different tx, this worked well and was easier than using a BF/CF FC to bind the sat rx! On a H8 mini blue board, pin A3 is connected to Pin 1 of the XN297L radio chip, and soldering the rx signal wire to that leg for binding is not too difficult. Next I’ll do the same with a Lemon rx, then see how I go with E011 and B03 boards.