NotFastEnuf E011 / Bwhoop Silverware Fork


#1004

Thanks, now I know where to start.
After looking at Silvervise I think I will give the Bayang BLE telemetry a try so I can see where the numbers end up.


#1005


Here’s the top of the fc. Thanks.


#1006

It looks like that’s the first version of the board so it should be flashable.

How are you connecting the St-link to the pads? Are you using the pads on the bottom or the through holes at the top?


#1007

I was using the pads at the bottom of the board according to the https://www.youtube.com/watch?v=o7B5NWqc1B4 video.

Should I use the top ones?


#1008

Yes, give it a try, just make sure that there’s no shorts in between them. I can’t remember if the pads underneath are swapped


#1009

Yes they are, DAT and CLK pads are swapped on the bottom of the E011.

Silverxxx wrote an app that you run on a pc, it connects to the quad through the ST-link and retrieves the PID’s, very handy.
https://www.rcgroups.com/forums/showpost.php?p=39907343


#1010

I did it :smiley:

It flies great. I didn’t connect the +5v so I needed to connect battery to program it via usb.

Thanks for the help, it’s awesome :slight_smile:


#1011

I’m trying out the Silvervise app and though it communicates with the BLE App on the phone and displays all the info, it no longer binds to my TX. (RX_BAYANG_BLE_APP) I tried putting it into binding mode - but nothing… The moment I flash the old protocol RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND, it binds - but obviously no BLE support.

Anything I’m missing?


#1012

Shamefully I’ve never even tried cause I don’t think my phone supports the app. So I’ve never looked into it. I think maybe you are supposed to define them both? Forgive me if that’s a terrible answer. Here is a better one … start with the silverware wiki. There are clear instructions there on what is supposed to happen and how to use it.


#1013

Of course I tried that first :slight_smile: but my above post is how far I got after scouring the wiki. Oh well, maybe someone else has something to try :slight_smile:

UPDATE: It won’t autobind but at least it binds now…yippy!


#1014

Are you using a Devo? If so, turn off the telemetry option under bayang protocol bind. Not sure if it’s the same with other tx but turn off telemetry options for Bayang to see if it helps.

Autobind isn’t written into the BLE code.


#1015

autobind is only working with the standard protocol at this time, but the problem would have been telemetry being on


#1016

Thank you both @yets and @silver13! I’ll check it out in a bit.

This place Rocks!!!


#1017

PID_VOLTAGE_COMPENSATION oscillations are fixed ?


#1018

Yeah I think it’s running pretty well.


#1019

ok Im going to flash it.

what’s new?
I think only this MIX_THROTTLE_INCREASE_MAX 1.0f


#1020

Not too much, I moved that back down to .2f. I liked what it did at 1.0 on very clean setups, but any noise freaked it out and more noise is common on NOT whoop type builds so it was causing issues there.

Mostly the ability to tweak setpoint weight and transition on each axis individually and on 2 profiles.


#1021

Thank you very much for the summary, I’ve always used it in .2f I’m going to try it in 1.0f 6x15 brushed 19500


#1022

Hey guys. I was kinda out of the loop for a few months. What did I miss? :sweat_smile:


#1023

not bad but I have oscillations, i’m going to try again MIX_THROTTLE_INCREASE_MAX 1.0f without PID_VOLTAGE_COMPENSATION