NotFastEnuf E011 / Bwhoop Silverware Fork


Thanks, now I know where to start.
After looking at Silvervise I think I will give the Bayang BLE telemetry a try so I can see where the numbers end up.


Here’s the top of the fc. Thanks.


It looks like that’s the first version of the board so it should be flashable.

How are you connecting the St-link to the pads? Are you using the pads on the bottom or the through holes at the top?


I was using the pads at the bottom of the board according to the video.

Should I use the top ones?


Yes, give it a try, just make sure that there’s no shorts in between them. I can’t remember if the pads underneath are swapped


Yes they are, DAT and CLK pads are swapped on the bottom of the E011.

Silverxxx wrote an app that you run on a pc, it connects to the quad through the ST-link and retrieves the PID’s, very handy.


I did it :smiley:

It flies great. I didn’t connect the +5v so I needed to connect battery to program it via usb.

Thanks for the help, it’s awesome :slight_smile:


I’m trying out the Silvervise app and though it communicates with the BLE App on the phone and displays all the info, it no longer binds to my TX. (RX_BAYANG_BLE_APP) I tried putting it into binding mode - but nothing… The moment I flash the old protocol RX_BAYANG_PROTOCOL_TELEMETRY_AUTOBIND, it binds - but obviously no BLE support.

Anything I’m missing?


Shamefully I’ve never even tried cause I don’t think my phone supports the app. So I’ve never looked into it. I think maybe you are supposed to define them both? Forgive me if that’s a terrible answer. Here is a better one … start with the silverware wiki. There are clear instructions there on what is supposed to happen and how to use it.


Of course I tried that first :slight_smile: but my above post is how far I got after scouring the wiki. Oh well, maybe someone else has something to try :slight_smile:

UPDATE: It won’t autobind but at least it binds now…yippy!


Are you using a Devo? If so, turn off the telemetry option under bayang protocol bind. Not sure if it’s the same with other tx but turn off telemetry options for Bayang to see if it helps.

Autobind isn’t written into the BLE code.


autobind is only working with the standard protocol at this time, but the problem would have been telemetry being on


Thank you both @yets and @silver13! I’ll check it out in a bit.

This place Rocks!!!


PID_VOLTAGE_COMPENSATION oscillations are fixed ?


Yeah I think it’s running pretty well.


ok Im going to flash it.

what’s new?
I think only this MIX_THROTTLE_INCREASE_MAX 1.0f


Not too much, I moved that back down to .2f. I liked what it did at 1.0 on very clean setups, but any noise freaked it out and more noise is common on NOT whoop type builds so it was causing issues there.

Mostly the ability to tweak setpoint weight and transition on each axis individually and on 2 profiles.


Thank you very much for the summary, I’ve always used it in .2f I’m going to try it in 1.0f 6x15 brushed 19500


Hey guys. I was kinda out of the loop for a few months. What did I miss? :sweat_smile:


not bad but I have oscillations, i’m going to try again MIX_THROTTLE_INCREASE_MAX 1.0f without PID_VOLTAGE_COMPENSATION