NotFastEnuf E011 / Bwhoop Silverware Fork


#864

Thanks i will give it a try


#865

I can’t use anything other than the the third option since updating to 5.25. I might need to reinstall Keil.

Ha, wish I could do any of those at the moment, currently can only fly a few packs a day in my street as too busy and the whoop causes little damage when I crash into cars :sweat_smile: LOS has taken a massive backseat, at least my FPV skills have marginally improved


#866

Hello all, I’m getting an error when i attempt to flash my e011 as well, older versions flash fine.


This is the error i get.
I managed to flash the bwhoop.axf file using the stlink utility instead and seems to be working just fine. I think my keil is 5.23.


#867

Upgrade your keil to the latest… should flash fine then. And keep us posted. Nice to know @yets isn’t going crazy!


#868

I think it could be the uvguix and upvoix (or whatever is called) files that were on the commits that could be the problem. I think they’re tied to the individual that makes the changes and relates to their Keil system and config/layouts. Maybe there’s conflicts because your layout/targets are different. Pure speculation and guess here but those files do include Keil settings and layout data


#869

I’ve been running the latest code and a few times while flying, I drop the throttle stick completely and my E011/Beta65s Lite keeps going up for another second or two (like full throttle is sticking for a bit). It surprised me a freaked me out a bit :- ) It doesn’t always happen - I haven’t figured out the exact trigger.

Could that be the STRONG to WEAK filtering change?


#870

No… filtering can affect throttle responsiveness but not like that I wouldn’t think. Try weak filtering and see though. When I get stick inputs that start to stick … I swap out the crystal. Usually that’s the cause.


#871

Could be… but what do we do about that… plus you have no way to test now that you’ve upgraded. We could grab my old ones out of whooverware. When I had issues getting blheli pass through to work… I grabbed those files off your fork.


#872

Download one of your forks before that commit and transfer those files to a test zip or straight to your fork. See if that works.


#873

Well the funny thing is… I didn’t even know I had a problem till I tried to turn on pass through. That’s when I discovered your files fixed it. I’ll go test some of my old ones. Unfortunately my silverlite fc has gyro issues so my tests will be limited. Not really sure how to know if I’ve fixed the problem or not at this point.


#874

Ha, the weird thing is that I can’t get pass through to work on a few of my ESCs using my own code! It’s strange all this stuff, probably a simple fix really.

Had the gyro died? I’m sure you’ve already done it but the pins aren’t shorted are they? Multimeter check etc…


#875

I just reflowed it and I’m good now. Whew! I was probing the programming pins and they are right by the gyro. Had been struggling to keep a good connection so I was tweaking my pinheader at an angle with some pressure after inserting it during flash stressing the board a bit I guess. Probably cracked a solder joint. Earlier today I had to reflow a dsmx receiver that had its board stressed in a tight installation. It’s crazy how fragile things can be sometimes and how everything we “trust” is always just hanging on by such a thing thread.


#876

Chips without legs are much more susceptible to flexing stress, it’s always gyros and rx chips that give problems. I’ve soldered a servo socket extension to both my brushless boards to save having to fiddle with angles when flashing regularly. My theory is that once I’m happy I’ll stop flashing! Who am I kidding? :grinning:


#877

Had exact same problem yesterday , tried different filter , reflashed couple time , checked my softmounting , disabled Vbat compensation ( NFE ask) ,blades and such . After couple pack ive found it was my props … but still , im still getting this problem you’re mentionning but less and managable …to compare i took my butter one and my butter Whoop was butter ( too much butter sorry ) . Then cameback to my silverone and didnt have the same feeling . Later i did try again my old TBS fat blade on another random whoop and they were perfect … so still dont know exactly whats going one .

@brianquad Let me know if you find out ! maverick-holding-goose-in-water-after-flat-spin-2


#878

The other major firmwares have insane filtering… you can fly OK with totally bent props. I do not run all that filtering in silverware… that’s one of the reasons why when you have good equipment it flies so much better. So if you bend a prop in NFE silverware … you’ll know it right away.

Still I’m confused by what you guys are describing… I have piles of NFE whoops and they all drop rpm the instant I lower throttle after a punch. Can you make a video that shows this behavior well? I’d love to see it. It really sounds more like a temporary loss of rx signal. The crystals on these toy boards are put in the worst location right under where you’d put a camera. And the radio chip is right under the camera too and easy to short out temporarily if it contacts.

I always relocate crystal and antenna to the bottom of an e011 style board. And insulate below the camera. Pay attention if any of your other controls are sticking at the same time.


#879

Thanks for the feedback ,

Tonight after work , ill take picture from my setup under the hood and then do a short clip about the problem and if possible with sound so you can get a better feeling .


#880

Yeah, that’s what I’m used to, and why this surprised me! It has only happened a few times so far and I didn’t keep track of which of my two quads it was (or if both). I’ll try to pay attention and see if I can make it happen and video it.

I’ve had some hard crashes recently, and could certainly have damaged the crystal at some point. If so, I would think only one of my quads should be having this problem, so I’ll keep any eye out. I can steal the crystal from my toy TX after I figure out which quad it is.

Thanks for the tips!


#881

Finally found the problem tonight while streaming , it was propellers tried different one until i decided to took out the one i had on my butter whoop and boom , it was just perfect !

As NFE said , its so well tuned that with a tiny bad unbalanced shit could just screw the whole build .

Now im ready to push the limit of this shiny NFE firmware and tune !


#882

I’m not sure we are talking about the same issue, but I do have some pretty beat-up props. I bought some replacements off eBay, but when swapped one set in, my quad went nuts on the ground. I put the old chewed-up props back on and it was fine again.

How do you tell if a prop this size is good/balanced? I have a Balancer for full-size props, but… Can you balance these tiny props? Or do people just swap them until things are flying well?


#883

Props in the wrong spots maybe?