NotFastEnuf E011 / Bwhoop Silverware Fork


#844

Double check your file you flashed and let me know if it’s on strong filtering or weak filtering.

I keep bouncing back and fourth on what I think the best default is. In the last say or two I changed it back to weak filtering since my current 7mm was smoother on that, but I’ve hade some in the past that did better on strong filtering too. That’s the most likely cause. By changing the filtering we may break up or move a little resonance that’s causing your throttle to be jumpy right at your hover point. To be honest … I don’t really hover so I don’t pay much attention … I could run throttle on a switch :smile:


#845

Hi guys, want to ask, i’m planning to add additional LED in front side of whoop, so it can fly in dark place or night time. I want to activate the LED through the channel that already available in the NFE version. But i’m bit confuse where i have to solder the led? The negative off course to GND but for the positive wire, where i have to solder it so it can be activated through channel like stock led.

Thanks


#846

Well this sort of depends on your led… I’d have to check a spec sheet but you really only want to route so much power through a pin on your mcu… either as a source of switched power or ground. So if your led setup is current hungry enough … you could pop a f0. Alternatively, you could open and close a mosfet with mcu pin and that would provide protection… like using a switching relay. The only pins on the toy boards we are given access to are the programming pins. Which is fine… you can use those too with the right edits but then only have a 2 second window to flash your board after you plug in a battery.

What board are you using and what is the current consumption of your led?


#847

@NotFastEnuf Got a weird one here, can’t flash your newest version to my E011. I’m met with Error : flash download failed - “Cortex M0”. Downloading earlier version works fine, doing it side by side and everything else I have. Have you updated Keil recently? I’m still running 5.22, maybe that’s an issue? It won’t even let me check out debug to look at the STLink to see file size. Had to download the hex. Weird.


#848

Ahhahahahha !

NFE - “Double check your file you flashed and let me know if it’s on strong filtering or weak filtering

filterSTRONG


#849

Try weak filtering


#850

I get that message if I lose connection mid flash… usually due to a fatigued wire in my flashing harness. I will grab an E011 and check tonight. Are other targets flashing fine for you?


#851

Ok Thanks ! Will do and see ^^


#852

Works fine back to back, literally I have two separate Keil’s up, same target, one of your earlier builds and your latest. Flash earlier fine. immediately flash newer one, refuses to flash. Will try another quad

edit: Just tried a Bwhoop board, same problem


#853

@yets… I just downloaded a fresh zip file off github … flashed 2 different e011, a betafpv lite, and @Ian444’s silvetlite.

Try deleting the .uvguix file & uvoptx file then reopening the project. Try a restart on your pc where you go to the new project first. Try a fresh download. There were quite a few changes from the main silverware repo I recently merged including changes to the make file and other stuff I don’t usually edit in files that I don’t really understand- some of them were gcc related. But all seems to be working well on my end. You could always zip up that project and email it to me so I can try it on my pc too.


#854

Weak Fixed it ! …not sure but feel like they are less punchy … might be my BEERS effect ( natural expo) but throttle is easier to control . Thanks


#855

I’m updating Keil so we’ll see if it works. Wonder if anybody else on 5.22 is having an issue?


#856

I’ve noticed the new version seems to identify our target under a different part number stm32f0305 (I think) … which may be related to bypassing the stlink error. Idk… possible I imagined that too. Guess we should just wait and see what reports cone in. Did you try deleting those to files and letting keil rebuild them? Or are you just going straight to the update? Maybe I should clear them out again myself and let keil rebuild them fresh… then push that up to the repo…


#857

I deleted the files and didn’t seem to work. Gave me a new error completely.


#858

Strange I can delete them and they just get built back fresh. I think @tarkux is flashing and tweaking settings right now too. … not sure if it’s a current download or not. Let’s see if he can check in.
@tarkux… paging @tarkux… lol. Is a fresh download flashing fine for you right now?

@yets. Try replacing the makefile in the gcc folder with the one from the old version. Maybe this is a gcc issue. Did you get keil updated yet?


#859

Seems to work with 5.25. Strange. Which compiler are using in Target options?

5.25 feels strange, it automatically starts with a warning!


#860

Default compiler version 5


#861

04 ! all fixed , im flying a MIG 21 now ! it was a mechanical problem , TBS clone / TBS fat blades was doing a horrible job and a lot of vibration …after checking my softmounting and make sure no noise could occur randomly i finally decided to swap my props with some brand new oldschool EACHINE ! problem fixed right away now i just need to change filtering for Weak as NFE told me for more JUICY ! and put Throttle on a Switch ! Boom !


#862

709 build? In the drop down, the third option?

On another note, did you ever figure out a solution for whoop blowouts? My E011 is notorious for it


#863

Untitled

No solutions to blowouts in corners on stock equiptment. Pump the throttle to prevent it. Its a characteristic of the limits of a clipping mixer I think and only shows up on a whoop frame. BF is a scaling mixer and doesn’t do this but has a whole host of other bad habits that result in addition to really low power in comparison.

Only solutions I have found are 3d printed frames with a duct height of no more than 5.5mm. Cut the ducts off. “Props Out” helps some. Very high stick_accelerator values will help push it back in place quicker but don’t stop it. FLy a boss instead of a whoop. And moar power … 2s!!