NotFastEnuf E011 / Bwhoop Silverware Fork


#764

Might have just fixed the issue with pid voltage compensation… fingers crossed for tonight’s test flights!

I really want that to work and to move on to our new features!!!


#765

Since having my “sloppy racemode” issues on the version from about a week ago, I flashed the latest version and turned off pid voltage compensation. I’m happy to report that I’m back to loving life. I was even sailing smooth with a 200mw tx in tow. Thanks!

Edit: I spoke too soon but I think I’ve narrowed the problem down a bit. I switched from horizon/racemode to acro for a battery. When I switched back to horizon/racemode it was sloppy again. I never had this issue before flashing about a week ago.


#766

yess me too!


#767

glad your whoops are ripping again @DonnieH801 & @Whoopingtits!!

PID_VOLTAGE_COMPENSATION is fixed now too!!! You two may want to reflash while you have your STLINKs out. LOL :wink:

I made a couple other minor changes but it’s late and I’ll fill you all in later!! Go enjoy PID VOLTAGE COMPENSATION!!!


#768

Is there a way to make rates function to change pitch and roll rates only? I like to keep my yaw rate the same when activating low rate


#769

I just had to flash about 5 times before I got a good flash with all of the modes working properly again. I seem to lose the level modes after a while requiring another flash. It doesn’t quite slip to full acro but it gets very sloppy drifting in the direction I was going rather than auto adjusting the angles when I yaw. I never had this problem on my H801 only on this Pro. I also didn’t have this problem before I flashed about a week ago. Is anyone else seeing this?


#770

What steps can I follow to try to replicate the problem? Also… whats an 801 and a pro? LOL

I’m testing stuff right now … so I can try to jump right on it.


#771

Furibee H801 does not have the Pro board. It has altitude hold. I’ll troubleshoot on my end as well. I’ll set up another H801 to see if I can replicate the problem on it. Weird.


#772

While you’re at it @DonnieH801 - make an edit to the code on your problem board just as a fun test…

Open main.c and find lines 296 and 299
before

Then comment out just those two lines to look like this with the //…
after

Test again and report…

This change would not fix you slipping out of level mode while it is flying fine … but it turns on the accelerometer when you go into level mode instead of having it on all the time. If you turn it on while not exactly level … it could take a second to clear that error and feel weird…
Maybe it’s not at all what you are experiencing but it’s worth a shot.

Also not weird to have a problem right now… I am changing things almost daily which does not lend to very stable firmware… I promise I am almost done and have it just how I want it very soon. Then it will just be minor cleanup from there… but nothing that will break the firmware…
Actually hope to push in my last major change late tonight.


#773

hi guys i just got a flyskyi6 tx with multiprotocol module. i got it to bind but cant figure out how to setup my arm button


#774

Is it that you are switching your aux 5 and it’s not arming, or do you not know how to set up your aux 5?


#775

like to know how i can set up the switch on my flysky to arm and setup for flight modes


#776

i had arm button on channel 7 on my stock bwhoop tx before.


#777

Gotcha… I can’t be of much help there…I’m on a devo. Maybe search this thread for any mention of your radio type and start tagging dudes!


#778

do i need to select define use multi tx in config.h?


#779

Probably yes… depends on your specific multimodule. if the channels don’t line up then select use_devo


#780

Tried the code changes but same results. Seems like racemode is broken for me.


#781

Which racemode… angle, horizon … or both?
EDIT: hang on a second … I just looked back at your issue. It seems you accumulate a drift off to one side after flying for a bit… that sounds like a vibration issue throwing off the accelerometer. Is this a whoop?


#782

Angle and Horizon both pitch forward constantly. Racemode roll will not auto adjust when I turn using yaw. Yes, Bwhoop-B03 Pro. Racemode will continue to drift in whatever direction I start out at. When it worked on this whoop I could basically give it a little pitch and then steer with yaw when in racemode.


#783

Yeah …when it worked for you - that’s the way it is supposed to work. What you are describing now sounds like acro mode. Are you sure it is even switching into racemode? Channel 6 + 7 or 6 + 7 + 8 all on together?

I’m testing recent builds on 3 different targets and all is working fine on my end.

Only other thing I can think of is a bad vibration that is throwing off the accelerometer. Pinch your motor cans and blow on the props to spool them up. Check for vibes that way. Also look out for a hot motor maybe after flying.

I don’t think its software. That leaves a gyro acceleromter problem, a mechanical issue like a motor or prop, or the off chance that you are not throwing your switches right or you need to check the use_multi / use_devo define for proper channel mapping of aux switches.