Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


on your new tune it feels too drifty. on level mode the rolls and pitch takes longer to level back in place… i kinda got used to the fast and tight pitch and roll leveling and miss it.what changes do i need to make in order to have it fast and tight on the leveling?


Open angle pids and select the high leveling strength options for p and d. I changed defaults to my personal preference but saved the high strength stuff that you guys liked there behind a //comment. :smile:


ty i found it! ty for all the information, im slowly getting it and finally get to tune my whoops!


with my 8.5mm build i finally got it not to shoot into the ceiling… but throttle control is very hard… im have very hard time to get it hovering in same level. how do i go about tunning this? do i go to pwm freq?



I’ve got problem with throttle control. As soon as I start moving throttle up at early stage it throttles up motors all the way up and there is no throttle control. I can only get motors off or full throttle. I’ve got E011 with Taranis 9XD with multiprotocol module, and compiled FW with gcc under linux. Ive tried to play with filtering etc but nothing seems to work. Any ideas what I can test ?. Ive commented out arm / idle up settings.


Please comment out //MIX_THROTTLE_INCREASE_MAX 1.0f with the two // in front. That line of code gives 100% authority over throttle to airmode and only seems to work on tiny whoop 31mm propellers.
If you can, report back if that is the solution.


@Whoopingtits, which pid set are you using? What other changes have you made from defaults? I’m assuming MIX_THROTTLE_INCREASE_MAX 1.0f is commented out and you have changed filtering to very strong?


That seems to fix it, thanks for fast reply ! :smiley:


Excellent glad to hear it. What were the details of the craft you are flying that did not like this setting?


@NotFastEnuf, have you tried Joelucids/Markus Gritsch’s Transient windup protection yet? Stops bounce back after rolls and flips. If I could learn how to do pull requests on a different branch I’d pull it your branch.


using the 8.5mm boss pid. im also using hv lipos

// *************makes throttle feel more poppy - can intensify small throttle imbalances visible in FPV if factor is set too high

// *************throttle angle compensation in level mode

// *************mix lower throttle reduces thrust imbalances by reducing throttle proportionally to the adjustable reduction percent
// *************mix increase throttle increases the authority of the pid controller at lowest throttle values like airmode when combined with idle up
// *************mix3 has a stronger effect and works better with brushless

//Currently eperimenting with the value below for whoop format. Default was previously .2f and should be
//changed back for anything other than a whoop. This gives “airmode” 100% authority over throttle


I think you should uncomment


That’s probably adding even more mix_increase_throttle. You should just need to run one which is #define MIX_INCREASE_THROTTLE_3



I agree with yets. You have duplicate features enabled which both increase throttle. Make sure you are on very strong filtering too.

@yets I have not tried Joe’s new transient windup protection but I was up late last night shoving everything I have missed since I forked into my local copy. After I test it out to make sure I didn’t break anything in the process, I’ll be pushing all the changes up. The wind up protection is in that commit. Do you really think it helps??? I have not seen bounce back on anything I own for it to fix. But I fly mostly fpv and I’m not flipping or rolling all the way across the horizon line of sight. I know transitioning from right side up to upside down can drive the I term nuts as its value has to change signs with every rotation. Maybe this is something that is more obvious in that application? Anyway no reason not to add it. Joe’s stuff is most usually gold!


I’ve tested stock E011 without any fpv gear. Problem seems to be only in level mode. Acro flights great.


@notfastenuf I’ve not tried it myself as I’ve only just pushed it to the brushless fork. I can see it being beneficial for brushless, LOS and running low PIDs but I don’t see any harm in you adding it to your fork.


I’ll try to replicate that as soon as I can. Mostly I have focused on fpv. Try to tape a small coin to it to simulate camera weight and see if it improves.


I bet it’s a vibration. Either as @NotFastEnuf said, Stronger filtering or you have a major vibration issue - props, motor shafts or FC rubbing against frame or canopy.

The tune is solid and I don’t fly Whoops.

I’ve had the same exact issue and it usually was an unbalanced prop.


Idk, some setting are incorrect for sure… with two mix increase features activated… but line of sight it is still one very powerful craft without camera weight. He may need a throttle curve in his TX… or to stop hovering … lean it forward … peg the throttle … and RIP till you puff those batteries! !! Hahaha


Ok my beta testing crew… I’ve got some stuff for you! I just pushed a major commit that included all the updates that I’ve missed in the main silverware branch. I’m only human so test with caution. Joelucid’s transient windup protection is also in.


Gee! The day doesn’t have enough hours to test all the work you do! :joy:

Seriously though, thank you. It’s an exciting time for brushed micros.