NotFastEnuf E011 / Bwhoop Silverware Fork


#604

Thanks! I’ll try to replicate that!
@brianquad - was arming feature enabled also?


#605

Yes, I had Arm assigned to a separate switch from Idle Up.

It didn’t seem to matter which I turned on first - Arm or Idle Up - my quad started to jump off the ground a bit after a few seconds when they were both on. The throttle safety feature was still working - I had to lower the throttle before Arm would work.


#606

Thanks. I did some testing tonight. I’ll have to test again to replicate separate arm and idle up.

With them linked, if definitely is squashing mix increase before takeoff. BUT, it is still idling a lot higher than acro mode. I calibrated the accelerometer and it helped settle it down a good bit. It’s loading up with error. I may need to subdue integral on the ground. I term windup is what I encountered. I’ll test separate arm and idle up and see if it’s the same situation or if mix increase is really active and report back. Thank you.

Also, this has pushed me to fly level mode for the first time ever. ROFL… why didn’t you guys tell me it feels like crap. I tuned it now for racing. I’ll update the settings soon. It’s fast now. Really fast. Curious to see what you guys will think after I update it.


#607

Separate Idle_up (aux6) and Arming (aux5) work perfectly and so do the safeties.
As long as the quad is disarmed, nothing happens
Quad armed but throttle is not at 0% = Flashing Leds until throttle is at 0
Quad armed with Idle_up enabled but throttle is not at 0% = Flashing Leds until throttle is at 0

Once the throttle is at 0%, everything engages as usual.

I did not notice any weird scenarios other than, after bumping on a wall and landing props down, it went more nuts than usual. Disarming took care of it.


#608

I tried an accelerometer calibration just now (Down Down Down, right?). That didn’t seem to help mine at all. With Level/Horizon mode enabled, it winds up the motors a lot higher while sitting on the ground than Acro mode. It sometimes starts to lift one side of the quad off the ground a bit. After it is wound up, switching the Level mode channel off to get back to Acro does not slow down the motors - they stay wound up.

So maybe it’s not mix increase, but just accumulating error. It just happens faster when the level mode channel is on.


#609

Yeah … that’s to be expected with mix increase have 100% authority now. Cool - good report!

@brianquad - yes I observe the exact same thing. I just tested split arm idle up like yours and it is not the mix increase feature doing this. It is just an accumulation of integral (error) on the ground. You can go down in config.h … way down below all the stuff we usually change and there is a line there for enable throttle minimum. For now comment out that line. That helps it get a little lower but the condition is still present. While you’re down in config.h in the lower section … change your level mode max rate down from 360 deg/s to somewhere in the 220 to 240 range. Also change your max angle down to 65. Finally open angle pids document and lower angle p to 5. These are the settings I’m flying now with all other values at defaults and they are soooooo much more locked in for racing.

Just a note on silverware angle mode. Remember yaw rotates around the gravity vector not the z axis like betaflight. So go light on the roll input and heavy on the yaw input to steer. You really only need yaw. It’s quite something.

I’ll work on some code to squash the integral windup on the ground. That will help angle mode


#610

I’ve sorted out the crazy idle thing in angle mode. It was indeed integral windup. I’ll update the code by tomorrow night with the fix. I just need to determine where I want to apply the fix.
Angle mode … obviously
Acro mode … I don’t think so - I like the ability to stage it up on its nose for a launch … and squashing integral eliminates that. Plus props aren’t going nuts.
Race modes … this is the one I’m not sure about. I need to test this further tomorrow. I’d like the ability to stage up (tilt forward on pitch) and have it hold the tilt. But I’m not sure if it’s revving to high to make this a useful thing - cause it is half angle mode.

Also, I still don’t know what to do about the min_motor_enable feature. Part of me thinks it feels better in the air with it on. Especially in turbulent air outside. Prevents prop stall events which usually present as a yaw blowout. Part of me feels like flips and rolls aren’t as crisp and lose a little more altitude cause it can’t spin the props all the way down. I’m torn and need to really scrutinize this one more.

Any suggestions?


#611

Hey guys, I posted a video on my YT on installing this awesome firmware… I am LOVING it!.. Video’s of whoopin’ coming soon!.

Sorry its so long, but I welcome your feedback!

Thanks!


#612

@FPVClub Nice video!

Did you have a look at my tools? :wink:
https://simonernst.com/silverware/


#613

Here is a sneak peek for you guys of flying last night at 3am in the garage to tune angle mode.

You guys know I’ve basically never flown angle mode and as non angle mode pilot - I never tuned it before. But pat yourselves on the back - cause you finally encouraged me to try it as a result of testing features and interacting here to make the fork better. So anyway, after testing the high idle when arming last night - I flew it and as expected - I just hated angle mode. No way I could get down in the “trenches” in my garage. So I FINALLY tuned angle mode at the expense of a few lost hours of sleep. Lol.

Obviously DVR from 3am hasn’t been edited yet so after I catch up on rest I will edit it a little more, add some music, and then make it a public video. But you guys get to see the unlisted raw footage right away!

Angle mode feels so much better now and I can actually rip it without feeling like it throws me off my game. I will update all these new settings into the fork today and keep you posted on when you can try it out. The high idle in angle will be fixed at the same time. Get your stlinks ready boys… you’re gonna want to try these changes :smile:

https://youtu.be/k46cXhcSwKQ


#614

I agree that you don’t need to squash the integral windup in Acro mode. It acts as I expect in that mode. I haven’t played with the Race modes yet, so I’m not sure on those. Angle and Horizon mode for sure, though.

What is the difference between MIN_MOTOR_ENABLE and IDLE_UP? They sound similar - like both are used to keep the motors from ever spinning down all the way to zero. They must be different, though…


#615

That’s looking pretty nice, I’m going to have to update my fleet!

Should probably whoop the ceiling fans.


#616

True story … my first alienwhoop zer0 build - I took off and it had so much punch I went right into the fan. I’ve never “Denoviched” a whoop before - that was a first for me. It broke my roach.

@brianquad - motor min is an absolute limit which motors will never spin below no matter what the circumstances. Nothing more. Idle up sets a baseline for lowest rc throttle position which keeps the pid controller active for stabilization. The pid controller can spin motors both above and below the idle up value. When you combine the two … the pid controller cannot spin motors down below min… but it can raise them above it.


#617

Lol! See I meant go over the fan, not plow into it.
It’s hard due to the air movement, but fun. Of course, that was the end of one of my frames though.

Denoviching a whoop is a good trick.


#618

Ah, so Idle Up is for the throttle value and motor_min_enable is for the individual motors.

But (after looking through the code) it appears that the motor_min_value is only in effect if the sticks are active (or failsafe, etc.), which is why the motor_min_value is not active while the quad is on the ground or during maneuvers.

Thanks!!


#619

What happened to Denovich? He had a lot of great input on small quads?


#620

He’s still around, mostly just in the mmw discord chat.


#621

Actually, when you idle up with motor min off, the pid controller can and does actually spin down some motors to a dead stop. Same thing can happen in the air if the pid controller wants to spin down a motor. With motor min enabled they can never be lowered below that min by the pid controller.

I’m making some changes today … probably flashed and test flew 100 times. Will update everyone when it’s ready and explain what I’ve done.


#622

New update is pushed up. Changes are as follows:

Integral term is now squashed while on the ground before takeoff to prevent windup in angle and horizon mode only

Config.h has a new layout for filters. You now select weak, strong, or very strong and all the filter values will self populate from that define. Should make it easier to match the right filters to pre-set pid selections.

Angle mode is tuned for whoops. It feels freaking awesome. Race mode angle and race mode horizon reaped the rewards of that tuning too so they also feel better. Standard horizon mode feels a little loose to me. Idk … I think it needs more expo than regular angle

IMPORTANT NOTE - If you fly a boss or any other non whoop format on silverware - I’m not sure I suggest leaving the mix_throttle_increase_max 1.0f line defined. It may be too much airmode authority for bigger props. Symptom will be a desire to fly away. If that happens … just comment that line out for now. I will revisit boss tunes soon to see if i can make it work with that setting on.


#623

I love you fw with racemode and arming. Here i got 10ch flysky tx, but i can’t use ch7 to ch10 on the fw settup… I only can use ch5 and ch6.
Can you give me some solution about this, oh i use nrf24l01 multiprotocol diy. Thank you