NotFastEnuf E011 / Bwhoop Silverware Fork


#584

Lack of sleep here too! Understood completely :smile:

So there is no way to undefine the throttle and binding safeties unless you disable the arming feature completely. However, if you do undefine arming feature but define idle up feature to a switch … the mix throttle increase safety is still active for the first takeoff event only. After that it’s on all the time. We could put the mix increase safety on a feature define easily enough … but again I’m not sure safety features should be able to be turned off. I personally want to eliminate the arming define and just require proper arm and disarm practices… lol

Edit: actually behavior of mix increase may be getting a little screwy if idle up and arming are used seperately. I’ll look into it more today.
Lack of sleep thing!!!


#585

Most of the multiprotocol modules that go in a taranis (or other non devo) use a different auxiliary channel mapping order. In the receiver section, comment out use_devo and uncomment use_multi. That will change the aux channel mapping order to match your module. If you have already done that prior to this post, then maybe you have the module that matches the devo mapping and you need to switch it back to use_devo.


#586

Can this Airmode be put on an Aux or commented out? I hate bouncy bouncy during landing landing.
I would like to see a couple of flavors of these builds. In particular, an ACRO only, balls to the wall no safety features, the NFE original config, and the latest “Safety belt edition”…

Since these brushed builds never exceed 130mm or 50grams, I’m really not all that concerned with safety. I could see implementing or hardwiring these safety features into +3", +2s brushless cuisenarts .

To me, the beauty of SW is the simplicity and function without the BF/CF bloat.

BTW, can’t wait to try it! Great job!


#587

Personally, I don’t intend to use the safety features as I use my tx for safety etc, plus I don’t use the arming channels, once again using my tx for that. Just hoping that mix_increase can still be used whatever the case, with or without safety features.

Some of the veteran users of Silverware or users who use their TXs may want to control it tx side as it’s ingrained that way? Is it worth continuing as it is and giving the option?

I’m trying to keep my fork as close as yours so if anybody did want to move on to brushless it’ll still be familiar


#588

I sorted out the last issue mix throttle increase and will update the code in a few minutes.

@yets - all throttle and arm switch related safeties are linked to the arming feature. The mix increase safety is tied to idle up. If you are commenting out the arming feature and the idle up feature because you prefer to do these things in your transmitter - everything will function exactly as it did before. Moreover, even if you are not disabling these features - nothing is going to conflict with logical safe practices. Just give me an hour or 2 to slide in the last tidbit of code. I will alert here when done. Let me know if you can describe a specific scenario or setup that you think these changes will interfere with.

@chime13 - what procedure do you follow when you land? This is a case of have your cake and eat it too. If you want mix increase to have the authority it needs to keep your quad totally locked in throttle off dives … it’s also gonna cause bouncing on the ground if you’re trying spin props while being on the ground. Avoiding that is exactly what this safety is all about. Either toggle off idle up before you land OR disarm on landing. This is no different than before. What’s new is that now before you take back off - mix increase will know to stay inactive until you get in the air. The issue of wanoting mix increase to know you’re in the air vs on the ground was a non-issue before because we were only using mix increase for 20% of its ability to stabilize. So in order for me to get 100% out of it - it needed a bit of self control when on the ground. None of this. Is going to affect what happens when you’re in the air - in fact it gives you to option to crank up mix increase strength ad I have done and still have a well behaved quad both on the ground and in the air. Thereven will be no need to turn that off. Should you so desire- you can always turn mix increase strength back down to 20%. At that level you won’t even know my safety feature is doing anything.


#589

I keep arm and idle up on different switches. I’ll be flashing the latest build tonight. Is there anything in particular that you’d like me to test?

I did test the new stick test feature yesterday - that worked well. It confirmed that my Taranis with IRX4+ module is giving the full rate commands at the stick endpoints.


#590

Understood…very cool.

My landing procedure:
While in air, flip RATES back to LO, turn off IDLE_UP, and land, Manual DISARM.
If using BF, flip RATES back to LO, turn off Airmode, and land, Auto Disarm occurs 1 second after motors are off.


#591

Yep @chime13 - so flipping the idle up switch off will stage you for landing. Once you land, mix increase will wait to kick back in until you take back off if you were going to.

It’s just like beta flight air mode … there is a safety there too which limits it’s authority while on the ground until your throttle passes a certain point during takeoff.

@brianquad - with props off (obligatory safety disclaimer) - try to do stupid things that could be accidentally done in real life and see if you can create a hypothetical prop strike scenario or if safeties stop you. Then go fly and put it through your regular paces. Arm, disarm, takeoff, land, idle up on and off - make sure flight performance remains as expected for the mode you are in.

If you want to feel what the new mix increase is doing - just try to land after having idle up on and without disarming. You’ll see Its very active now. Compare that to the way it behaves before taking off after a disarm or and idle up off event.


#592

I had already uncommented use_multi, so I’ll try to comment it out again and choose use_devo.
Thnx


#593

@dido Yeah I can’t follow your link because it requires the bg app. But if I’m not mistaken the cheapo multi module is a clone of geobish’s work and he is/was a main deviation (devo software) developer. That’s probably the module that is mapped like a devo. If it is … I believe you also cannot use the autobind bayang protocol because it chooses a random ID each time you turn it on. So if you save a fixed ID on the quad side with the autobind procedure … you will probably get locked out of all future bind events due to ID mismatch until the feature state is turned back off and saved or you reflash a new radio protocol option. I’d suggest a change back to standard bayang telemetry and the use_devo transmitter type.


#594

OK the last update is pushed up which ensures mix increase throttle 3 safety acts normally when arming feature is not used and idle up feature is used OR when toggling idle up feature while armed, AND also makes sure mix increase 3 behaves normally when both idle up and arming features are undefined.

@yets - the only change that is going to affect you while doing all your safeties in your transmitter and undefining arming and idle up is that I have turned up the max strength of mix increase 3 to 100%. Nothing in your transmitter is going to be able to turn that strength down if you want to idle up your props before taking off. So you may have to change that strength back to 20% as it used to be - which is no big deal. Just a setting in config.h for you to edit. The downside is that you won’t be able to enjoy the added low throttle stability in the air that you get from cranking that strength up unless you want a very nervous quad before taking off. Why not try enabling arming and idle up features and set up a new model file and just try out how well it works for the software to do it all for you. You might like it. I also don’t think any of your transmitter safeties are going to conflict on your current radio model file if you set up good safeties. In fact they will probably just satisfy and clear out all my flags with no noticible change as long as you set matching switches to arm and idle up.


#595

I just want to add that I like that changing things spawns good discussion and feedback. It helps push me to write good code. It helped me find an error today that is fixed now. It helps the project grow to meet all our needs. Thank you my friends. I truly appreciate you!!!


#596

RIGHT BACK ALL OVER YOU, BROTHER!!!


#597

@NotFastEnuf I think keeping it at the original strength will be fine for brushless. Nobody I have seen flying brushless Silverware has mentioned anything about nervous quads under low throttle. And it’s not something that I’ve ever noticed but I fly LOS.

Thanks for the changes and keeping the good work flowing.


#598

DUDES!!! CRAZY NEW DISCOVERY!!! UNIVERSAL WHOOP PIDS!!!

Backstory … I did all my testing of the new features on 6mm because that’s where I have the most variety of board types and receiver types. Today I flashed my 7mm e011 and it flew terrible on both preset 7mm pid sets. WTF !!! Hahaha… so I turned the mix increase 3 strength back down to 20% and it was back to normal. Well that shouldn’t be happening if the tune is clean. I’ve also noticed a bit of a low pwm noise that has always been present in 7mm. Sooooooo… I dropped back to my new PIDS set the “abduction - team alienwhoop pids” AND i put the mix increase 3 max strength back up to 100% and WHAMMO. Beat it has ever ever EVER flown!!! Turns out I was over tuning 7mm to compensate for a lack of low throttle authority in mix increase. It’s just blowing my mind how clean the motors sound, how responsive they are and it’s on every build I own. 6mm, 2 blade, 4 blade, 7mm - ONE PID SET TO RULE THEM ALL!!! muahahaha

Oh this also means with mix increase at 100% every boss tune that’s saved is probably also off. If you fly a boss or other brushed format (or as @yets suggests for brushless) turn mix increase 3 max strength back down to .20 until I have time to retune everything. I didn’t delete the old 7mm pids today … but expect them to go away soon after more data is collected. For now - set all your whoops to the team alienwhoop pids and leave mix increase 3 max strength at its new NFE default of 100%.


#599

Cool! I’m excited to try this out on my E011 and Beta65S Lite tonight or tomorrow!


#600

I took the bait - now I’m hooked!
Good job @NotFastEnuf - everything works as expected and I noticed the motors are running so cool, they can keep my beer cold -hahaha

I did change the rates/auxes to my taste but left everything else alone.

Overall, feels about the same if not better using the new pids and features. I need bad weather in order to see if it is as rock-solid as before the 05-09,10 updates

More important - all the safeties work and are non-intrusive. Operation normal + added safety = THanks Dude!

One note: If I comment out
//#define LEVELMODE CHAN_7
//#define RACEMODE CHAN_9
because I just want ACRO, I get a complie error in rx_bayang_protocol_telemetry.c… resulting in 7 errors total.

Remedy, enable both
#define LEVELMODE CHAN_7
#define RACEMODE CHAN_9

I can live with it, but I’d rather not have it.


#601

Thnx a lot. Flies like a charm now :+1:


#602

Change them to CHAN_OFF, that will leave them defined (needed by other bits of code) but locked off.


#603

Yeah, my E011 is working great with the lates and the alienwhoop PIDs. Super smooth!

@NotFastEnuf I haven’t been able to get it to do anything unexpected as far as the safety settings go.

I did notice that, with Idle Up enabled, level mode is really jumpy on the ground. It does not appear to have the Idle Up disabled before flight feature that is working great for me in acro mode.