NotFastEnuf E011 / Bwhoop Silverware Fork


#41

I remember at one stage the trim switches on stock tx’s were being used to switch channels. I just checked and they are still there in the main branch “// CH_RLL_TRIM , CH_PIT_TRIM - trim buttons pitch, roll”. That might do it for stock tx and save the beeping?

I flashed both an E011 and a H8 mini blue brushed quad and that worked fine, everything was as expected I think, it all worked, including race mode. I found the RHS horizontal trim switch was doing the arm/disarm function with this H8 stock tx. It seems so cool to have an arm switch with a stock tx! I’ll reflash them to use the Devo, see how they go now with these firmware settings. They certainly seem to be a lot more wicked than I remember : )


#42

Well that’s good news on the toy tx functionality overall for attempt 1.

I’ll have to look at the defines page for silver’s h8 and see if there is a reason for that I can see. Maybe that fc is just mapped differently.

I certainly wish that was the case… and it may be possible but it will take some creative coding. Silver explains to me that the trim channel returns to zero when the pitch/roll stick passes 50% so maybe if I use something similar to button debounce code on it. Make it toggle to its opposite state every time that channel goes from low to high.

That new combo kit coming out from beta fpv looks like it’s coming with an old full size bayang transmitter as an option. That would be the ultimate starter whoop kit if I can get my head wrapped around toy tx behavior and have all of it’s buttons working the way we expect on a hobby grade radio. I need to order one to sort that all out!


#43

I tested the Toy tx (e011) and once I switched it to level mode and hit the left stick race mode, and then armed it (not a huge fan of arming for a toy remote and losing rate control) seemed to work fine, with the exception that it went full throttle and stayed there once armed (as you described experiencing yourself already).


#44

Hmm… that happened on mine because my toy tx was broken. I wonder why its happening to you???
As for losing rates in favor of idle up…idle up can be quite useful for attempting indoor acro but all of these features are quite simple to turn on and off in the code. If you’re using a toy tx …Chan_5 is documented as the rates button so just move it to the rates channel and comment out idle up/arming.

Still curious why you’re going full throttle as soon as it armed. My toy tx was going full pitch forward and never worked right. Do you have fpv gear on yours?? If not the 6mm pids are a better match to line of sight if the throttle up is just an oscillation.


#45

Did you select E011 up the top of config.h? (Silly question I know but I have often forgotten to set obvious things). I wonder if I should retest on my E011. I’m using a H8 mini stock tx so not sure if it’s the same, like with the RHS horizontal trim switch doing the arm function, also it’s mode 3, too many variables I guess. The firmware has been working for me though. I’m doing props off for flashing though, I got a reminder yesterday when I flashed the wrong firmware to the wrong board type. Thankfully brushed.


#46

See my username. I’ll never get offended at someone asking if I overlooked something obvious.

But yeah, the line for E011 was already un-commented (there has to be a better way to say that).

So, I am just going to include my current config (using the default E011 pid setup as it existed in the repository when I downloaded it).
https://pastebin.com/4Tq0GGXN (EDIT for future visitors: << THIS IS THE WRONG FILE, SEE THIS ONE https://pastebin.com/8xsSUvAZ )

But, in its current configuration I have it flying in Race Mode using the stock TX. I did not manage to get Rates working however. When compiling, it threw errors every which way I thought of to configure the line, but I was in a hurry and probably overlooked something obvious.

My VM with STlink and uVision imploded on a forced windows update so I had to rebuild it and lost most of my play time to that today. I’ll find time to dig in and read through some of the files soon and better familiarize myself with the changes.

I am liking the new config layout BTW, and Racemode is everything I hoped it would be.

I don’t know where I found this, but one of the SIlvers mentioned it I think in a thread for setting the TX power specifically for the BLE app. The comments are my own, and based on a quick test and no experimentation (I didn’t test it at 7, or 0, just 4).

// 0 - 7 - power for app
//#define TX_POWER_GENERAL 4 // enable this when using BLE_APP for telemetry. Perhaps set higher than 4. Touch antenna to give it signal, or touch antenna to metal to extend it to connect to app, or set quad directly on phone.

That might be something worth including in the config (with a better description). I could also be totally wrong about it doing anything.

I removed the buzzer from my usual TX, but I have a spare that is completely untouched, and I can test in the future if needed with that if there is a code change to remove that maddening beeping. Personally, I’m fine with just removing the buzzer.


#47

Oh, I almost forgot totally.

I don’t have anything but a stock TX, but my quad occasionally falls out of the sky, and I have to go near full throttle to stop it from going thud, and then bring it down again to keep it from denting the ceiling in response. It seems like a momentary power loss to me, but I am guessing it has to do with the stock TX. Can anyone tell me if they have experienced something like this on the stock transmitters too? Just curious if its just me or not.


#48

I’ve never actually blown on a stock tx and have not experienced that condition before. I’m gonna download your setup tonight and look it over for any possible suggestions I could make to you on setup.

So just to be clear … you DO NOT want an airmode feature (idle up) and you DO want low rates working. Other than that you’re good right?


#49

I’d be 100% down for learning my way around the idle up feature but with the stock TX I’m not sure I have enough control. I have never flown with airmode (idle up) so I have no idea what I’m doing with it. The theory as I understand it is that it sets minimum throttle, but so far trying it, I had a bad time.

** Now to actually answer your question, Yes. Right now, I am aiming for low rates working, as the priority over airmode. If I could get both going, I would though.** Worst case, I can just manually set my rates really low. I’m sure its 90% all my lack of skills, but flying with the stock TX is like typing with foam fingers on your hands, so being able to lower the rates to molasses mode sometimes really helps.

For me, I might use acro outdoors (around here I have to go 30+ miles to fly outdoors though) and I will absolutely use race mode, but I know I’ll never use level mode, so if there were a way to switch just between acro/race, access high/low rates, and fit airmode in there somewhere too, that might be cool, but that sounds like a lot of work to make that happen so maybe thats something for the wish list.


#50

Ahh, it looks like you are using earlier firmware. The latest version can be downloaded here:


Try that one and see how you go.


#51

Thats the one I am using. I just downloaded it earlier today. I did change some rates, angle, and expo settings, etc to match my old config to make it manageable indoors on the stock TX.

What happened is I had the old one open to transfer those rates, etc, over and grabbed the wrong one when I made that paste. Refer to the username.

https://pastebin.com/8xsSUvAZ

My bad.


#52

Well I don’t know what’s going on with idle up jacking you to full throttle … but I will take a look at your file here soon and post some changes you can paste in that will just replace level mode with race mode all the time and keep rates on the rates button. That’s easy enough. I could even put idle up (airmode) on the headless button. Maybe that will work better. If you’re willing to try a few things … I could try to disable the arming feature so that you don’t have to use idle up as arming and the headless button will just idle up if you want to.

Idle up or airmode still gives you control even when your throttle stick drops to zero. That’s why we like it.

There hasn’t been alot of testing on the toy tx … but a few people now have reported that it works as expected. Very strange yours doesn’t. It should start spinning the props … but not send you into the roof.


#53

First, thanks both of you for taking the time to take a look.

Second: I will test out any configs you want to send my way. If you want to toss together a few hex files and name them so we can keep it straight which does what, then I can power through loading them even faster if there will be a lot of revisions to test in a single day, but I can make it happen with config files nearly as fast (its just harder to keep 10 different config files straight since they all have the same name).

I will scrap what I’ve done so far and test again from scratch tomorrow if I have free time (I should), just to be sure I wasn’t overlooking something. With everything cranked way down, I suspect I might find airmode works, but I’ll have to try it to know for sure.

This would all be much easier if I just bought a proper transmitter already


#54

OK, start with this… sorry I didn’t make you a hex file but the more you see the code the more these things will make sense to you (and thats a good thing).
Go into your config.h file and past this over top of your lines 64 to 76 (as pictured in your last link).

That will put rates on the rates button, acro/racemode on the stick gesture, and airmode on the headless button (click left stick in)

NEXT… go to the control.c file and paste the following over top of lines 191 to 194

That will take the arming feature away completely but leave the idleup/airmode bit. In other words, one way will act completely normal, and then when you click it in - it should idle up the motors and still give you stick control even when you drop your throttle stick to zero in the air. If you were running my default rates and expo - a flip in acro mode would be near impossible without airmode - you’d lose control. But with it on it behaves quite predictable.

If any of this gives you a problem I will make a hex for you … but give it a shot first!


#55

hey, finally made it here, of course I know of this fork already.

I’ll probably add some things like the channel defines to the normal code from your fork.


#56

if anyone can make bluetooth apps, there is a way to have 2 way communication with the xn297 chip. It’s a hack , but it should work, could probably be used for pid config

it involves sending advertising packets from the phone, so it needs android 5+. The xn297 payload is encoded within the advertising packet is such a way to be picked up by the xn297 chip after it passes thru the BLE encoding layers

I actually tried a concept payload and it did send correctly


#57

Yeah, I appreciate in particular the cause to take a look in the control.c file.

At first glance rx[3] is the variable for throttle input from the stick, correct? Looks like you added “if throttle-position less than .1% then throttle is 0” and took out the “if airmode=off then throttle =0”, or something in that ballpark.

As for the hex files, if you want me to test 10 different configs in a sitting to vet some new features or something, I’d appreciate hex files, but otherwise yeah a config or a few lines to change is great. I wasn’t (and probably still am not) very clear on that. Point was: I’ll test as much of anything as you want since I am on the toyTX and have random bits of time I can flash and test throughout the day often enough, but if you want me to test a big batch of different things and give feedback, hex files are much easier to keep from confusing which version is which. But these small one-offs, yeah I can compile that and stick it in a folder of its own no problem.


So far, rate switching works exactly as it should.
Airmode is off, however pressing the left stick (channel 7, correct?) it does not react (turn on).
I also didn’t get a response from channel 6, seems stuck in race mode, but that is a gesture thing I think so a lot of room for me to be doing it wrong.

I wouldn’t call my results here definitive. At this point in the day I am likely to be missing some brain cells.

Also, Hey its a silver13 !
I played a bit with BTLE on Android years back and concluded that kind of thing is better left to smarter people than I. Glad to see you are still moving forward with that though. It is a really cool feature. I didn’t get pids but I did get battery status out of my E011.


#58

The gestures for acro/Racemode are left-left-down for one side of the switch and right-right-down to switch back the other way. You may be missing going the other way. Curious that clicking the left stick (headfree) did nothing … that works on mine. I wonder if your tx is functioning properly. It is mode 2 right? Not sure if that makes any difference. Well, it may just not be one we can win on your particular equipment for some unknown reason. Hopefully you get your acro/Racemode switching properly with the correct gestures… and the channel selection makes a bit more sense to you now so you can pick things how you like them.


#59

Yeah, I’m going to try the other TX I have and mess around with it a bit more. It is probably something I’m doing wrong. I’m sure I’ll sort it out. Whatever the status of the other features are, I have racemode now! It really is excellent. I look forward to doing a lot of fine-tuning to get it working really well with this awful toyTX, and having a lot of fun doing it!

Thanks for putting in the time to help with this stuff today, and of course for taking Silvers work and building on it to bring us all something really exceptional.


#60

Hey man! Wow I’m honored I could make a contribution which may be added to the official firmware!

I’m still stringing along a pile of old note 2’s here, making repairs, swapping parts, and keeping a Frankenphone alive. I wonder if I shove the right 5.0 based rom on one if I could get that Bluetooth functionality.