NotFastEnuf E011 / Bwhoop Silverware Fork


#544

I use the cheap one from bangood and i choose telemetry autobind when compiling. https://www.banggood.com/Multiprotocol-TX-Module-For-Frsky-X9D-X9D-Plus-X12S-Flysky-TH9X-Transmitter-p-1097688.html?rmmds=myorder&cur_warehouse=CN
Could you give me the steps you did to get telemetry on taranis?


#545

Have you tried using the St-Link utility program to start the process?


#546

Guess what… the newer firmware just flashed nicely and now the FC works like a charm! :smiley:


#547

@amdnikos Did you upgrade the firmware on the multiprotocol Tx module, like the link I sent mentioned? You have to have the latest firmware (not the factory firmware) so the module will speak the modified Bayang+telemetry protocol. Info here: https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/blob/master/docs/Compiling_STM32.md

After that, you need to compile Silverware using bayang_telemetry_autobind, like you mentioned.

Then, you set up your model in your Taranis, you need to select the Tx protocol “Protocol Bayang Bayang, Telemetry 1” or “Protocol Custom 14 0, Option 1” (which is the same thing). You won’t have this option until you update the Multiprotocol TX module firmware.

I use Serial mode for the Multiprotocol module to talk to the Taranis, which requires updating the Taranis firmware to OpenTx 2.2 (https://github.com/pascallanger/DIY-Multiprotocol-TX-Module/blob/master/docs/Tx-Taranis.md).

Does that help? Or have you done all of those steps and still have trouble?


#548

Thanks a lot for help! I am afraid that i have the wrong multiprotocol and it cant be updated, check the link in my previous post.


#549

@amdnikos Too bad… It sounds like you could maybe update the firmware on that one, but it is more involved: https://www.rcgroups.com/forums/showpost.php?p=36552023&postcount=14


#550

Yeah, its too much for me definately, i ll prolly buy the irange plus. Thanks again for help my friend. :slight_smile:


#551

@yets Yes I tried the ST-Link util. It wont connect either. I upgraded the Firmware on the STM32 device and that did not change anything.


#552

Has the board been flashed before? Have you tried the regular pads on the backside of the board?


#553

I have accumulated a few stlinks now and am actually down a rabbit hole of firmware for them and connectivity issues. Most stable combo I’ve found is version 27 with utility 3.9.

What a mess. It seems you can only jump forward so many versions when upgrading or it will fail. And you also seem to need a matching release of utility to your version of firmware. One link I could downgrade to 14, but can’t upgrade to anything. Maybe I need to downgrade drivers too. Ugh

Idk really. I don’t enjoy this side of the hobby. Lol


#554

The best procedure that I use is that when flashing I connect St-Link first, connect board, attach battery last and press connect. If it doesn’t connect, I make sure hat I remove the st-link from the USB, close the program and start the steps again. If it’s still troublesome I change USB ports. Normally gets it.


#555

I found that I have to open ST-Link Utility first, and AFTER that connect the ST-Link to the USB port. Then all is fine until the ST-Link is removed from the USB port.

Having the ST-Link plugged in and then opening ST-Link Utility does not work for me.

I get the feeling the ST-Link Utility does some sort of initialization on the ST-Link as it powers up from the USB port.


#556

I’m discovering that many of these procedures are specific to certain firmware versions on the link paired with certain releases of the utility.


#557

Interesting, I have not had to look into it, maybe I’ve been lucky. Also the PC used, Keil version etc might have something to do with it. Edit - I’m running the latest Keil uVision V 5.25.2.0. Attached pic of my ST-Link Utility version.

It took a while, but I got the flash.bat file running from this thread and this does not have the “Keil bug”. I am still assessing if this has benefits overall compared to just using Keil. So far I like it but not sure if I could or should recommend it. Just mentioned it for interest’s sake (another possibility).

stlink1


#558

Yes, the old one has been flashed before with the initial Silverware HEX file.
It was flashed via the larger pads on the middle of the board… I will try connecting it there…

Thx!


#559

I’m building a Boss 7… noob question alert…:grin:

Where do I adjust the settings written in the comment above the Boss PIDs? (Highlighted)

//BOSS 6 & 7 - 615 and 716 motors, hm830 46mm props -1st gyro at 70hz, D 2nd at 80hz, motor filter at 70hz
// ROLL PITCH YAW
float pidkp[PIDNUMBER] = { 24.5e-2 , 24.5e-2 , 9.5e-1 };
float pidki[PIDNUMBER] = { 12e-1 , 12e-1 , 8e-1 };
float pidkd[PIDNUMBER] = {14.1e-1 , 14.1e-1 , 7e-1 };

Thanks in Advance!


#560

Those settings are in config.h. Essentially you need stronger gyro, D , anf motor filtering than the default whoop settings.

I highly recommend the experimental tune which also involves changing the same filters and adding torque boost


#561

I tested the latest code today. The new arming safety feature worked as expected. I have arm and idle up mapped to different switches. The arm safety worked with idle up mode on or off, so arming would only function if the throttle was down. Seems solid!


#562

Thank you @brianquad and everyone else who participates in checking out these new features. You all know who you are and I wouldn’t be releasing so many changes without your support in checking behind me. As for my testing … i still feel like one thing is missing. Upon bind, if I have my arm/idle up switch active - props will spin up at a potentially dangerous time. (Not really dangerous a whoop I know). So I think it needs one more check in place, and also that constraint on the throttle safety value that @chime13 pointed out. I’m not sure I’m gonna jump on that now or not.
Current to do list:

  • finish arming safety features
  • code dsm serial rx
  • code sbus telemetry & move pin assignments to targets
  • establish a serial link with pc to change user variables - basis for configurator
  • figure out how to serial communicate with pc and serial receivers with only one usart.
  • split separate setpoint weights for angle and acro
  • add spi rx support to alienwhoop Zero

#563

I would love to know if 2 sets of setpoint weights for acro is possible.
I feel that 1 good PID tune is all that is needed for any kind of flight, but having 2 setpoint weights, like rates, makes a heck of a lot of difference in regards to feel and styles of flying.

It could be addressed like the definition “#define LOW_RATES_MULTI 0.5f” but called something like “#define LOW_SETPOINTS_MULTI .5f” assigned to an AUX and have it cut the Setpoints by half giving me both Aggressive and relaxed setpoint weights.

Just a thought… :slight_smile: