NotFastEnuf E011 / Bwhoop Silverware Fork


#524

If I were to change the value on config.h from #define THROTTLE_SAFETY .10f to #define THROTTLE_SAFETY .99f effectively disables it though for safety reasons I strongly recommend not raising the value above .20


#525

After assigning channels, I successfully compiled and flashed your update on a 6mm Boss E011 with 18kv motors and H8 Props (my new favorite props) and I’m happy to report that your objectives were met with a high degree of success -hahaha

If trying to arm with the throttle just past 10%, the LEDS will flash rapidly and not allow arming. Once you lower the throttle below the threshold, the craft arms and normal operation follows. Idle_up on a separate Aux channel (6) presented no issue as it doesn’t come into play unless I arm first.

As it is, the only thing I can’t do is a burn-out - flipping the arm while throttle at max and watching it shoot straight into the sky

On the other hand…maybe that’s a good thing - hahaha

All the flight modes work as predicted though, I personally still prefer Acro mode with faster YAW rates (900degrees) and less expo. (.5)

Using the the 7mm Whoop NotFastEnuf “High and Tight Pids”, it flies great and motors come down only lukewarm.

Regarding Brushed builds under 120mm, PIDs and elevation:
From my own personal experience - A good tune is a good tune at any altitude between sea level and 9000ft (the highest elevation I’ve flown from. Your Pids are priceless.

I honestly can’t say enough as to how happy I am since discovering Silverware.
Beta-who?

BTW - Backing up the FC was a cinch using the STlink utility and saving it as a file.


#526

Hey everyone!. I’ve just updated to the latest firmware and I am having issues…
I am running USE_MULTI with QX7 Stock E011 frame & Board.
I have an AKK A5 Camera mounted up front between the front ducts and the VTX between the Battery and the FC.

Whats happening is that when I arm/idle-up the quad flips over backwards. I cannot get in the air because it always flops over before I can do anything. If I hold pitch forward or trim it stable, when I add throttle, it flips over forwards.

I tried adding 5 degrees of manual pitch trim, but it didn’t make any real difference.

I tried mutlple times, and I “down+down+down” numerous times to re-callibrate the gyro as well.

Any ideas?


#527

I just disabled IDLE UP and now it pitches forward when I try to take off… It will not autolevel

I do have LEVELMODE CHAN_ON ( level mode on )
I tried both the up+up+up and the down+down+down gestures… no luck


#528

It seems like the throttle is controlling the pitch… The right stick is not doing anything.
If I throttle up to ~2% and move the right stick nothing happens.

Note - I am using: https://github.com/NotFastEnuf/WHOOVERWARE.git


#529

You are using a hovercraft firmware on a drone.

Use this instead: https://github.com/NotFastEnuf/E011-BWHOOP-H8-Silverware


#530

THANK YOU!.. I switched over to this one and its working 10000% better. :smiley:


#531

One additional issue. To get to “Acro” do you still need to go left + left + down, or is there a way to assign a channel? It seems “RACEMODE” != “ACRO” from what I can see, its still stabilizing on the roll access.

Thanks!


#532

Sorry for the SPAM… :smile:

FYI
I figured out how to get ACRO via a Switch by inverting Channel 6 on my QX7. This way I can start in AUTO LEVEL mode and then switch to all modes from there.


#533

That raises an interesting point. I seem to recall most taranis users needing to reverse the throw of their auxiliary switches. I could set this up in the main channel map if that’s a consistent thing … but before I do - I need to figure out how to warn anyone updating that their previous model will now need it’s switches reversed again back to normal orientation. Also the use_multi radio map isn’t limited to just taranis … do you flysky guys also have to reverse?? My cc2500 module arives at the end of the week. I’m quite curious what my map will look like on a devoted using a frsky sbus rx. I guess I need to update the reademe anyway … I’ve been doing stuff and documenting it here but not in the readme.

@FPVClub - you have set level mode to ON all the time. You will not be able to get into acro with this setting. Put it back on a switch and you will be able to switch between acro and levelmode. Also racemode by definition is acro on pitch axis and leveling behavior on roll axis.

Levelmode not only activates plain old regular level mode … it activates the entire group of level modes (level, racemode angle, racemode horizon, and horizon). To get into a specific leveling mode … it takes a combination of switches. Levelmode switch must be activated with the others to “build” the mode you want.

LEVELMODE ON + RACEMODE OFF + HORIZON OFF = regular angle limit level mode

LEVELMODE ON + RACEMODE OFF + HORIZON ON = horizon mode just like betaflight

LEVELMODE ON + RACEMODE ON + HORIZON OFF = racemode angle (roll axis will have angle limit, pitch will be acro)

LEVELMODE ON + RACEMODE ON + HORIZON ON = racemode horizon (roll axis will have leveling but no angle limit, pitch will be acro)

LEVELMODE OFF - this will go back to acro no matter what the other leveled mode switches are set to.


#534

Haha… that didn’t take you long to figure out how to get around it. Lol. I should probably put a constraint on the range.

Beta who? … I’m laughing again!

Very cool on backup … obviously I have a lot to learn!


#535

Hmm…I have a QX7 with IRX4+ multiprotocol module. I don’t invert/reverse any switches. Maybe I’m misunderstanding what that means.

If the radio is laying flat, switches down towards the ground is -100 (off, 1000 ms) and switches up towards the sky is +100 (on, 2000 ms). The spring-loaded toggle switch, then, rests if the “off” position, which seems consistent.

Now that I think about it, @FPVClub probably just means that he wants that switch to mean “acro mode,” but since, in the code, it is actually “level mode“ when that channel is active, he inverts the switch to reverse it.


#536

Identical setup - I don’t have the issue either.

Under Mixer 5/11
Scroll down to the Switch you want to modify
Long press gives you EDIT
Once in edit, scroll down to Switch and press Enter
Now you can toggle the physical switch to whatever direction you want it to engage
Long Press Exit

I keep all my default switch positions in the same direction (away from me) and have them only engage when pointing in my direction, which means that my switches SA-SF (Menu 5/11) have a down arrow to the right of the switch descriptions.


#537

x9d+ & IRX4+ no problems


#538

Ok. Thanks guys. Leaving good enough alone then. I’m honestly Ignorant to the world of taranis. Devo for life here. Lol


#539

Anyone with taranis and multiprotocol managed to get telemetry to taranis?


#540

@NotFastEnuf Helpful feature for those coming from BF. I’ve implemented it into the brushless fork :smiley:


#541

Yes. Telemetry is working great for my two silverware quads (paired to the Taranis Q X7 and IRX4+). There wasn’t a whole tutorial to get through all the steps, but I got it working in the end. I started with the links on this page and muddled through from there:
https://www.rcgroups.com/forums/showpost.php?p=39230062&postcount=3

Do you have any specific hangups or questions?


#542

@NotFastEnuf @brianquad I’ve set it up now back to the stock setup, but I’ve reversed CHAN_05 so that it starts in auto-level mode. This is working great. Thanks guys!


#543

Hey guys, I ran into another issue…

I have 2 E011’s - One OLD and one NEW. I’ve put 4pin headers on both boards ( using the 4 front pads ) and built a cable to update them with the latest firmware.

The new drone flashed super easy and just worked perfectly. The old one will not connect to the quad no matter what I do.

I’ve tried:

  • using the power from the STLink ( works on new FC )
  • Putting the battery in at random times after startup
  • I’ve confirmed all the pins are reaching the board using a Multi-Meter
  • I’ve confirmed there are no shorts on any of the 4 wires using Multi-Meter.
  • I’ve rebooted the machine

I am at a loss for additional things to try to get it working… Any ideas would really be appreciated.