Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


Well the wiki is about actual silverware and not so much my experimental fork of silverware. I will review my instructions in the readme and also in the commented notes above that selection. I may just make autobind the default option too. I always forget to change it too.




I’m not exactly sure which one of those will do it but it’s probably one of them. Being an absolute novice to code writing … that’s the sort of thing I have to test to remind myself of. I’d have tested it first before responding but I’m away from home for the weekend. I’d say always experiment with props off … but fortunately we are just playing with whoops! Lol


it is, links in the features list right at the top of the start page


The protocol listed should be the autobind protocol which makes sense but goes against all of that steps I’ve seen in the wiki and in this thread. The default protocol is not the autobind protocol which further added to my confusion. Works great though. Thanks.


did you choose #define RX_BAYANG_BLE_APP for radio protocol…?


Dear @silver13 and @NotFastEnuf,

Thought I’d ask again…:wink:


I honestly don’t know. Lol. I know there is something about pid tuning from sticks and reflashing which allows you to keep your pids as long as you don’t edit the pids in pid.c … but I will be the first to admit I only use about 10% of the functionality of silverware… and i haven’t tested much beyond what i use. I certainly do want to learn and experiment with as much as possible. This year my goal is to master a silverware brushless build and explore all the other amazing functionality like silvervise, stick pid tuning, sbus receivers, so much more…


Hello everyone, is there any way to get rates and super rates as in betaflight? I could not get fast flips/rolls at the end of the stick without losing smooth turns at the beginning of the stick


Are you running my fork or stock silverware?


your fork, I have tried in many ways. I know it’s not the same as betaflight is much better than bf that’s why I got interested, but I can not configure the rates.

my rates in bf:

// *************rate in deg/sec
// *************for acro mode
#define MAX_RATE 1308.0
#define MAX_RATEYAW 1308.0

// *************max angle for level mode
#define MAX_ANGLE_HI 70.0f

// ************* low rates multiplier if rates are assigned to a channel
#define LOW_RATES_MULTI 0.5f

// *************EXPO from 0.00 to 1.00 , 0 = no exp
// *************positive = less sensitive near center
#define EXPO_XY 0.8
#define EXPO_YAW 0.6

// *************transmitter stick adjustable deadband for roll/pitch/yaw
// *************.01f = 1% of stick range - comment out to disable
#define STICKS_DEADBAND .01f

// *************Radio protocol selection
// *************select only one
//#define RX_CG023_PROTOCOL
//#define RX_H7_PROTOCOL


Scroll way down in config.h
Look for a line:
Make sure that line has the // in front of it. There was a short period of time that I had merged in some changes where the // got dropped in the merge and expo stopped working. That may explain why you are having a hard time with your rates. Check that and report. If the // is missing - put it back and re flash.



// disable inbuilt expo functions
//#define DISABLE_EXPO

when I have high rates the flips / rolls are great but the handling with small stick movements is impossible because they have the same rate as the flips / rolls This is where Expo should help. I have run out of FPV camera, once the new one arrives, I will do more tests or even better DVR

Thanks @NotFastEnuf


So as long as expo isn’t disabled … just up it now till it feels comfortable. Try .9 for both roll/pitch expo and yaw expo. If that’s not enough keep going up by adding .1 till you like it.


I set expo in my qx7s. This way I could more quickly try them out.


Sorry :sweat_smile::sweat_smile:


No worries man. There is so much to keep track of. :smile:


Now working thanks

Telemetry Battery issue

#define USE_MULTI


I don’t use a taranis myself but I think @chime13 had a similar issue and changed a setting in his radio to correct that. Maybe he can help.

Also once you get it scaled properly, there is a fine tuned adjustment you can make to get it close to perfect in code too. We will go over that after someone more taranis familiar helps out with the location of that setting. It is documented somewhere above in this thread if you want to dig. Maybe it’s good wiki material since it’s come up a few times.




I do not know how to share the video of my first flight with 6x15 silverware, so I put it on youtube as private.
Very surprised and in love with this fork, I need to adjust the rates a bit, it will be tomorrow.

Getting close to my rates