NotFastEnuf E011 / Bwhoop Silverware Fork


#364

an off chance, but try the latest rx***app.c file from my bwhoop github, there was a change, and it might help. Apart from that, sometimes touching the antenna helps


#365

I just realized that this H801 board is different than the ones in the stock H801s I bought off Amazon. Hopefully it still works. Looks nice with the flash connector. Is that other one power for the camera?


#366

March 20, 2018 6:40PM?
This is the last one I used and still did not work.


#367

Does this app exist in the Play Store or is it sideload-only?


#368

IDK - I got it from the Wiki and BT’d it to my phone
http://sirdomsen.diskstation.me/dokuwiki/doku.php?id=silvervise


#369

@DonnieH801 My h801 fc is in the mail yet so I’m not sure if that connector on the top of the h801 fc can power the fpv aio, but in the connector on my bwhoop b03 fc, it works great!:+1:


#370

I uploaded the changes to separate arming and idle up features tonight. For default - I left them both assigned to channel 5 cause I’m not going to make use of them as separate features … but its there for those of you who want it!

I’m testing the telemetry scalefactor voltage correction thing now. If that works - I’ll add it tonight too and report back.


#371

Great job!
Stupid question:
After dling this last build, will all the features you configed for me be available so I can safely delete all the previous builds?


#372

Good question! LOL What all did I configure for you??? HEHE I think so… but you’ll have to get your channel assignments assigned the way you like it and such in the receiver section.

Also… the telemetry voltage correction thing works great!!! There is now a spot in the voltage settings section of config.h here you can enter the value you measure with a preferably accurate voltmeter on a fresh pack … and what the telemetry is telling you is in that battery. Change those values, flash again, and it does the correction from there and you get accurate voltage telemetry.


#373

Curious to see if other Q X7 users need the same ratio & offset i need to dial into the TX…


#374

It’s working better than ever. Didn’t mess with your ratio/offsets


#375

Hi All,
noob here, thanks to @NotFastEnuf and all members here
:grin:

I’ve got trouble here. After dowload the latest version (03.19), i tried to activate buzzer of these line

// *************external buzzer - pins in hardware.h
// *************external buzzer channel define to enable switch control
//#define BUZZER_ENABLE
//#define BUZZER_ENABLES_CHAN_10

but the buzzer didn’t work

i tried for some different way but didn’t work either

here’s my modify line

hardware.h
// BUZZER pin settings - buzzer active “high”
// SWDAT and SWCLK pins OK here
// GPIO_Pin_13 // SWDAT - GPIO_Pin_14 // SWCLK
#define BUZZER_PIN GPIO_Pin_13
#define BUZZER_PIN_PORT GPIOA
// x (micro)seconds after loss of tx or low bat before buzzer starts
#define BUZZER_DELAY 5e6

note:
i soldered the buzzer at B+ (+) and CLK pad (-)

config.h
// *************external buzzer - pins in hardware.h
// *************external buzzer channel define to enable switch control
//#define BUZZER_ENABLE
//#define BUZZER_ENABLES_CHAN_10

i made a change to
//#define BUZZER_ENABLE
#define BUZZER_ENABLES_CHAN_10
–> didn’t work

#define BUZZER_ENABLE
#define BUZZER_ENABLES_CHAN_10
–> didn’t work

//#define BUZZER_ENABLE
#define BUZZER_ENABLES CHAN_10
–> didn’t work

#define BUZZER_ENABLE
#define BUZZER_ENABLES CHAN_10
–> didn’t work

did i miss something or i mess something…?


#376

I’m assuming you’ve assigned a channel on your tx for it? Have you soldered ground to B-/ground too?
http://sirdomsen.diskstation.me/dokuwiki/doku.php?id=adding_a_buzzer


#377

I’ve honestly never connected a buzzer to silverware. LOL. I’ll have to dig into it with a fresh head as soon as possible (when its not past midnight!) Code looks right though


#378

I have two brushless with buzzers, they have to be certain types of buzzers. I made mine according to the schematics on the wiki page :sweat_smile:


#379

Something about needing its own transistor to drive the buzzzer right? I remember reading about that. I’ll try to make one this week and see how I get on with it.


#380

@yets,
for any silver13 firmware, it work well even i just soldered on that two pad only :smile:

@NotFastEnuf.
sorry for that, it is noon now ( i am from Indonesia) and I really appreciate your help.
:slightly_smiling_face::slightly_smiling_face:


#381

Sorry, so does it work at the moment but you just can’t get it turn on with a switch? What type of buzzer is it?


#382

it doesn’t work at the moment.

I assume the buzzer will active if one or more situations meet the condition

if ( lowbatt || failsafe || aux[BUZZER_ENABLES] )

lowbatt > doesn’t work
not/lost binding ( I’ve set for 5 seconds) > doesn’t work
assign to switch(channel) > doesn’t work

it is active buzzer, and i use the same active buzzer for silver13 firmware > it work.


#383

Is it 5 seconds for your other buzzers and firmware? Try the standard 30 secs as a test. Do you get sound from it when you turn on the quad? Do you get sound from the others when you turn on the quad?