Micro Motor Community

NotFastEnuf E011 / Bwhoop Silverware Fork


#263

I think I have successfully ported over RCgroups Bikemikem’s Blheli passthrough to @NotFastEnuf’s repo for Windows/Keil users. Basically means that you use a TTL USB (or Arduino) to pass through the board to Blhelisuite, but you need to remove the FETs and pull up resistors next to the motors. I haven’t got an E011 and BWhoop to test it on so I’m not 100% ate it works. Hopefully have it up this evening once I figure out Github… I also tried looking at autobind not got it working correctly


#264

you can change the pids too, autobind will be unaffected


#265

Thanks - Yes I verified it - works like a charm! Again, very impressed!


#266

Well I copied your diff to my local file and attempted to apply it … but I really have no idea what I’m doing and was met with a series of fails… it seems it couldn’t locate any of the key files that it was supposed to edit? Not a problem with your diff of course … just my own inexperience. Anyone want to teach me how to do simple things like the the right way??? Send me a PM if so. I’d love to learn … but hours into trying to teach myself and I have gotten nowhere.

On top of that, it seems my fork has so many changes that I can not merge back in any of silver’s recent commits. I’d love a little guidance on what I’m supposed to do in a situation like that. Hand edit everything or is there a way to pick out single commits and apply them?


#267

check your messages…


#268

The way it worked for me was to copy the autobind.diff file into the src folder. Open a terminal window from there - copy the text below and paste it into terminal - hit enter

git apply --ignore-space-change --ignore-whitespace autobind.diff


#269

Still seeking help, just tried saving the diff to the src folder and applying there in bash terminal … but nothing happens. Any advice for how to do this in windows?


#270

I just flashed my JJRC H67 but I can’t take off, throttle does nothing. Idle up (CHAN5/rates button) works and makes the motors run and I can fly

#define BWHOOP
#define RX_BAYANG_BLE_APP

SilverVISE doesn’t find anything when I scan.

The rates are insane for the stock tx. does this mean it’s locked in high or low rates?:

#define RATES CHAN_ON


#271

Channel 5 is airmode in the firmware as you’ve stated. Comment it out for normal motor operation.

You may need to go into the BLE_app protocol.C and change your settings. Comment in Use All Bluetooth channels and comment in tx power and change it to 3 maybe.

It’s locked in at high rates on probably. Lower the rates to maybe 360 for stock feel?


#272

@NotFastEnuf I’m not entirely sure how Microsoft decided to implement Bash in Windows. Do you have a proper Unix environment, or do they just fake it? Either way, you need to have git installed and available in bash. Try which git, if git is there, that command will tell you. Then you cd into your src directory, copy the diff into there, and run the command I gave above.

If you need in depth help, just PM me. What timezone are you in? :sweat_smile:


#273

To be honest I am not even skilled enough to answer those questions. I use a bash terminal called cygWin.
The procedure I follow is as such… Clone my repo -> Download your diff to my src folder -> navigate in bash terminal to inside the src folder -> apply the command… nothing happens.
Now…if I put the diff in the main folder called E011-BWHOOP-H8-SILVERWARE and I apply the diff from inside that folder in my terminal … I get the response that it can not find the directories for the 5 files that it is supposed to edit … but at least it tries to do something.
Strangly… If I move the 5 files that it wants to edit out of the src folder and put them in the main folder E011-BWHOOP-H8-SILVERWARE … It will apply the diff to those files. Then I have to cut and paste them back into the src folder. I have no idea why nothing happens with the git apply command when I am inside src … but it will do something elsewhere. What a mess


#274

You could use windiff and my bwhoop code, the autobind is there now

that means ignoring the diff file and just manually changing things over


#275

Thanks… I’m just frustrated. LOL. Its hard to learn something new with no formal training and without a tudor. You guys are all very helpful to string me along and I appreciate it.

I did succeed in pushing the diff patch into my local files … I just know I was not supposed to have to move files out of src to apply it and than back into src. Either way - I have autobind in - and I pushed it into my repo. I’m gonna push it into whooverware next.

I will research windiff. Thank you


#276

If it works can I then send over the Blheli through code?


#277

Autobind is working. Bring on the blheli pass through next! What all did you have to change?


#278

I had to add files and that’s where I’ve been having problems because as soon as I push them to github and then download it to test the added files aren’t included, so it won’t compile. I’ll send it over in the morning. 3am here and I’m dealing with a six month old that is refusing to sleep.


#279

Yessir. Have you tried

git add .
Then
git status

That should include all your changes and then let you verify it’s ready to push. All you’d need to do then is add a commit note

git commit -m “your note here”
Then
git push origin master

Maybe that’s exactly what you are doing … Idk. I’m really new to all this. But that works for me. I actually always start now with the git status command so that I can see what is modified before I git add .


#280

I don’t know how to use git. * Embarrassed*

I’ve got the git Windows thing and a bash. I’ll have a go? I’ll have to fork your repo again with the autobind I guess?

5am here and still up with kid, you may have to wait until I get some sleep lol


#281

Sorry gents, what was the census on whether the “new” style "E011 replacement board can be flashed or not?


#282

New style cannot be flashed unfortunately.