New here. Just wanted to say Hello and Ask a Question


#1

Hello all. I am new to the hobby and had some questions which led me here. I am a member on various other forums as well trying to get the hang of things and not spend too much jumping in at first.Just wanted to say hello and post a question since I am limited as a new user to which threads I can post in for now.

I have a Blade Inductrix Pro that I got new in the box. I bound it to my Frsky Taranis X9D+ with Orange Box and it seemed like it took. After I powered them down and back up I had no control over the unit and the motors spun up and maintained a decent speed. Now that is all it will do when I hook up a battery whether I have the radio turned on or not.
I had a similar issue with my Makerfire, but was able to get into Beta Flight and force a flash to fix it, but Beta Flight is not reecognizing the Inductrix Pro.

Which leads me to my question. Does anyone know or are able to find out if the Pro FC has Boot Jumper Pads? I think if I can find those, I can force a fix.The quad was NiB, but bought from an individual so no receipt or warranty is available, AND I see it as a challenge to fix it and learn more about these little buggers and what makes them run.

Thank you in advance for taking the time to read this and also for any advice that may be offered.


Blade Inductrix FPV Pro
#2

Hey @baby2huey3, welcome to the forum! Lots of people willing to help here :slight_smile:
Can you provide a bit more info on what happens when you connect to betaflight? Does your computer not recognize the board? Do you have another FC that connects fine? This will help determine whether it is a driver issue or not. Let us know what exactly happens and we should be able to help. Shorting bootpads is usually only needed if you flash the wrong sketch or if your board memory is corrupted. I wouldn’t try that just yet, can sometimes cause more issues.


#3

I have 2 other FC’s that connect fine. The computer recognizes the board when I plug it in and gives me an audible confirmation of this, but Betaflight does nothing with it. I have successfully shorted the bootpads and forced firmware on ona Makerfire Micro FPV FC, and though I know it is not the ideal method, I do not know what else to do. I have it apart right as for now so I could see if I could locate the bootpads, but have had no luck and so far as I can tell there is nothing online about the board yet. Thank you for the response. I guess if worse comes to worse, I could just replace the board, but the factory board is 50.00 and I would probably go with a Beebrain for less if I were to replace it.


#4

You are right, not much online about it. Could you post a picture of the top and bottom of the FC? Maybe another set of eyes will help.


#5



#6

Could you set the board down on a table or something? Your camera’s done a wonderful job of focusing on your fingerprints, but the board’s too blurry to make out any detail. Also, are you getting any LED blink codes? Or does the Inductrix FC even have LEDs?


#7


#8

Hopefully those are clear enough to help.


#9

Went ahead and ordered a Beebrain V 1.2 to replace it. I will hang onto in case more information comes out and I can figure out a way to get it going again.


#10

Great choice
I’m sure you will enjoy it
It’s a go to in these parts🙂


#11

Appreciate it and I hope so. May be bugging you guys with some setup questions after it comes in lol.


#12

Chief Scientist’s video on the Beebrain


#13

Got it up and running. The Beebrain V1.2 was really easy to install and tune. May dump my Makerfire board for another Beebrain.

Thanks for the help.


#14

'bout boot pads on inductrix pro fc see:


#15

Thank you. I will try it out. I replaced the board already so no vig deal if it does not work out. Will try tonight and try to post my findings.


#16

New to the forum but I was curious to see if you ever tried the boot pins to see if you could flash it? Your diagram is the only one I have found so far and I have a bricked board from a friend that didn’t know what he was doing when he tried to upgrade it. I was trying to salvage the board to put in my older inductrix.


#17

I still haven’t flashed my Pro fc. Still on BF3.16. As it flys good as far as a board with sucking ppm rx can I had no need to change firmware.
Also I didn’t fly mine much these days because I prefer my other weapons. Since I have so many projects on the desk right now I’m not sure if I’m willing to mess with flashing that one. Also there’s no necessary need to bridge boot pads for flashing. Usually you can flash without that, except if you can’t get response from bootloader.
Maybe @baby2huey3 can give you some insights if he got it working.


#18

Thanks for the reply. I know that my buddy bricked it after updating to 3.2. We had successfully updated and he decided to try and copy the old command lines into the new updated version. I didn’t realize what he was doing until it was too late. Rookie mistake! Either way, if anyone knows how to reboot these, a diagram would be really helpful. I just wasn’t sure if the picture you posted earlier was a confirmed way of jumping the board to enter bootloader mode. I’ve never done it on a board that I wasn’t sure which spots to jumper. I’m fairly new at all of this. I’ve built a couple of quads and programmed them but I am willing to admit when I am uneducated and ask for help!