Need help with RX not showing movement in Cleanflight


#21

I am havving the same issue all seems to be set up right but i get no responce from my Raido it is bound and picking up my reciver. just not sure what i am doing wrong.

SF3 F4 Pro Flight Contriller running CleanFlight

More images here i hope if i can link the…





#23

sorry for the multi post but user limits i guess.


#24

@Telazorn it would be better if you upload your images rather than linking to another site. It isn’t hard to do and your post is getting a Moderator flag because of this

Thanks :grinning:


#25

I am new to drone setup, but understand. I have a fs i6s radio and spf3 cleanflight controller. I followed this vid to a T https://www.youtube.com/watch?v=K2pPVRTQgi0&spfreload=10. I setup as PPM. I am getting no radio response. I flashed the latest stable code, my drone beeps when plugged in, my radio is bound to reciever…However I am getting no stick/switch response in clean flight. Motors do not move either…they do during power up sequence like normal…Any guidance???


#26

ok going even crazier…I was using the wrong port on the flight controller. I was in PPM mode but connecting the reciever to the serial mode bus. I am able to get trasnmitter to talk to clean flight…Now…y are my motors not spinning???


#27

Have you set up the receiver settings? How about stick travel? In my experience, flashing betaflight will help get you up in the air way faster. More user friendly and less steps.


#28

Thanks for your reply. Just before I gave up for the night I noticed I had my “disable motor” button on. Thanks to all those that help all of us.


#29

im having a similar problem… i am using an orange rx reciver that is bound to my Dx6i. but when i go to plug it into cleanflight, and move the sticks on my transmitter, nothing happens in the reciver tab. ( even though my reciver is bound) i also have ppm selected in the config tab as well. any ideas?!


#30

Are you using a PPM receiver? Or satellite? Did you make sure to select serial RX for the right UART?


#32

thanks for the quick reply! I’m using an orange Rx which supports ppm. and im using UART3 serial rx


#33

What board are you running? I’m just trying to think of what the issue could be. :confused:


#34

im running a DYS F4 Flight Controller OMNIBUS F4 STM32 Microcontroller Integrated OSD DSHOT Flight Control Board


#35

Maybe this can help: https://m.youtube.com/watch?v=LAWvKhKgVMs I think this is the FC you’re using


#36

yes this is the guide that i used to set it up… its just when i go into cleanflight, it doesnt show😔


#37

There is definitely an easy solution to this. Believe me I’ve been through situations like this! You went through the correct bind procedure? Did you select the right option under the receiver settings? If the receiver is showing that it’s bound, it must be a simple setting that’s messing up the signal.


#38

alright thank you for the replys… ill continue trying. thanks again


#39

Sorry man I don’t have access to wifi right now so I can’t watch any videos to help you (takes up a lot of data). I’m sure someone else will respond to you. Try flashing betaflight


#40

so this is the problem i am having… the transmitter is bound to the Rx. (solid Light) but it doesnt show movement in Cleanflight. I have all of the correct settings, (i think) yet still no luck. any ideas!!!


#41

Chris, did you ever find a solution? I just bought the Tiny7 and am having the same issues with the radio now showing stick movements and I’m using the DX6i. Thanks!


#42

sorry for the late reply. But yes, the problem was that my signal wire was soldered to the wrong pad. For my setup I had my signal wire soldered to the rx pad, but then resoldered it to the TX pad, and it worked.

Chris