Motor Spin on FlF3 Evo

I was wondering if anyone has run into this, I’ve done some searching and find variations of what I’m experiencing, but nothing exact.
When i apply to power to my FLF3, I have the number 1 motor spin. it doesnt spin fast, it just a steady low rpm spin, all other motors remain off.
I have updated to the latest firmware for cleanflight, which helped with a bind issue i had prior, the motor spin issue was still occuring, prior to this.
I have also tried setting my min throttle down to 1000 from the 1150 it was set to prior. I’ve also gone into cleanflight and manually engaged the motors going full on and off a few times, then rebooting.

any help is appreciated.


Sounds like a damaged fet for motor 1.

1 Like

In my case the board worked just fine and flew as expected for 3 or 4 batteries. After that, motor 2 always start spinning when plugging the battery. It doesn’t arm (no buzzer confirmation as it happened before when powering the board and when arming it with the switch). When powering it via usb it does all the buzzer confirmations at startup and responds to the switches, but of course it wont spin any motor.

I tried the “set motor pwm rate” solution with different numbers (1000, 16000, 32000…). I also tried changing almost every value in betaflight’s configuration tab. I reflashed the board, i desoldered every cable (power, motors, camera, buzzer) and resoldered again. None of these solutions seemed to have any effect on the behavior of the board.

Already asked Banggood for a replacement, i hope they send a new one. Starting to be a little fed up with banggood’s defective products. Maybe my fault for buying parts in the wrong place, i know…

Same answer as above. Sounds like a dead mosfet, in this case the one for motor 2.
Which particular FC?
If you inspect your FC do you see any burnt components? Ever seen smoke?
Maybe post a pic.
Did you stall your motor on a crash by accident while giving throttle or disarmed too late while using airmode?

Thanks a lot for the info. Here you have a photo of the board, it’s good quality, so i hope you can zoom in and admire my pro level soldering skills ;). And this is the link to the board in banggood:

No burnt components and no smoke at all. As i said before, it flew just ok for some batteries. I didn’t mention that i had a crash before changing battery again and starting to have that problem. But i didn’t mention it because the crash was so light that shouldn’t be considered a crash. Maybe a hard landing, and not so hard. I thhought a fc should be able to deal with hard crashes without a problem… so i think this board must have had a really poor quality control, as many eachine products.

And… the only thing i did set up in my modes was arming with one switch, and changing modes in a 3 position switch (angle/horizon/acro). No airmode, no anything else.

Fets are on the other side of the FC.

1 Like

Sorry man, didn’t know just what the f— a fet was, and of course no f------ idea where it was located

No visible damage whatsoever

Do you know which fet this board use, because mine are blown atm. I wanna replace it with the new ones

The picture says a08k, google says that is a AO3416 n channel mosfet, but really any other n channel mosfet from an old brushed fc should work.

Other possible replacements can be found in this thread:

Blown FET? on Scisky board. Need help ID'ing