Micro Scisky and Furibee F3 boards, Help!


#1

It’s been weeks since i received these boards (one furibee f3 and two scisky) and only was able to flash them in cleanflight after several unsuccesful attempts. But once flashed, they wont connect to cleanflight.

I tried to short the bootloader pads in the 3 of them, but got the same result. Tried using ImpulseRC_Driver_Fixer, but it just searches for a flight controller board forever. Tried using Zadig, but when i “list all devices” there’s no STM32 Bootloader to select. Also tried restarting my computer and trying again… After all these issues with 3 boards, i tried everything the same in a laptop with same results.

Don’t know what to do and i’m already tired. Any idea?


#2

before you connect on clanflight boot pins must be separed. otherwise connection failed


#3

What do you mean, separated? I tried with bootloader pins as they are, and then connecting them making a short, but no different results on any of the 3 boards


#4

Most if not all FCs running Betaflight should flash easily by doing the following:
1 Select Firmware
2 No Reboot Sequence = OFF
3 Full Chip Erase = ON
4 Manual Baud Rate = OFF
5 Show Unstable Releases = OFF
6 Load Firmware [online]
7 Flash Firmware
Notice I did not say jumper the boot pads.

If it’s a V1.2 Microscisky, Only flash it with NAZE - nothing else works

Stay completely away from any 3.1.7 release - flash only with 3.1.6 or 3.1.5

If this does not work you might be having communication issues (USB, Cable, or (Windows drivers)

HTH


#5

Thanks a lot for the info. I was trying to follow your steps but cleanflight still wont recognize the scisky board, and it is not able to open serial port to flash the board. I guess it may be a problem with drivers. The thing is that i can’t find the STM32 bootloader driver in my computer. It’s not listed in the device manager. I updated (but didn’t select) the driver on the scisky (in the device manager window). That seemed to be a little progress, now cleanflight shows “COM6” instead of “Manual Selection”. Yet, that is the only change, still not able to flash or connect the board to cleanflight


#6

same results in betaflight, by the way


#7

Sorry, I gave up on Windows due to driver issues (in my case, audio) - went to the other side - never had driver/communication issue since 2008. Speaking strictly from personal experience and not Windows bashing…

That said: If you know anyone with a Mac and they use Chrome, try it on that system to eliminate one more variable. Also, just in case, try a different USB cable. It doesn’t take much for these cables to go bad or worst yet, it might be a charge-only cable and not a data cable (they look identical)


#8

thanks man, i’ll try every cable i have around (i’ve got a few). And i don’t think i have any “other side” available. The closest thing i have is an ipad or an iphone…


#9

If you have an Android that supports OTG then you can use EZGUI. Works great in the field. Full disclosure - never flashed via Android, only tuned and with great results.


#10

Yeah! i tried it some weeks ago, because i needed to tune in the field. It worked great, but didn’t explore anything further than pids and rates, and didn’t think i could use it to flash boards… Great idea, thank you!


#11

sorry I do not understand what the problem is, but if you have a fail to connect com port, may you try with this different driver http://www.ftdichip.com/Drivers/VCP.htm in the past I had similar problems with flip32+ not able to connect com port with default CP210x driver
also look my last 3d about flash firmware problems… using st demonstrator can be a solution when flash utility non work, I write the 3d for a different board but the procedure can be the same (except for different firmware file)
Micro f3 from BG flash firmware


#12

Great, two more things i can try!! Thanks a lot, i’ll post any progress i have with the boards
Thank you!


#13

Sorry for my ignorance. Am i supposed to change the driver that is installed on the fc board through window’s device manager?

I completed succesfully the first 5 steps. Then desoldered the boot pins and tried to connect the board to cleanflight/betaflight, but no success :disappointed:


#14

yes is a virtual com driver for windows like CP210x driver (the one suggested by BF/CF welcome page)
I have used it with my flip32 on my windows7 where cleanflight was unable to show com ports
When you open cleanflight/betaflight to connect you see a com other than 1 ? when you plug usb cable, if virtual com port driver working good, you must see another com port starting (not com1 a different number available).

on my windows7 64bit CP210x driver not work. I not know why, I use the driver FTDI shown in the previuos link.
sorry, More than this I do not really know how to help you


#15

I’ll spend some more time with this and will tell you any progress that i achieve, but if it doesn’t work i’ll try to get my money back. Too much time invested trying to make these flight controllers work and i’m not really learning a lot from it, only getting frustration out of it, and i don’t think that’s a good deal…

Even if it doesn’t work, i appreciatte your help. If it wasn’t for the community i wouldn’t even be able to fly fpv, so thanks a lot!


#16

Have you ever been able to connect one of your boards successfully before you flashed them?

If you connect via USB, do you hear the windows badum sound which indicates plug in of an USB device?

Are you sure you flashed the correct target onto your FCs?

Do you have any other FC that connects to your configurator?

What version of Sciskys do you have (maybe post a pic).

Since you have 3 different FC with connection problems I’m pretty sure it’s a computer / driver or cable issue. Very unlikely that you have received 3 faulty boards.
What Windows version are you using?
Maybe think about getting access to another windows PC (family, friends, work) to try.


#17

If I understand you correctly, you’ve never been able to communicate with any FC or just this last couple of FCs?

If you can’t communicate with any of your FCs, then it is definitely computer-related. I find it hard to believe that you received 3 or 4 defective FCs.


#18

I don’t think i was able to connect any fc and access the config before flashing it. In some cases, like the beecore, i flashed directly the second and third ones i received without trying to connect them first. In other cases, when trying to connect a board before flashing it i received a message telling that it has an old firmware that i had to update in order to connect it to cf/bf

Always

Yes, in the case of the Furibee board (SpRacingF3). In the case of the 2 microscisky i found some tutorial recommending to flash alienflight, and that’s what i did (my mistake, in the BG’s product page, it is clearly recommended to use Naze)

Yes, i have. Two beecores. They connect to betaflight normally

Windows 10

I agree, but after all this time trying to get them working, don’t know what to think

I did, in a windows 7 laptop. Same results


#19

Almost everytime i had issues connecting boards to my PC, but nothing i couldn’t solve running Impulse driver fixer, until now

Yes, my beecore boards (already flashed and configured) connect to betaflight with no issues


#20

The Scisky you have is a version 1.2 and you are correct to only flash NAZE into it. I don’t use CF Configurator and only use BF Configurator without issues.
Maybe use an earlier version of Configurator to see if you can connect.
When you are trying to connect - does the round connect button on the upper right say “connecting” and just hangs there?