Looking for a repair of a Scisky board with issues

I am in south east Pennsylvania. I am at work right now, but I will post up a picture when I get home of on my lunch break. Thanks.

Out of curiosity did someone sell you a bum board but say it was working?

Not really. It was working for the most part, but the whole thing was a big mess with hot glue and stuff everywhere. It was also heavy with a FPV setup. So I decided to remove everything from the frame and re-do it. I also do not fly FPV yet, so I removed the camera and transmitter for now to reduce weight and try to increase run time. There were also two pololu boards on it. It looks like one was bypassing the missing inductor and the other was a step up one for the FPV setup. So I removed both of them, not realizing that one was used to bypass the on board inductor. So with everything removed it would not power up. I bypassed the inductor (bad move, i think) and fired it up. The props moved for a second then one of the FETs blew. I can go back and reinstall the pololu to bypass the inductor, but the FET repair is beyond my skills. Regardless to this, the part when it is plugged into Cleanflight and it shows the model representation on the first screen as you move it did not work from the start.

So, for the most part it worked.

Hi.

I think you wont like the following - sorry.

That sounds like some weird story - some nasty questions first. Did you buy a used scisky? Which was already burned up such that it needed the bypass? Really? I really hope you got it cheap.

Maybe you did power the board via the reinstalled bypass reverse polarity?
That might cause some random and hard to find damage. The accelerometer / gyro not showing any readings is a first indicator of $random damage to $some ICs.

In my world the bypass is a already last resort solution. A board damaged beyond being able to be fixed with the bypass isn’t really worth fixing. You are lucky if it’s only a single FET. You can give reinstalling the bypass properly and replacing the burned FET a try - but I don’t want to sound too optimistic. A SciSky doesn’t cost enough to track down some really hard to find issue.

Short summary, correct me if wrong:

  • seemingly the board already had the bypass, that was removed and then unfortunately installed with reversed polarity - or you had a short on the board (or something like that)
  • you have at least one blown FET
  • accelerometer is not working and might either need to be reflowed or even to be replaced
  • possibly other parts damaged
  • the STM and the CP are still working since you can still connect to the thing via USB (something survived!)

My recommendation: Get a new one. You want your FC to be at least somewhat reliable, even on a brushed micro. Even a brand new SciSky isn’t exactly that.

Did I mention that I don’t like SciSkys? :wink:

Some close up pictures would be nice - of everything.

@Zeros @las isn’t being hash, if it seems it, just to the point…It’s his way. I am sure that if you put pictures up we will all try to help.

If anyone here wants to fix it - I’ll offer my (remote-)assistance of course.

But alone sending it here and sending it back would be possibly more expensive than buying a brand new one.

@las, I bought the entire quad with the scisky that already had the bypass installed. The listing had that mentioned, but I had not done my research yet as to what that meant, so that one is on me, I guess.

No offense taken and I had already pretty much decided to replace it. I just saw a few threads here about repairs and thought I would ask.

What board would you recommend for a 135mm micro?

Well, I think a SciSky is the cheapest option available, there are other more fancy boards of course (just look around the forum, we have a couple of threads on different FCs). SciSkys are really OK for their pricetag. But they could be better - and I think some design decisions on the SciSky are at least questionable. :wink:
And that’s why I don’t like them. Why the hack are there these really almost completely unusable 5v outputs? :wink:

1 Like

Ok, I am at home now and have some pretty good results. I put the bypass pololu back on and plugged it in. So far so good but still no accelerometer. I adjusted the accelerometer trim up 1 then back to 0 and saved. After rebooting, I have a working accelerometer again!

The one FET is completely blown, as in I touched it and it crumbled. So, where can I go about getting another FET? I safely removed the blown one. I am willing to try to solder it on.

These will work.

http://www.digikey.com/product-detail/en/infineon-technologies-americas-corp/IRLML6244TRPBF/IRLML6244TRPBFCT-ND/2393877

Usually removing the old one is more of a challenge than installing the new. Especially with an iron.

Good luck.

1 Like

Have a look here. Might be helpful.
http://community.micro-motor-warehouse.com/t/blown-fet-on-scisky-board-need-help-iding/1146

2 Likes

@madman1412 got any for sale still?

@Zeros
Pm your address to me. I have a couple extras here if you’d like…

3 Likes

That would be awesome! I’ll pm you now.

2 Likes

Not exactly a FET but the component style/casing is almost exactly the same.
One of some ways to do it with an iron:

Clean the pads with desoldering braid before soldering. Use good flux and solder.
Don’t use excessive heat.

Well, thanks to @Jtwalkz for a pair of FETs, I was able to get one soldered on and working. I put everything together and did a quick test flight, which was great.

Unfortunately, I landed a bit hard and ran into another issue. I just can’t seem to win with this one. So after the hard landing, the green LED is doing a slow, steady blink. I connected it to cleanflight and I can see that I am not detecting any receiver inputs. I re-bound my TX (red led turns solid indicating a bind) but the green LED still blinks and I still get no input in CF. After pulling the board out of the micro frame I was checking the solder connections near the FET I installed and then the green light stopped blinking and I am getting inputs on CF. So odd. It looks like some sort of loose solder connection in the area of the FET I replaced. If I mess around in that area on the board, sometimes the radio inputs work and sometimes they don’t. I am pretty close to calling it quits on this board, but I figured I would ask one last time if there is a certain chip or component I should be checking.

This is the general area that seems to have the loose connection. That is the area of the FET I replaced. I will post a picture of the actual repair later, but fair warning, it is a mess.

Sometimes a reflow of the card will fix these issues. I would try soldering that antenna wire at the far upper right first as if there is intermittent signal that may be a prime suspect. The components that make up that Rx circuit are all on the bottom side of the card just below that antennae, between VIN and GND. So if resoldering the antennae doesn’t work, try reflow to that are of the card on the back. Also if you could show a shot of the back of the card or do a close inspection with at least 10x mag you may see what the issue is. That is not always the case but that is always my first course of action when something doesn’t work.

Did you use double sided tape to mount it?
I’m pretty certain the problem is on the other side of the FC. Check the soldering on the STM32F1 - maybe PA3 is loose (RX of UART2, check the datasheet).
It must have to do something with the connection between the onboard RX and the RX pin of UART2 on the STM32.

Ok, I got it flying again for a few minutes. One of the legs on the FET that I soldered on came loose. It flew a few minutes then after a crash it stopped again. I haven’t take it back apart yet, but i would bet it is the FET came loose again. I just can’t seem to get a good solder connection on that tiny FET.

I also soldered the antenna better.

Edit: I took it apart and got a good solder connection on the FET now. I ran it outside with a few batteries. Had some crashes and it held up great. Now I just have to adjust some settings in CF. Thanks again to everyone in this thread that helped me out!

3 Likes

Great Work man!

Glad you are flying again.