King Kong Tiny 6 RTF - Another Bind Problem


#1

Hello, i had problem to rebind the Transmitter and Receiver on this RTF version (the drone have Bind button but Transmitter not) , i don’t know how but it’s now work.

Meantime, it’s arrived my new Multiprotocol Jumper T8SG (Deviation 7), that have S-FHSS module inside; Now, how i bind it…? In the voice S-FHSS it’s only “Freq Fine” and “Freq Coarse” values, and not Bind function :expressionless:

On drone, if i push bind button while it’s on, nothing happen;
If i press button when off and turn on, the led flashes…

But, what must i do on transmitter to Bind it…?
I don’t know what’s Receiver name, because it is RTF version and not writed…
Only know that in transmitter RTF “S-FHSS PCM 1024” so it’s Futaba…
And in Betaflight Receiver is setting as SBUS

Help please :disappointed_relieved:


#2

@PJC might be able to help since I know he uses Deviation and also have a T8SG on hand.


#3

Thank you, i hope this!

The problem, is that in RTF Version, it’s not writted what Receiver use…!
So i can only suppose from what writed on transmitter RTF, “S-FHSS PCM 1024”, that’s Futaba… But, i open the RTF Transmitter, and there’s a A7105 Chip, that is not Futaba…!

Anybody know what Transmitter and Receiver there is on Tiny 6/7 RTF Version?


#4

If you ever figure out what protocol to use, binding on the T8SG is under the model menu where you load your model in and right next to where you choose your protocol.


#5

I don’t know for sure, how told i think is futaba S-FHSS as writed on Transmitter, but inside Transmitter there’s a A7105 Chip that’s not Futaba! And with protocol S-FHSS on Jumper T8, there isn’t “Bind” word as Flysky or others, i can only set manual Freq Fine and Coarse…


#6

Try freg fine at -40


#7

From the Deviation manual

The YD717 protocol supports 9 channels and only supports auto-binding. The protocol stays in bind mode until successful.


#8

Okay thanks!
Tonight i will try with fine freq to -40…
I have now the dubt that it’s possible that T8 not working propely, because i see that antenna was very lose :scream: i hope that it’s not cooked!!


#9

I try but nothing…!

Now… i see that NO RTF version of Tiny 6 can arrive with 4 receiver:

AC800
FM800
DSM2
FS PPM

I think that in RTF version use one of these (it’s not writed on Box)…!
So, what of this is compatible with Futaba S-FHSS Transmitter that come with RTF Version…?

If can help, on the drone is wired in S-Bus…!

I want understand exactly what receiver i have…!!

This is outside of Transmitter:
Transmitter RTF

This is Inside Transmitter:

I continue to not understand how it can Be Futaba S-FHSS with a A7105 Inside…!


#10

@JacobBlack

Found this list which may be helpful for you.

Protocol - RF Chip

FLYSKY - A7105 - Flysky uses protocol AFHDS and AFHDS2a. The channel order is the same as futaba (Aileron/Roll, Elevator/Pitch, Throttle, Rudder/Yaw)

HUBSAN - A7105
FRSKYD - CC2500
HISKY - NRF24L01+
V2X2 - NRF24L01+
DSM2 - CYRF6936
DEVO - CYRF6936
YD717 - NRF24L01+
KN - NRF24L01+
SYMAX - NRF24L01+
SLT - NRF24L01+
CX10 - NRF24L01+
S-FHSS - CC2500
BAYANG - NRF24L01+
MJXQ - NRF24L01+


#11

Very Thanks!! it’s what i thought…!

So, also if in RTF Transmitter is wrote S-FHSS, it’a Fly Sky :open_mouth:…!

It’s ridicolous…!

I will Try to bind with My new T8SG with FlySky Protocol…!


#12

No worries! I agree with you there its a bit silly. Some chinese manufacturers love skipping the little details. :slight_smile:
Hope you get it all working and up in the air soon :smiley:


#13

Did anybody manage to solve this?
I’m having the exact same issue. Binding with Flysky protocol doesn’t work :frowning:


#14

I just got the Tiny 6 and hit this same issue.

I plugged in the quad to add Angle mode via BetaFlight. Worked for a few batteries, and now the radio won’t communicate with the quad.

When I power up the quad, the light blinks blue indefinitely. If I then turn on the radio, the light turns solid blue, but none of the inputs work.
I’ve watched a few youtube videos now of others Betaflight configurations, but nothing seems to be working.

I’d be happy to hear if anyone found a solution to this, I just want to get back to flying :slight_smile:

(I’m browsing through other articles and will add links to answer to this if I can find it!)

The same problem is discussed in this thread.


#15

I finally Solved this changing Receiver on Tiny 6 with a FrSky one…


#16

I changed the receiver, no luck.
Tried a FS82 with my turnigy evolution , no luck.

I guess next is the FC.


#17

Wait wait, i’m sorry but it’s a very long time i opened this post and not remember everything well. What’s your exact problem…? Because i had problem with the Tiny 6 and it’s original Transmitter not binding and work properly, that i then solved Reloading original Dump. Then, for use it with Another Transmitter, i changed Receiver with an FrSky… Tell me exaclty what’s the problem what you see in Betaflight ecc. so i try to help you!


#18

Sure, thanks for helpiing!

So the situation is that the receiver was binding (confirmed because the light turns solid), but Betaflight is not registering it.

Ports
UART1 Configuration/MSP at 115200
UART2 set as Serial Rx.
UART3 disabled

Configuration – Receiver section
Serial-based receiver (SPEKSAT, SBUS,SUMD)
I tried both SBUS and IBUS for serial receiver provider.

THen going to the receiver tab, with the Turnigy on and the bind light solid, the channels are blank. (all say 0 and no inputs are registered).

Now after disconnecting and reconnecting the USB, I do see the serial receever provider changes intermittently. (It likes to go to Spektrum1024).

This was the same issue I was having with the original Transmitter after adding modes. (I sets up ARM AIR ANGLE and HORIZON).

Here’s a gif of turnigy binding.
https://drive.google.com/open?id=1EgXg-CJrO2vg2r8ruQQrFOHzW-oJoQ_r


#19

So, you had the same Binding problem with original Transmitter provided with the King Kong tiny 6, i understand right…? And the original Receiver…?

If it’s, i will give you the correct DUMP to rewrite the FC, but you must have the original Receiver on Tiny 6, and then you will tell me if it work!

If it work, the next step will be make it work with turnigy and other Receiver!


#20

Yes! I had the same problem with the original transmitter/receiver.

Thanks!