Inductrix Pro Arm Switch - Taranis X7 + OrangeRx


#1

Greetings,
I have been painstainkenly going through steps in order to get my Inductrix Pro to work with my Taranis X7 and associated OrangeRx module. It’s been quite an ordeal, but I think I’m on the final step.

Here is what I’ve done so far:
-Configured radio to work with OrangeRx (set Internal RF off / External RF to PPM with 30.5ms frame rate)
-Extended Limits on in order to try to raise the throttle minimum
-Set Channel 6 to be SH in order to trigger arm the motors
-Set Channel 5 to SD to use as the Mode switcher (3 modes)
-Got it finally working with BetaFlight after installing all the drivers and turn off and on the UART in ports until the receiver started showing the movements I was doing on the transmitter
-Tested that the motors do in fact work inside of BetaFlight

The Issue:
I can’t get the motors to arm on the Inductrix Pro. I have tried using the SH switch to pull towards me for a couple seconds and let go. I even tried reversing the SH switch to see if that would help. In BetaFlight, it is definitely recognizing that when I pull the switch towards me, it is within the yellow active area. I try using the switch, then raise the throttle - nothing.

Also, I should mention that in the manual it states That the Travel should be increased.
THR : 150/150
AIL: 148/148
ELE: 148/148
RUD: 148/148
GER: 100/100
AUX1: 100/100

Even with the Extended Limits activated on the Taranis, I can’t figure out how to increase the min to 150 for the throttle. In Outputs inside of the Taranis radio, the highest you can make the min is 0. You can make the max 150.

Can anyone point me in the right direction to get my motors to arm?


#3

@FPVer SH is a momentary switch and won’t work as an arm switch. Choose another for that function.


#4

Hey guys, anyone figured this out? I’m trying to get the Inductrix pro working with a taranis plus and the orangerx v1.2 module. Binds no problem, can get it to arm and switch modes, sometimes flies, but then loses its arm and flight mode and yet its still seems bound (lights are right on the pro) seems like something is just not jiving… but what? any help would be great. Thanks.


#5

Hi, I know this may not seem constructive, but I don’t think we can rule out that your FC is operating flawlessly because I’ve had similar issues with my Inductrix fpv pro FC while using the recommended spectrum transmitter.
Here’s the thread that discusses what’s wrong with that FC including my terrible experience with one near the bottom: Blade Inductrix FPV Pro
Sorry, I’m convinced they are junk, but there are many other options :grinning:


#6

Still working on this one also. Should be DSMX 11ms for pro, which is 3 blinks on the module. Won’t bind in this mode though. Will bind in the other two modes, but unpredictable, TX drops out, other issues. Following past directions for stock inductrix is not the way to go.