How to set up Scisky FC step by step


Did you calibrate the accelerometer on a level surface? What flight mode are you in?


Which Scisky? New or old, can you post a picture of the quad and a close up of the top of the board.


Hi All,

I have followed all the instructions listed above and done what each one as said.

The quad i built flys ok but it is very sluggish in the rudder. What i did not understand was step 7 setting up the deadbands. Would this make it very sluggish?

If yes what are the default settings for the two commands:

  1. set deadband to 6
  2. set yaw deadband to 6

What is the default for these settings…



Defaults for both are 0. It’s useful to have a small amount of deadband particularly with a cheaper tx.
Go into the pid tuning tab and increase the yaw rate, try 0.60 for a nice fast yaw.


thanks for that, cheers mate


Chaotix and Bubbak, thank you for your quick responses! Tre’ cool

As per your request:

Here are a couple of pics. I believe this is the old version. I’m going to swap out the motors to see if I have a bad one… In the configurator screen, I can see that I’m giving equal thrust to each motor (Angle mode). I did calibrate the accelerometer several times - just for s and g’s

I do have an FPV camera for it that also works, but took it off to avoid damaging it in the meantime.

I have the CW Red/blue motor top right and bottom left. All the prop blades face into the center, so I believe my orientations are correct.

I can switch between Angle mode and Horizon mode - seems to go crazier in Horizon mode (blue LED)

Pardon me if I’ve gotten any of the jargon wrong as I am an (old) newbie :slight_smile:

Thanks again!


Top left and bottom right should be Red/Blue motors… If you look at the config page in CF, it shows arrow direction of motors. Red is positive. On the black/white motors, white is positive. Its hard to tell in the picture, but it looks like the props are on the correct motors, but in the wrong location.


There is an easy fix in cleanflight (set yaw_direction = -1) and betaflight (set yaw_motor_direction = -1). There’s no need to swap the motors around. I’m running yaw_direction = -1 on all my machines.


@Las nice one! That’s how to get the props to stop getting my cam dirty, I remember reading a discussion somewhere.
@chime13 there you go, problem solved?


Thank you Las! In Cleanflight the above command worked.

That did it!!! I’m doing pirouettes (me - not the bird, yet) Dammit guys - I love you!!!
IDKWTF I did wrong - but I guess I did it wrong…hehehe

I still think I’m gonna swap the motors so the brushes set in the direction they were intended to be - or am I wrong?

Cheers to all!


You’re motors are running correct directions.
Red/blue CW.
White/black CCW.
Everything is fine.

If you swap them, don’t forget to set yaw direction back to 1 or you’ll have same problem again.
But no need to swap them again.
Enjoy flying.


Thank you chrisdo - I appreciate the response. Ok, I’ll leave them alone. I just put the camera back on and battery and the weight comes in at exactly 50g. Let’s see how it flies. (lighter than my 2 lost crappy H107D+'s)

Even though I’ve read tons of stuff on PIDs, I wish there were general plain-jane-vanilla setups for this FC with 8mm motors. I do realize that it’s all highly subjective, personal and ever-evolving, but I think there should be a standardized set of parameters with expected results that could help in troubleshooting initial setups (at least for newbs like me).

Kind regards and thanks again!


Your motors were basically running in the opposite direction as your flight-controller software expected them to run. That usually confuses your pid-controller and turns your quadcopter automatically into a nice spinning ninja star.

The aforementioned CLI command tells your FC that the motors run in the opposite direction than the standard. Running them inverted from the cleanflight default is absolutely OK - I know about two reasons why one would do that by intent:

  • Less dirt on the camera (think about in which direction dirt from the ground is thrown)
  • Possibly slightly better aerodynamics on dead-cat configurations (I don’t know whether any proper measurements on this exist - but it works well as a placebo)


Brilliant! Thank you for the extra info - I truly appreciate it.
Since your last response, I’ve been experimenting with different PIDs - I’ve got to say, I’m very very pleased with the accuracy, stability and response of this bug :slight_smile: It’s a little more delicate than my Nano QX so, I’ll take it out more and more as I get proficient - in the meantime, I’ll continue to crash my Nano QX as I continue to develop my skills in ACRO mode….

If you wouldn’t mind giving me some further info:
Difference among, angle mode, horizon mode and airmode mode? I thought it was basically auto-level or manual flight modes.

Once again, Thank you!
You made my weekend (and spared my wife)



Angle mode:
ACC is active, indicated by blue led.
Self levelling with limited possible maximum angle of tilt. No flips and rolls are possible.
You can increase max angle through CLI command set max_angle_inclination=xxx.
Where xxx stands for degrees of angle. Default is 500 (=50 degrees) if I remember correctly.

Horizon mode:
ACC is active. Self levelling, but at the outer end of stick range max angle isn’t limited. So flips and rolls possible.
It’s a mix between angle and acro/rate mode.

Acro/rate mode:
Acc inactive, indicated by blue led is off.
If no other mode (angle/horizon) is active you’re in acro mode.
No angle limitation.
Full authority through sticks.
Quad keeps moving in last stick direction till you give input in opposite direction to stop/level it.

This is a supplement to the above mentioned modes.
If airmode is on the PID loop is active even when throttle is at 0. So you have full authority over the quad when doing manoeuvres with zeroed throttle, 'cause motors keep spinning at idle speed set through min throttle.
If you fly with airmode active, it’s important to immediately disarm when (or better before) you crash because motors keep spinning and you’ll burn motors and or fets if you don’t stop them.


Thank you @chrisdo
For the airmode explanation and disarm info. It sounds like it’s an improvement to acro.
(And I just got my head around the first three)…


Thank you @chrisdo for your explanation.

I only have 2 AUXs on my DX6i, AUX 1 for ARM/DISARM and AUX 2 toggles ACRO and Horizon mode. Unfortunately, there is no 3rd position on any of the AUXes to toggle AIRMODE and ANGLE Modes

In your opinion/experience, why/when would I want to use Airmode vs the other modes?

Happy Sunday to all!


Airmode is great when you fly full acro (rate mode), it basically allows for “air control” while the throttle stick is in the lowest position. I only fly acro/rate mode currently and don’t have any of the leveling modes (horizon/angle) configured (once you fly acro/rate they are no fun). Acro/rate mode is the default mode which is enabled when neither horizon nor angle is activated.

I fly mostly acro + airmode. It’s nice to gain some height and dive down while having the throttle on zero - still being able to control your machine. Without airmode (or something similar) the machine wouldn’t be controllable in such a situation.


Air mode you can activate with the motor arm/disarm switch so its always active when the motors are on. If you are just starting out, and want to fly safe, set your aux 2 for angle and horizon mode. Horizon seems to be the best of both worlds as it helps you keep somewhat level, but still allows you to push the limits a bit.


@chrisdo , just got my dx6 back and I honestly cannot thank you enough. You have helped me out an indescribable amount. You helped me learn how to navigate and set up my dx6 , and you helped me in this thread learn how to set up my scisky and get it in the air, without having to call anyone for help! thanks again man, I will do my best to follow your example and ham around these forums learning, and spreading the knowledge!