How to set up Scisky FC step by step


#141

So you got it working?

Here are some more things to consider if I you’re using a dx6i with a scisky.
http://community.micro-motor-warehouse.com/t/help-with-scisky-board-dx6i/1741/23?u=chrisdo


#142

I have strated flying my scisky fight control board today. I followed these build intstructions. However I was not able to get the board to arm with a stick command.

(Mode 2, left hand throttle and yaw)

Setup the Quad to arm with Aux 1, and that works well.

I don’t think it is my throws because I set them to 150% travel.

Image shows stick arming as throttle down and right but I thought I read a description that said to ARM move throttle down and to the left.

Which is it?

Any idea why I can’t ARM with Stick commands?

Thanks


#143

You may have to disable switch arm just like if there is no modes it on acro. I think to the right is arm.


#144

Down right is correct.

What are your throws of min throttle and max yaw in receiver tab?


#145

Yaw from 991 to 2005Throttle from 992 to 2001


#146

Does the Micro SciSky support servo control?


#147

followed this write up on a scisky micro from banggood and couldn’t get the quad to arm via sticks or aux on battery, although in CF the config worked fine. re-flashed with naze 1.13 and motors spin on power. re-flashed alienwii 1 after watching a youtube video on scisky setup and now arms fine with aux 1. haven’t tested sticks yet as all motors spin counter clockwise when armed. haven’t torn the build apart yet, but the motors were previously used with a blade nano qx fc and worked fine. the blade fc’s have the ccw in top left and lower right (black/white) but i changed to red/blue to motors 4 and 2. since all are spinning in one direction i’m questioning the polarity of the connectors since i bought the one that had female micro jst so i didn’t have to cut my motor wires and solder. i’ll probably tear it apart to verify polarity of the connectors on the fc since this doesn’t make any sense. figured i’d post just in case.


#148

2 of the connectors are on backwards on the boards from Banggood, if you look closely on the board you can see the plus sign by each motor position. Swap wires over on 2 motor plugs and you’ll be good to go.


#149

thanks chaotix i did notice that this morning and can confirm after changing the connectors the motors spin in the right direction. i’m using hubsan 8.5mm replacement motors with an eachine 110 frame. i think the whole unit is a little too heavy as after i adjusted PID and RC Rate settings using MultiWii 2.3 it barely takes off but is controllable. i’ll check AUW before i tear it apart. i’m printing a whoopee frame too see if this is a weight issue or if i still need to find some different firmware. as a side note, i was not able to get any of the betaflight firmware to work either. the last alienflight 4 i tried left me bricked until i can jumper bootloader back to cf alienwii 1. yay! :slight_smile:


#150

Also make sure in cf receiver tab that your tx gives full throw ie. throttle goes from 1000 or just under to 2000 or just over, this is adjusted on whatever transmitter you have rather than in cleanflight. Weight and prop choice makes a big difference too.


#151

using the dx6i and travel adjust all to +125 i was able to get min/max 1062/1947. I ran these motors on a 3d printed frame with blade nano qx fc and hubsan clear props (ordered the fpv flight controller but it’s not what i received so i had fc resets on crashes and erradic flight sometimes due to the 8.5mm). when this setup did fly, it seemed too heavy. i’ve got some gemfan 65mm props on order, just waiting for them to arrive.


#152

I have a DX6i, too, and at the maximum +125% I’m only getting to 1850 maximum, which doesn’t seem to be enough to arm the quad. (I’m using a switch instead, but since I seem only to be able to use one switch, that means I can’t toggle between modes…)

Is there anything else I can do to increase the throw beyond what’s on the Tx?


#153

Try the “rxrange” settings in CLI


#154

Hey @tomchaps
I also use a dx6i, and just going to assume that you also adjusted -125 also. So in other words from the TX wheel over the + and then move the stick opposite to get -, then adjust to -125. Then I had to use sub trim to get in range. I’m at work now but when I get home I’ll check my settings if you need.


#155

So, to make sure I understand the CLI commands: I measure the endpoints on my Tx, and enter “rxrange 0 min max” with those numbers and it will magically remap those to 1000-2000?

I found the Github a bit vague, and wanted to make sure:
“Now reboot your FC, connect the configurator, go to the Receiver tab move sticks on your transmitter and note min and
max values of first 4 channels. Take caution as you can accidentally arm your craft. Best way is to move one channel at a time.
Go to CLI and set the min and max values with the following command:
rxrange <channel_number>
For example, if you have the range 1070-1930 for the first channel you should use rxrange 0 1070 1930 in
the CLI. Be sure to enter the save command to save the settings.”


#156

Yes, exactly. You got it right :slight_smile:


#157

@tomchaps, @thexboxblaster
Thank you both , I just learned something. I totally missed that. I am now going back and re-reading straight from clean flight and get hub instead of just following directions ,allbeit good ones that got me in the air.


#158

I have the new version of the Scisky board. To set up this DSM/DSMX board with a Spektrum DSMX Tx some settings in CF need to be different. Choose SPEKTRUM2048 and RX_PPM on the Configuration page. (I also had to alter the Channel map on the Receiver page).


#159

Very interesting that they now seemingly use PPM instead of serial for the RX. That could free an serial port - such that you could maybe very easily attach any SBUS FrSky RX to UART2.


#160

Greetings! I built a micro quad using this FC/RX on a 110mm cg frame - 8.5mm -with Hubsan props.
I was able to bind it with my DX6i and setup the sticks with relative ease using all the different directions and recommendations found here and elsewhere.
The issue that I am having is that no matter what I do, or whatever mode I choose, the moment I give it throttle, it just wants to spin (yaw) in place (cw or ccw) and if I leave it long enough, it’ll accelerate and try to fly away like a spinning plate. I can’t get it to stop spinning. Once I get it going cw, trying to center the rudder just make it go the other way. There is no straight! :slight_smile: I flashed the board with AlienWIIFI1, Naze and no matter what I do, it just wants to spin like a top in either direction. Holding on to the quad down and giving it throttle, I can verify that the controls are working correctly. I verified the motor directions, props, but to no avail. Any help would be appreciated