How to set up Scisky FC step by step


#121

If I want a guaranteed bind I have to power the devo first then the scisky, do it the other way and I have to use the tx menu to bind and it only works about 75% of the time.


#122

I have been using Scisky for a few months and never had any problems with binding. Occasionally it wouldn’t bind for whatever reason (most likely the wrong power up sequence) but it would bind the next time. It always worked regardless the distance - from working at the desk which is about 20cm to binding with the quad on the floor (1.5m - 2m). After reading the suggestions I have tried altering the distance but it didn’t work. Also, on the Devo I have tried using all the power settings, built a new model from the scratch, changed the binding ID, removed the ID altogether and still nothing. I have flashed different versions of the code (Betaflight, Cleanfligh, older AlienF1) and still no luck.

Unfortunately I don’t know anyone close by who has a DSM radio/receiver combo. Next step I want to try is to flash a Naze target firmware and manually play with CLI binding commands. As I don’t really think it will work I may try a satellite receiver mod as I have a little Lemon DSM2 sat receiver.


#123

I am new to this and have been attempting to set up my scisky for a couple days now. Everything appears to be correct based on recommended settings that have been posted, but I cannot get the FC to arm. I have tried with a toggle as well as with stick commands, with no luck. I assume it has something to do with the transmitter end points as have been mentioned several times in the post that I have read. The transmitter I have came with a RTR ultra micro plane setup that I had previously acquired, and I don’t believe there is anyway to adjust the endpoint. The transmitter binds fine. Cleanflight shows the appropriate reactions to the transmitter inputs. When moving the sticks to the max throws the indicated values in Cleanflight run from about 1150 to 1850. any suggestions:? the transmitter is an MLP6DSM.


#124

I don’t think that the CLI binding commands will trigger anything on the onboard RX.
Does the onboard RX go into the typical binding sequence (fast flashing red LED after ~10sec without TX on) at all?.

@Ryan_M:
What is min_check / max_check set to? You could try “rxrange” to fix the endpoints - that usually works - even with random toy transmitters. I additionally set small_angle to 180 - because I don’t care (read the docs on what that does before setting things like that - really).
There are various reasons why a FC wont arm:

  • not level (put the quad on a level surface, ugly fix via small_angle - also: check accelerometer calibration!)
  • throttle “not low enough” (min_check / max_check / rxrange)
  • battery low with VBAT feature enabled? (not 100% sure about that one)
  • TODO: EXTEND THIS LIST PLEASE

#125

Not sure about that. But I think you can adjust rx range in CLI to match your max/min throws.
If you do a CLI dump, somewhere you’ll see

rxrange

rxrange 0 1000 2000
rxrange 1 1000 2000
rxrange 2 1000 2000
rxrange 3 1000 2000

Which represents your 4 channels.
If you set each one to 1150 1850 you should be able to arm.
Maybe you might have to adjust your min command, min throttle and max throttle values too.

Never did that, but read that it should work

See Receiver Channel Range Configuration at the end of this site

If you wanna stay with this hobby really think about getting a good tx. There are several options out there, from cheap to expensive.
A good tx is one of the most important things for enjoying this hobby.

Edit: @las du Fuchs.


#126

Yes. Slow flashing for 10s and then quick flashing.


#127

And it doesn’t turn to solid red when you set your TX to bind?
Because - if it does - your TX and the RX are bound and it’s possibly some bad connection between the RX and the STM32F1.
Can you rule out problems on the TX side?


#128

@czajunia, as you’ve no other dsm2 boards to try one other thing you could do is reflash the latest deviation firmware just in case the devo has lost the plot. I’m thinking there must be a way to get the Scisky to report various status such as tx functions, I wonder if as it’s an stm chip that accessing debug via Keil tools or something might work. Anybody more knowledgeable than me on this please chip in :grinning:


#129

I did that yesterday. Even though it didn’t make much sense to me as all was working fine before. On the other hand though I thought it wouldn’t hurt.

I have PMed an RCGroups member who knows his way around KeilTools. Even though he doesn’t have a MicroScisky he may be able to point me in the right direction. Will see how it goes.


#130

I was going to suggest that :slight_smile:


#131

So i fried one of the esc’s (shorted the contacts) but I did get the board to arm. Thanks so much for the help. I’ve been banging my head against the wall trying to figure it out. In regard to the transmitter I had planned on upgrading, but the wife isn’t particularly thrilled with my new found money pit


#132

All sorted. Turned out one of my TX modules gave up for some reason. Weird thing was that my radio wasn’t reporting any errors and all seemed to be working OK. Still, I have no idea what happened and why it stopped working all of a sudden Luckily I had an old module that I replaced with the one that died still lying around.

Thanks a lot for your help.


#133

Always good to hear a successful outcome. I think heat can get to these things eventually like lots of electronics but particularly tx stuff, do you wrap them in heatshrink inside the Devo?


#134

The module that died wasn’t wrapped in anything. It was quite large and had a big metal shield on it so it shouldn’t overheat: http://www.walkeraonline.com/walkera-wk-devo-s-mod-devo-8-or-12-to-devo-8s-or-12s-upgrade-module.html

My 2 other modules are in heatshrink actually.


#135

I thought about it a bit more and maybe you are right. The module was a bit larger and was installed using double sided tape so it was closer to the batteries that way. I don’t think they get hot when charging but maybe the combination of factors caused something to overheat inside. Even though I have no idea what to look for and how to test the components inside I think I will open the shield to check what’s going on inside. Why not? :smiley:


#136

Same, I have plugged in my battery and USB at the same time with no bad effects.


#137

I’m having some trouble setting up a custom motor mix for my custom 3D printed quad frame. I would greatly appreciate any help you guys can offer.

Link to full detailed discussion: CleanFlight H Frame Quad Setup Help!


#138

I have a little problem with my scisky. I failed to make do with my DX6i bind. Any idea what the problem is or scifly defective.


#139

So you have a dx6i which has dsm2?
If it’s dsmx only it isn’t working.
Check menu “modulation type” on your tx and set it to dsm2 if possible.


#140

This modulating Dsm2.
Thanks chrisdo