How to set up Scisky FC step by step


Even Though the dx6i can only be at lowest on 1080 ?
Is the max okay? Thanks for the quick reply.


As far as I understood all this CF stuff from reading about it and messing around, min command is the value sent when board is disarmed and no throttle stick input is applied. So I assume that has nothing to do with your channel throws. Even when your tx is off, that value is sent.

You could/should raise your max throttle too, to get full power. If it’s set below your max throttle stick throw, you loose power because throttle stops at 1850.

Set your min throttle to 1000, max throttle to 2000 and min command 1000 and you should be fine.
If that doesn’t work, which I doubt, set min throttle to 1080, max throttle 1947 and min command 1000.

Have to add, that I’m not a CF expert and maybe my explanations might be not that elaborated or even somehow wrong. If somebody could explain it better or in a correct way, please chime in.
Most of my knowledge is based on trial and error while messing around with all that stuff. And it applies to brushed micros. On brushless builds all this might be somehow different.

Let me/us know if my suggestions work for you and got you up in da air.


Chrisdo I just built my first Scisky/reggea shark controlling with a Specktrum Dx6i, spent a shit ton of time programing it and figuring out the control as this was my first non Hubsan X4 or H111 Quad copter. The solution to motor turning on ARMing for me was to internally trim the controller until cleanflight indicated that my throttle was actually below 1000. I hope that helps.


Thanks Guys :slight_smile:
Finally got control over arming and no problems but one (seems like It never wants to end)
My quad is 60 Gramms heavy (with battery and fpv) but doesn’t want to lift with a 35C-70C 700mAh nanotech battery. A few days ago I accidentally pulled the 2 wires of the battery out… I know really stupid from my side and it touched and gave a small spark. I know it was for less than a second but I think it’s because of that it doesn’t want to lift… Guessing I have to buy a new one but hope I can still use it for something. Can someone confirm it’s because of that?


Not sure if I understand what you’re saying. "solution to motor turning on arming"
What exactly was your problem?

If you trim down your throttle on your tx to come closer to min value of 1000 in receiver tab you also decrease your max throw. This results in not getting full throttle power when your stick is all up. So your quad will not be as powerful as it could be on full throttle.

Also you don’t need to get your throttle below 1000. Minimum 1000 or slightly higher is ok.
To get your channel throws on all 4 channels as close as possible to min/max 1000/2000 you need to go to travel adjust menu on your dx6i and increase all stick directions to 125%. Hold the stick down and increase the travel, then push it up and do the same, also do this while holding it to the left and after that to the right. The little arrow will indicate direction. Do that with both sticks. Then your values on receiver tab in CF should as close as possible to 1000/2000.

If center stick on all channels isn’t 1500 you can use subtrims on tx to match 1500 at center on both sticks.

Also check your monitor in tx menu with all trims and subtrims centered. If max and min endpoints and center stick are off you should calibrate your sticks.

Said all this I fly my sciskys with a dx6 and have absolutely no problems.
I used my old dx6i just once to help out a forum member in the German thread.
Setting up the dx6i wasn’t complicated and it worked like it should.


guys im new to the Scisky board, I plugged it in first time and it connected to cleanflight but now when I plug it in I only get a red light flash slow then after a bit it flashes quick, I believe this is bind mode,

Can I just connect to cleanflight or do I have to bind it first, and if I connect a satellite up to uart 2 as I can only run dsmx will this follow the board and go into bind mode.


You don’t need to bind a tx to connect the scisky to CF.

When you plug in your FC via usb is it recognised by your computer? Do you hear that badam sound? Can you see com port in your device manager?
If so, you should try to flash it with Cleanflight with jumper on the boot pads. It’s easy, here is my thread how to do it.
I would choose the newest Alienflight F1 firmware. It’s working great, no drift issue in angle/horizon.

If your computer isn’t recognising the board at all (no sound when plugged in and no com port shown in device manager) than your problem most likely isn’t easy to fix. Had this with one of my boards too. Maybe defective silabs chip or defective usb. Whatever, no chance for me and my specialist to fix it.
Made a video and asked seller (Banggood) for help, and got a new replacement board from them.
Here’s my thread about it.

Unfortunately you cannot just connect a dsmx satellite to UART2. This wouldn’t work.
If you are really skilled with soldering, you can do this mod to make it dsmx capable


Thanks Chrisdo. I ended up re flashing with cleanflight and I can connect now.

Surprise I had was the scisky bound to my dx9 with the latest firmware. I can’t bind to dsm2 receivers but it bound to this.

Oh well I’m not complaining. Lol


If you don’t have an EU transmitter that’s just normal. If you have one, you are lucky to have one that still works. :wink:
Or they changed the scisky to support DSMX - I don’t think so - but it should be possible.


You’re saying you cannot bind to dsm2 transmitters?

Isn’t your dx9 dsm2 compatible?


Can’t bind to dsm2 receivers

Newest firmware in Europe does not allow dsm2 on the dx9 or new spektrum transmitters.

So I thought it would not bind but it did so I’m happy.


Jep, know about that EU dsm2 ban. I’m from Germany.

If you got your dsmx dx9 bound to your FC is it really working correctly in CF Receiver tab?


Chrisdo yes it does seem to be.

One is very happy :blush:


Do you know if there is a way to troubleshoot DSM receiver on the Scisky? I am not sure what happened but after flashing the latest AlienFlight F1 and making all the necessary changes I can no longer bind with my Devo transmitter. It was all working fine a couple of days ago when I last flew the Scisky but for some reason it stopped. I haven’t made any changes to the radio recently and only flashed the Scisky. It’s not the AlienFlight issue as I have tried reverting back to the previous FV version, flashed older versions of Cleanflight and AlienFlight and have no luck either. Also, I have changed the power settings on the radio, FixedID to none and different numbers with no effect. A bit confused as I have never has issues with binding.

Thanks for any suggestions.


Mmh. :thinking:.
I assume the red led is flashing fast, right? So the rx is in bind mode.
Did you select Serial rx and Spektrum 1024 in CF?

Devo batteries charged?


Yep, all checked. The red LED is flashing fast, green one slow. Spektrum is 1024 and the UART2 has Serial RX enabled but that was already selected by default after flashing the AlienFlight. Yes, Devo fully charged and I have tried different output power settings. This is so bizarre.

I don’t think such a thing exists, really, but I was wondering if there was some kind of low level format available that would reset all the sensors?

EDIT: Added a CLI dump just in case. (2.6 KB)


The RX on the SciSky is basically a separate circuit on the FC. It is somewhat a strange satellite receiver which automatically goes into bindmode by itself after a certain time. The standard binding procedures you use with other satellite receivers (like the LemonRX) don’t apply here.

In case the RX is really broken you can still attach a “real” satellite receiver to the SciSky (See the DSMX Satellite Mod thread).


Thanks for the info. As I have a sat Lemon receiver lying around and tried to see if it was possible to connect it to Scisky I have already come across your DSMX satellite mod thread. Before attempting the mod I thought I’d wait and see if there are any other suggestions. I guess that’s probably the only way to check it.

I still don’t quite understand why the Scisky receiver would stop working all of a sudden.


Just had a quick look at your CLI dump. Concerning rx relevant settings it seems to be ok.

Did you try different distances of Tx and fc while trying to bind? Sometimes you have to find out what distance works best for your combo.
Some report they have to bring both antennas very close together or even touching each other (didn’t work for me).
My way is to bring FC in bind mode, then move my Tx 1-2m away, turn around to bring my body between rx and Tx, then power up Tx while pressing bind button. Works nearly every time.

Don’t know how bind procedure with a Devo works exactly 'cause I’m using a Spektrum dx6. I always have to power up FC first and Tx second.
I can’t imagine the scisky rx is damaged because of firmware flashing.
Maybe try it with a new model from scratch on your Tx.

Do you have a friend with a dsm2 capable Tx to test if it’s working with another Tx?

Good luck.


Agree on the FC first, TX second part. Other than that I didn’t have any major issues binding anything yet - usually roughly 1m distance - random orientation. If it doesn’t work - I just do it again. Dx6i & Taranis with DIY DSMX Module.