How to set up Scisky FC step by step


What’s your actual tx?

Anyway, the red led should work.
Also if it’s not working and the onboard rx is ok, you should be able to bind it.
As said plug it in, wait min 10 sec or better 20 to be safe it’s in bind mode. Then power up your tx with bind button pressed or whatever is the right way to do it with your tx.

If you set the FC to Spektrum 1024 and receiver mode to rx_serial before, it should work. If not, there might be a problem with the onboard rx.
Did you inspect it with a magnifier?
Maybe you can spot a loose leg or bad solder joint.

Also it’s always good to test the FC if it’s working before soldering stuff on it.
Should include that hint in my tutorial, but somehow I’m not able to edit it anymore.

Another thing:
Send a video to BG customer service showing that the red light isn’t working. If possible include a pic of your shipping label. Normally it isn’t a problem to get a replacement without sending the faulty one back.


I currently have a eflite mlp6dsm tx, and unfortunately I ordered a devo 7 not a devo7e. So now I have 2 useless tx lol! If my next scisky has a bad led, I will make them replace both. I am about to sell off all of this quad stuff if I don’t get my first build in the air soon… getting really frustrated


As far as I know the mlp6dsm is a dsmx transmitter, but nor sure. If so, it’s only backward compatible to dsm2 with hobby horizon/ blade stuff.
So it shouldn’t work with a Scisky dsm2 onboard rx.
You wouldn’t be happy with that tx anyway, trust me.

But all this has nothing to do with your red light problem.
Ask for a replacement. Don’t wait.
But if you (or a friend) have a dsm2 capable tx it might bind even with a non working red led if it is not another problem. Rx maybe.

Couldn’t you cancel the order of the devo 7?
Otherwise just order a different one and sell the devo7 as new when you receive it.

Don’t give up mate. We all have our hassle with this micro stuff. Believe me, it’s worth the setbacks if you get all worked out.


Hi Guy’s i’m new here. English is not my native language so forgive me for any gramamar mistakes.
I have found this threat because i’m looking for help with setting up my Scisky FC/Quanum micro.
I’m hoping you can help me out.

So my setup is as follows:

-Futaba t9cp super transmitter (set to PPM)
-OrangeRX dsm2 switchable futaba module(see link below) with switch2 ON the rest is set to OFF
-Cleanflight Configurator

Now i can connect to the Scisky board with cleanflight by usb and i can get my futaba to bind with the board. But in the Cleanflight receiver tap there is no throtle readout.
So i can’t control the board with my Futaba.

Cleanflight setup:
-Receiver Mode is set to: RX_PPM
-Serial Receiver Provider is set to: SPECTRUM1024
-Channel Map is set to AETR1234

I’m getting a bit desperate…:sunglasses:
Am i overlooking something?

Kind regards,



Chrisdo, thank you for the info and encouragement. I received my other scisky today and will bench test it tonight. I also ordered a devo 7e today.


Ok, not much Futaba users around here.
I also never had one in my hands.

You’re saying you can’t see any throttle input in your receiver tab, right?
Do the other channels (roll, pitch, yaw) work like they should?

Checked the link of your module, and description says it has a selectable channel mapping for either TAER1234 or AETR1234. Try setting it to TAER and change that in CF receiver Tab too.
Also make sure the module is set to 1024.

Don’t know if that will solve your issue.
Just trying to help.


Hello Everyone! Long time follower first time poster. Because of this thread, I have been able to build and tune my first micro quad using the Scisky FC. I have been flying with this FC for a bout 5 days now but something just happened that has gotten me confused.

I have searched this entire forum with no answer. Basically, today I was fine tuning my tune and all of a sudden, my FC lost connection with CF. I rebooted my computer, reconnected my FC, changed micro usb cables and I keep losing connection. There are times where it will connect for 5 seconds, then lose connection.

I was using BetaFlight 2.7.1 AlienF1. I am trying to re-flash my board now with the latest stable CF build of Naze or Alien but I just cannot connect. When it does connect with CF, it loses connection after 5 seconds and just hangs.

I have no idea what is going on. I did not crash for a couple of flight when this happened so I know it is not that. The last thing I remember is having the FC connected to my computer for about 15 minutes while I was reading about PID tuning and Rates. While I was trying to save my recent changes to my tune/rates, it hanged on me.


I forgot to mention. The FC still works as I have been flying it around. Seems like my PIDS are still intact when flying in acro. Also, the FC still remembers my ACC trims since the quad is still very stable when flying in angle mode. The FC, from what I can tell, still functions fine.

Only problem is connecting to CF.


Now I think my FC is done. After trying to connect and reconnect the usb to the FC, the green and blue lights stopped flashing. I disconnected the usb cable from the FC and connected a battery. Same thing, both the blue and green lights no longer flashes.

The FC still communicates with my transmitter because the red LED stopped flashing; bounded with my transmitter, but now it appears the FC does not work because motors no longer spins. Arming or disarming does not work and the blue and green LEDS no longer flash. I have no idea what is going on.

My next course of action is desolder everything and go over the FC to see if I can visually see anything wrong.


Me had a similar problem.
Couldn’t connect the board to my computer anymore. No badam sound from PC when plugged in via usb.

Couldn’t solve the issue. Tried to flash it with an android tablet and cleanflight flasher, no way. Assumed the silabs chip might be faulty. But not sure.
Surely it isn’t a software problem. Think it’s hardware related.

But BG sent me a replacement after I sent them a video of the issue. Try that too.

@las offered his generous help but couldn’t solve the problem with cleaning and reflowing. So he came up with a great idea which isn’t that easy to do, despite you have some magic hands, ideas and soldering skills like @las has.
Stay tuned. The outcome of that endeavour will (hopefully) be published soon in the above linked thread.

Sorry I couldn’t give you an easy solution for your problem.


I bought my SciSky from Dave Woods at Picnic Quads. I’m not sure he will or can help. I went with PicnicQuads because he has the cheapest SciSky boards in the U.S.

I originally ordered a SciSky from the U.S. Banggood store but I requested a refund after 1 month and it still never arrived. This sucks. I was getting a lot better flying acro too. Now I have to wait again and just fly my fpv free rider sim.



I did this: Flashing Scisky- bootloader corrupted - solution

Thank you @chrisdo!!
I used the tweezer method. I just placed the tweezer ends on the two metal contacts used for bootloading and SURPRISE… CleanFlight recognized my Scisky again. I flashed to the latest stable Naze firmware.

I will no longer try Betaflight. Betaflight is just that - “BETA”. Im not a techie so I will not mess with it anymore. Plus, it is obvious to me now that Betaflight is what caused my FC to hang and not be recognized by CleanFlight.

Sticking to stable CF from now on.


Hi there, hmmm that sounds bad - usually almost everything with the blue and green LEDs flashing is fixable.
The fact that the RX is still communicating basically just tells you that the RX unit on the FC is still working - but that’s an almost completely separate “module”, the rest might be completely broken.

Does the PC still see a COM port from the FC? In case of @chrisdo’s FC the silabs chip responsible for USB seemingly stopped working - I replaced it with a standard serial UART port instead.
Did you try to short the bootpads and flash it again?


That’s great to hear.
Cool you solved it. :+1::+1:.

So I was wrong with my assumption about a hardware problem.


Board works properly, 43.9g weight with 500 mah battery on board. My devo 7e should arrive tomorrow. I am excited to fly it


Can I use alienflightf1.hex on this board?



Got it from up there


Alien flight feels weird to me…or maybe I’m just use to a 5 inch quad with like 8:1 power to weight ratio…


Great post!

Some questions:

Using stock firmware as shipped from banggood, my lowest motor speed at idle is undesirably fast. I can fly ok, but I like to be able to spool up from very low rpm. I’ve risked battery with USB connected, so I can spool motors from CF. Using CF I can spool as slow as I want, but all radio settings I’ve tried spin up the motors to nearly take-off.

My next thought is to try different firmware.

  1. Is it possible to download the stock firmware from the FC to keep as a backup?
  2. Is a setting available to control the minimum rpm at idle?
  3. Another reason I’m thinking new firmware is that CF settings for flight mode assignments are lost when I click “save.” Is there another issue that might resolve this?


seriously need a video that goes through this step by step… i have everything i need to get this in the air, but cant get this fc configured and working properly. bound up to tx and plugged into cleanflight and went through complete process as stated above. got nothing but solid red bound light and flashing green when in cleanflight. move tx sticks and nothing happens on rx screen. devo 7e with deviation v5 installed. im ready to throw all this stuff in the trash… anybody have a link to a useful video or guide to get this scisky from package into the sky?