How to set up Scisky FC step by step


#21

I continue to do it. I used it for some tethered logging (which is unhelpfully not in blackbox format) which included hovering. And I used it when I set min throttle. But mostly I plug in powered up because I hate unplugging batteries. F-u JST. I’m lazy and it works. Makes changing PID values less painful. (I haven’t setup the weird stick adjustments yet).


#22

It may or may not be significant that I’m plugging the other end of my usb cable into a Macbook Pro.


#23

Nah, its still 5v usb, the computer end shouldn’t matter, I don’t think that Macs have any special protection on the usb. This is good to know. I wonder if there was a revision to the board at some point after the initial release.


#24

I bought mine sometime in Dec from BG.


#25

I also got mine mid december.


#26

cool thanks for this thread, it helps alot since i had to dig through the other one to find this list. If it’s ok with you i’m going to link this thread in the review video i’m making.


#27

@illpoet for sure it’s ok to link it. Please post your video here too when it’s done.


#28

I have plugged in the computer and the battery multiple times and never had any smoke and I did test the motor outputs on cleanflight and it worked just fine. However, I am not sure if it is related or not, but a little while later while using it the board totally shut off. I can no longer connect to it via battery, only through USB… Pretty sure this is due to a burned up inductor.


#29

Did you resolder your power leads to be sure that isn’t the cause of your problem?


#30

Not yet but that is my next step in eliminating all other possibilities besides the inductor. lol same convo over two threads at the same time :sweat_smile: I just cant get enough of this hobby!


#31

I can not get stick commands to work on the DX6i? Ive tried everything. My travel adjustments are +/- to 125 in both directions. On config page i have min=1000 mid=1500 max=2000. On receiver tab my rc is reading my trottle min = 1038, mid = 1475, max = 1916. Im trying to trim the board with stick commands instead of using rx but i just cant seem to get anything working.

EDIT:
I figured it out. So anyone else with DX6I with the same issue go to the CLI and type in the following

rxrange 0 1050 1950
rxrange 1 1050 1950
rxrange 2 1050 1950
rxrange 3 1050 1950

Since the DX6I does not have the ability to hit the 1000-1500-2000 marks it just causes problems everywhere. This will actually adjust the program to the rc’s range. Hope this helps someone.


#32

@Droopydroors … I just went through a similar issue not being able to use the stick commands with the DX6i. When I was setting the travel adjustments, I was only setting them in 1 direction. Must move the stick in each direction and adjust to 125. Stick commands have been working fine for me since then.


#33

@bubbak yes mine are set in both up,down,left,right directions. I actually did read through your post and mine were still not working. But doing the above fixed the issue.


#34

@Droopydroors… OK… I’ll keep those settings in mind… Seems like the DX6i may be a bit fussy.


#35

I just got a scisky from bangood. This is the first time I have configured a fc. I cannot get it to go into bind mode. I soldered on a power lead and 4 8.5 motors. Plugged in a battery, I get green flashing light and blue light, but no red light. I plugged into a pc on cleanflight, but also only get green flashing and a blue light, no red. What am I doing wrong?


#36

@Skootetrash74 have you set the receiver tab in cleanflight?


#37

Maybe a faulty red led.
Plug it in via usb, wait 10-20 sec. And try to bind it even without blinking red.


#38

Good point, never thought of that.


#39

I am waiting for a new devo 7 tx to arrive. My current tx may or may not bind with the fc. I did go into the reciever tab on cf, set it to spektrum Jr etc… it still won’t show a red light. I suspect the red led could be bad. I also have another fc coming from banggood.


#40

If you have indeed order a Devo 7, that was a unlucky choice!

Hope you mean the 7e because Devo7 is not supported by the Devation firmware. In case of that you can not flash the firmware to get DSM2/DSMX support.

See the link below…

http://www.deviationtx.com/forum/stock-firmware-help/5833-set-up-a-devo-7-not-7e-with-a-syma-x5sw?screenMode=desktop#48055