How to make Mac OS El Capitan talk to USBasp

When I updated my workstation to El Capitan, I could not see the serial ports for my Alien FCs and USBasp programmers anymore.
Here is the solution: https://www.kiwi-electronics.eu/blog?journal_blog_post_id=7

Just in case above post disappears at some stage, here is the important bit:

Reboot and press CMD+R immediately after hearing the startup sound to boot to Recovery Mode
Open Terminal
Execute the following command: csrutil enable --without kext
Reboot

1 Like

Above made my Aliens re-appear via USB, but a plain USBasp is still not recognized.
I went all in and did the following to install all potential dependencies.

  • install XCode from Appstore
  • install Homebrew from http://brew.sh/
  • brew up the following stuff:

brew install avrdude
brew tap larsimmisch/avr
brew install avr-libc

python setup.py

  • open XCode
  • create new project
  • select OSX, xavr
  • click next

I read that install all I need.
Still no go, I cannot see a USBasp connected.
In Arduino port selection, it does not turn up.

If anyone successfully uses a USBasp on El Capitan Mac OS 10.11, please let me know!

@Benedikt just in case you can’t find an OS X USBasp solution right away, you can always use Parallels, VMware, or Boot Camp and install a version of Windows with the most reliable Java/Arduino release.

I would so love to help, but my knowledge of arduino/usb asp is nil…
I did actually get some in the post today, not open yet. I’m a bit filled with trepidation about it. I need them to flash esc’s. Going to be interesting tonight. I don’t even know which things to use haha.

Edit. Sorry to not add much, but I was excited.

Yeah… sigh that probably what I have to do.
I was doing VMWare infrastructure support and consulting for quite some time. Switched to Parallels for my private VMs.
Apple really picked up the game over the last years, and the apps I have to run on Windows get fewer and fewer.
But when thinking about it, I remember I also had to flash my radios using CompanionTX on Windows.

Looks like you are full steam ahead on your way to full expertise :wink:

1 Like

I believe this is your desired effect.(shows as SLAB_USBtoUART) just not sure if this is exactly what you need it to be. Here’s where I bought mine.
http://www.ebay.com/itm/131650527654?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT

Is this what you have/are talking about?

because its a cp2102, here is where i got my drivers. not even sure that i needed these but i got them and ran the installer before device arrived. (i like for things to “just work” when i get them.
I use this to connect my beefs board to cleanflight.

maybe your device requires this

maybe here can help.