Micro Motor Community

How to figure out no FPV video on googles


#1

I have a furibee x215 pro racer drone and I have been learning how to fly it (my first drone), I did not crash anywhere real hard but I finally got my FPV googles eachine EV100 to start with but I am getting no video, just black screen.

I have been trying to figure out what might be wrong but no luck since then.
I do autosearch on googles, it picks up signal but not at the frequency that my vtx is streaming (I compared vtx frequencies table with google frequencies table from documentation). Sometimes it does find the correct frequency, but mostly not. And I get only black screen with frequency on googles. When I switch to other channels on googles, sometimes some of them are black too and most is just noise.
Also, when I do autosearch, it finds a signal (correct signal from vtx), Im getting black screen, I turn off googles, turn them back on and they show noise on the same frequency (before I powered off). So there is some magic in it :frowning:

There was a connector on the pcb which fell off so I soldered it back (before I tried googles) , but I thought that I might solder it bad and it was hard to take it off, so I soldered camera wires directly to pcb pins.

Now real deal is, on the website where I bought drone https://www.gearbest.com/brushless-fpv-racer/pp_708379.html description says, that camera needs 12V DC input voltage. Whats weird is that the power that goes to camera is only 5V and that was original when I bought it. So I am not sure if they made a mistake (which I doubt since nobody had ever problem with it) or it can work on 5V. When I power on the drone, after a minute or two I can feel that camera is getting warm a bit so it should be working.

Now, what can I do to figure out, whether my googles are bad or some part on the drone? I have no other camera to try out or googles or vtx. Just one drone and one googles.

Thank you all for help.


#2

Welcome! Not sure if you have seen this, but it looked like it might help. https://www.rcgroups.com/forums/showthread.php?2961326-Furibee-X215-Pro-Another-great-budget-FPV-racer-(review-work-in-progress)
The author, SoloProFan, says that he had vtx issues as well and then switched to the ‘high power’ setting. Another thing that I thought of is that your vtx may be shot. You say you have static in the goggles, and are on the right channel, so that could be it. Try checking with a multimeter to see if that’s the problem. With the channels that are black, double check you don’t have a lens cap on the camera. It happened to me before :sweat_smile:The esc doesn’t have a manufacturer, but looks similar to the holybro one. It makes sense that it would be that one, since the FC is holybro.
Can we get some pictures of the esc, FC, camera, and vtx? That will help a ton with diagnosing the problem.


#3

Hi,

I switched to High power but that did not help, still black picture… Yea lens cap is off for sure, no worries there :smiley:

I set the frequency on vtx to 5705 like that guy in link you posted to see if googles find that signal as strongest and they did find it but black picture. I turned off googles (drone still on) and turned googles back on and as they remember last frequency, it was still 5705 but noise, not black anymore. And that happens all the time.

I checked for static electricity but doesnt seem to be there.
I also checked for continuity on the wiring and I am not sure if it should be that way but when I check camera wires (red, blac, yellow), I attach red wire from multimeter to black, and I check for continuity on red, black, yellow, and I get beeping on all 3 so seems like they are all connected, is that okay? If I do it for all 3 wires, same results.

I have also walked in the house with my googles on and drone in my room, the further I went away from the drone, video in googles was changing from black to some random colors black, noise, some strips of rgb but just really quick changes, so I think there is a signal but what can cause no video??

What if the vtx is bad? there are no spare parts for this drone. VTX is kakute F4 V1.4 but from different manufacturer, since I contacted Holybro and they told me that. And it also looks a little customized so its not exactly same as original kakute F4.


#4

Was this a DIY or a RTF? If it was a DYI I have seen the black screen when the incorrect voltage is supplied to the camera or Vtx. If it was an RTF then it should not be that issue and I would assume you have a faulty Vtx or camera. I would lean towards camera since if you get that black screen it means the Vtx is sending a singnal, if it is not sending a signal it will be all snow on every channel.


#5

It was RTF. I have ordered new VTX, should come in a few days so will see if that solves the problem. But yes, your idea makes sense, but since its very easy to blow up VTX (mostly without disconencted antenna) it might have happened because I dont remember if I had antenna on all the time when I powered on the drone. I will post an update as soon as I get the VTX.


#6

Maybe osd in betaflight in the fc needs switching on/off.i had sumilar prob with the f4 v5 pro aio/vtx all in one they sell on banggood,its got the vtx built in,i was using a swift 2 and could only get a black screen till i messed with settings in betaflight.
:smile:


#7

Only quickly read through the thread but black screen usually means the VTX works but it’s not receiving image from the camera. So it just transmits a black screen. So I would check the connection between camera and vtx, or try another camera.

Don’t know about you guys, but this looks really sketch to me and seems like the connection to the camera. I would strip and resolder those.

temp


#8

I striped wires and resoldered but still same. Will see when new parts come what will be the issue.


#9

Okay so I got new VTX and new camera (Runcam Swift 2) and I changed both VTX and camera and still no video. So my last try is going to be to remove the 3pin connector which was originally used for camera connector, its the one on the left next to the red circled connections from the post above. Will see if that solves the problem.


#10

Strange, if that doesn’t work maybe bypass the entire FC and just use Camera > Vtx > 5v power. Maybe the fault is on the FC osd side of things.


#11

Yes, I had to bypass FC …probably something wrong in there…But since Swift 2 has Vbat connector and Im getting battery voltage, do you think I will need OSD from FC? It is my first drone, I have no experience in this. And I will do also aerial footage so, please let me know ur opinion on this.


#12

Does your receiver/radio combo have Telemetry? If you can read the voltage from your radio you can set alarm on your radio, then you don’t NEED osd, although it is nice to have for things like RSSI (radio signal). Depending on whether you are going to do long range with it.


#13

I have Taranis Q X7 but Furibee X215 doesnt have telemetry…I think…And yes I would like to do long range also…


#14

It depends on your receiver, what kind of receiver is in there? You could put RSSI on radio too.


#15

there is FrSky XM+ Receiver


#16

Aw, crap. You are right, that one doesn’t do Telemetry. In that case you would need to get your OSD working or use another receiver, or you’ll be flying without voltage and RSSI warning.


#17

But if I have Vbat on Runcam which goes straight from battery + wire, that should be good enough to fly short range right? Btw, what is critical voltage for 4S?


#18

If you can do that, should be OK for short range. You can also rely on the buzzer for short range. Critical voltage would be to never go below 3.3v x 4 = 13.2 volts. Below 3.3 will damage the battery. I generally land around 14 volts or after my timer expires, you will find voltage changes a lot during flying (under load). On a punch out it will drop, then it recovers again. At the end of a battery it stays around 14 volts for a while and then suddenly begins to drop very fast, at that time it’s usually too late. Take your time on the first flights pay close attention to the voltage. Try to find out how long you can fly and what a safe timer would be. After you land the voltage will go up a bit. (resting voltage) Ideally you would want it at 3.7 volts per cell after landing. (14.8v) Better to come down a bit early, then fly too long and damage your expensive batteries, or even drop out of the sky.


#19

Thanks. Since that FC is partly broken and the OSD doesnt work and I had to bypass, I am thinking what would be the best thing to do. Should I get the same FC (https://www.gearbest.com/flight-controller/pp_666350.html Holybro Kakute F4 V1.4 Mini Flight Controller) or some other controller. Problem is, I am not sure if there is a controller for stack with exactly same dimensions, because the one I have now is max size that fits.


#20

I wouldn’t write the FC off just yet, could also be a software issue. Maybe try playing with BF osd settings or another firmware. Maybe you can also use a separate osd but I don’t have any experience with that. Now that we have narrowed down the issue try searching for this issue on Google again, maybe it’s a common problem?