Help! Quad Motor Problem


#1

Hi Everyone, First Post.

I got a Christmas Taranis QX7 and King Kong Tiny 7. When the throttle is raised on the Taranis, the motors immediately come on at about 1/2 speed and start accelerating on their own from there. But, in Betaflight if I use the Master slider on the Motor page, they work perfectly. Everything in Betaflight looks right and I compared settings with some Youtube posters to be sure. The only weird things that happened during setup were I accidentally pressed the BOOT button on the FC at first when trying to bind the TX, but I don’t know if that changed anything, and when I did press the bind button on the XM RX, then connected the battery to bind, I got a solid red and green light, not a blinking red light, but it still bound to the TX. Since they perform flawlessly in Betaflight, does that mean the problem is in my Taranis? The QX7 works perfectly in flight sims. Everything for the Tiny 7 model (Mixer, Inputs, Outputs, etc) is set to 100. Or could it be the RX since I didn’t get the standard blinking red bind light, but I don’t see how that would affect the motors, and it did bind. Completely stumped, please help!

Scrench


#2

Have tou made sure the min/max throttle value is at 1000/2000?
Also under the reciever tab, does the values look good when you move your gimbals om the Taranis?
Is the mode set to TAER (spektrum)?

If those are correct, please type ’diff’ in CLI the post the results here.


#3

min throttle is 1070
max is 2000 on config page.

AER are all dead on 1500, throttle 987 to 2011, all move smoothly.

Mode is TAER, but for Frsky.

color

mode_color

aux

aux 0 0 0 1300 2100
aux 1 1 1 900 1100
aux 2 2 1 1300 1700

adjrange

rxrange

rxfail

master

set min_check = 1000
set max_check = 1920
set motor_pwm_protocol = BRUSHED
set serialrx_provider = SBUS
set gyro_sync_denom = 2
set acc_trim_roll = -74
set pid_process_denom = 1

profile

profile 0

rateprofile 0

rateprofile

rateprofile 0


#4

Try lowering min throttle to 1040 in configuration.
By ”config page” you mean reciver tab?
I would also adjust the endpoints on the Taranis so your max throttle goes to 2000.

What is your pwm rate? I usualy have pwm rate at 16000.

Not sure if there is some hardware issues on top of this, hopefully someone more experianced than me have some ideas…


#5

No, I meant the config tab, On the Receiver tab Stick low is 1000, Center is 1500, High is 1920. RC interpolation is Auto.

Where is pwm rate?


#6

Im not sure that this had anything to do with your problems, but here it goes anyway.
In CLI you can type:

To se your current value: get motor_pwm_rate
To set a new value: set motor_pwm_rate=16000

Then type ’save’

Im not the best at explaining what it does, search the forum and you will find good answears.


#7

get motor_pwm_rate

motor_pwm_rate = 400
Allowed range: 200 - 32000


#8

Calibrate the accelerometer and check if airmode is permanently on.


#9

Since my pwm rate is only 400 should I change it to 16000? What does pwm do?

I thought the only way airmode can be on is if I program a switch to turn it on in the MODE tab.


#10

Set pwm rate to 10000 as a suitable general rate.
Airmode can be activated via a switch, set up in modes tab or permanently on, selected in the configuration tab.
In your first post you say the motors spin when you raise the throttle, this is good, then you say they increase by themselves, is this with the quad restrained? If so it’s totally normal, raise the throttle and it will want to fly, pid loops will be active and it will attempt to get to where the throttle and accelerometer are telling it.
Calibrate the accelerometer! Don’t spin up motors with it restrained, just fly it.


#11

See below.


#12

Thanks for the PM. I set pwm to 10000 and recalibrated the acc. and it
flies! I was testing the motors restrained, airmode is off. Thank you so
much for your help and encouragement. Last thing, when I try for a steady
hover a few feet off the floor, it constantly wants to wander around in all
directions, more than it seems possible to trim, and it constantly dips
back to the floor. Any suggestions?


#13

Does it do it still once you get a bit higher? Ground effect can cause that when you are real low.


#14

It does it regardless of height, but I’ve been trying to get it to hover steady at 4-5’ off the floor.


#15

Just read that lower pwm rates cause earlier motor failure and more motor noise. Mine at 10000 is the noisiest quad I’ve ever heard, so I’m jumping to 16000, maybe even 23000. Any reason NOT to use 32000?


#16

Quad is quieter at 16000 pwm and seems to have smoothed out a bit. I also created a near-perfect level surface using a two-direction level to calibrate accelerometers on. All this seemed to help, but, from a steady hover it still starts to drop all by itself, and this happens rhythmically, about every 5 seconds, then it starts to ascend again. You can hear the motors changing speed. I can keep it relatively level with throttle input, but I’ve never encountered a quad that did this, and the cycling of the drop makes me wonder what could cause it.


#17

You might just need to raise your PIDs and see how that goes. PID tuning usualy helps alot. If you are on BF 3.2 or higher, turn on dynamic filter.


#18

I’m on BF 3.0.1. PID strength was at 50 for Angle and Horizin modes, I turned it down to 25 to make the quad more docile for indoor flying. I thought PID’s just affected how far and how quickly yaw, pitch and aileron performed.


#19

Well thats not completly true. If you follow a tuning guide you will notice what behaviur that P, I and D can cause when either of them is to high or low.
I would recommend that you get a newer version of BF though just for the dynamic filter. But you should be able to fly without it.


#20

Thank you. I’ve looked it up and there is a disagreement as to whether or not when Dynamic Filter is engaged, you should turn off the two other filters. What do you think?