Micro Motor Community

Help me fix my F3 Evo Board by Eachine burnt transistor

#1

Does anyone know this transistor on this board? I burnt it why adding a buzzer. The chip is to the right of the USB port and I put a red box. Hope someone can help. I was able to fix a Scisky FET before by looking at one of the posts in this forum. I also posted this question in rcgroups but I did not get a reply.

0 Likes

#2

Here’s a pic from my F3_EVO_Brushed board:

0 Likes

#3

The one that says SL, or the one that says “100”?
SL looks to be a diode, probably a Schottky diode rated around 10v, 100 is a 100uH inductor, unknown amps.

Both can be found easily enough.

0 Likes

#4

@noypi2000’s broken element is the “SL”.

0 Likes

#5

The one that is labeled SL. I will try and find a Schottky diode. If you know where to find one let me know. I found a 1AMP 20V in ebay. Will this work?

0 Likes

#6

Probably, yeah.
I’d go for digikey if you’re in the US, there’s a little bit of account setup but they have pretty much everything. Figuring out what package the diode is in might be tricky, measuring it with calipers/micrometer/vernier gauge should get you close enough to make it work though.

0 Likes

#7

I will try the diode from ebay. Thanks for all the help.

0 Likes

#8

I am happy to report that the Schottky Diode that I bought from Ebay http://www.ebay.com/itm/272134449900?_trksid=p2057872.m2749.l2649&ssPageName=STRK%3AMEBIDX%3AIT worked. Thanks again for all the helpful people in this forum.

2 Likes