Micro Motor Community

Help, cam goes out wheb throttle up


#1

OMG, i just bought a z02. On the first one I riecieved it went out when I throttle up. I returned it and the same issue is on the replacement… WHAT IS BROKEN??


#2

That sounds like the power filtering capacitors on the FC may have been damaged.
I had that on a betafpv-lite recently.
Adding more filter caps fixed it.


#3

It’s gotten much worse… FC doesn’t boot into silverware now. I can’t flash it either doesn’t show up. Won’t bind… I think it’s over. shouldn’t have left it on my table overnight i guess…


#4

Time to pull the FC out and see if it works by itself. If not, it’s new FC time, if it does that means something else is causing the issues.


#5

If the FC shows as unrecognized device when trying to enter DFU ImpulseRC has a program designed to fix that. If you didn’t already know here’s a link https://impulserc.com/pages/downloads
Windows pc are the reason they made this program I believe since I have plenty of experience with windows and driver issues.


#6

Ill try doing that, I’ve been inspecting the FC for the last 6hrs. Everything seems fine. It is an old e010. maybe the FC just died?


#7

Oh, it’s a silverware, I missed that. I don’t think that will work for silverware FC :confused:


#8

Oh… At least the FC’s are cheap


#9

Indeed. I’ve been out of the loop for a bit even though silverware started a while back. Does the FC light up when you plug it in? If it lights up I would check the pins for the programmer on the FC and the programmer itself. If the pc does nothing when you plug in the programmer it could be driver issues because whether or not it’s connexted to the FC it should show up on a com port by itself.


#10

I don’t know what happened. The FC just started working after I re-flashed “No device plugged in” a couple hundred times. but the issue with the cam is still present. I’ve noticed that if I put my finger on the cams LEDs while I throttle up everything is fine.


#11

I saw that that AIO is switchable between 0-25-200mw. If it’s in 200mw mode that might be the issue? I have a TX-02 and that’s 200mw. I tried using that on a Whoop and that was the result I got, the Whoop would barely fly and then get grounded. Have you tested the build with camera off?


#12

It’s on 25. led said so. (the OSD in the vid is onboard not magical through silverware) and about the build without cam. Before the flashes it didn’t work even without cam


#13

Just noticing. my even though my cam is on boscam 4500 I still can connect my goggles. it only works sometime.


#14

I suppose what bobnova was saying could be the issue. I believe he was referring to the two caps usually 10uf that are near the inductor for cleaning up the power. He’s a really smart guy and knows a lot more than I do. I have the basic concept and kinda know how things work but he has a deep understanding. Ihave learned most of what I know from fooling around with open spurce FC. I also have learned a lot around the various forums and YouTube including this Moco Motor Community. Anyhow, I believe those would be the caps bobnova was talking about because power flows through those after the power regulator. Nice touch with the Nintendo music :grin:


#15

I’ll try seeing if I can do something with the caps, And I know as a intellectual that the wii channel theme is an amazing masterpiece, That is the reason I chose it. (Definitely not cause it was #1 royalty free music)


#16

It’s still really wierd that shorting the LEDs (or pressure) just fixes a problem.


#17

YEEHAW BOBNOVA. ya did it. One of the caps wasn’t soldered.


#18

Like I said, he’s pretty damn smart haha. Solder joints are very difficult to tell by looking at them if they are making contact unless your using magnification. Even then you can miss it but what you said in the last message was a good indication that something needed reflow of pressure was fixing the issue. Congratulations @An_Old_Man :grin:


#19

Yeah at first I thought it was just oxidation but it was a crack. Thanks for the help everyone!! Time to race this old whoop!


#20

Woohoo! That’s excellent news!