FC not resonding


#1

Little problem. I have a brushed quad with the eachine 32 bit Naze FC. In cleanflight, I can tune and set up the quad, but when I try to arm, it doesn’t respond. Also, when the battery is plugged in, the motors instantly goes full throttle. I’ve tried arming and er checking the connections and nothing works. The TX is fine, and in the Rx tab, it shows that the signal is coming through. Any suggestions? Thanks


#2

@MidnightQuads
Can you post a screenshot of config page with min throttle min command etc
And then what do your sticks travel to in the receiver tab?
Looking for 1000 -2000 for all channels or as close as you can get with 1500 being center.
May have to adjust travel on tx to get there. On my Dx6i it’s -127 then I have to adjust the other side to +127 and sometimes I still don’t reach 1000-2000.
There are ways to adj with CLI commands as a last resort


#3

@MidnightQuads
I bookmarked @burtlo “crib sheet” here:
F3_EVO does not respond to Transmitter input after flashing
Hopefully it will help


#4

Kamsleo, thanks. A picture won’t help, sadly. All the values are in the 1000-2000 range. It is that way on the motor tab and the rx tab. Also, I tried to recalibrate the esc, with no luck. It spins up and back down when I do the slider, but not with the throttle.


#5

How about posting some pics of your FC.
Front and back as close up and hi res as you can. There are some very knowledgeable guys here with a sharp eye, maybe we can spot something


#6

Within 1000 to 2000 range is not good enough they need to be 1000 min and 2000 max. Not slightly higher or lower. What is the exact value of throttle channel min? Also in cli type “get min_check” and let us know the value. If the min throttle value is above min_check value it will not arm.


#7

If motors are spinning when lipo is plugged in it’s either min command too high (set it to 1000) or wrong ESC/motor protocol (set it to brushed).

Next thing is with a brushed setup you don’t have to calibrate ESCs like on a brushless setup.

For arming follow @Chaotix advice.


#8

Thanks, chrisdo, that was helpful. I think that that’s the problem.


#9

Thanks a ton chrisdo! I had oneshot selected, and not brushed. How dumb. Thanks for all the help!