[FC] - MultiFlite PICO-B-FC: Cleanflight F3 Quad FC

fc
multiflite
quad
pico
brushed

#144

Hey @quadlifepro good news! Next time add more solder to the pins so they all join together, heats quickly that way and dilutes the solder they use in manufacture. It is easy to muck up, I’ve had my share of overheating damage.
Now get that Crook in the air and enjoy the PicoB :smiley:


#145

:frowning: sigh… sorry chaotix… last question - i held the throttle up, and then pushed left a few times while reversing channels and what not, and i noticed this blinking blue light… i know it is the accelerometer trim, but I now I am “lost” on where it was last set… I tried letting it blink 15 times to the right, and then 30 times to the left to see if i would indicate where the middle was, but I cannot seem to find “middle”… Is there a way to reset the accelerometer trim back to factory?

edit: nvm - I think i got it…

set accel trim pitch was set to 0, and set accel trim roll was set to 48, so i set them both back to 0 which I assume is the stock setting… I guess I could always just re flash back to stock if there are any issues…

I tell you what @giles - you seem to have made a bullet proof board… It so far has survived ME… the FC ruiner… :smiley:


#146

In that sort of situation typing “diff” will show you any changes so can pin down what’s altered.


#147

excellent point! out of fear of messing something up I paniced and tried the analog count method… then sifted and sifted for accellerometer values, where i could have jus typed in “diff”. that would have simplified things but of course lately ive been making things wayyyy complicated… i need to stop being so impatient with my builds and start paying more attention… lol thanks again chaotix!


#148

Another command I use lots is “get” as in “get acc” will show all lines with acc in them. CLI is a great thing to get into for troubleshooting and altering stuff that might not be in the gui.
I have this open in a tab almost every day CLI


#149

You also can simply recalibrate the acc to get it back to default either with stick commands or through BF.


#150

Hi, i am having some serious problems. It all started out amazing until one day it wouldn’t arm so i had a look and couldn’t find anything wrong so i tried re flashing with betaflight but it now wont flash on says cant contact boot loader. Also all i get is solid red!!!
PLEASE HELP. @Chaotix @giles
Cheers Josh


#151

hey there, i am sorry ur having issues with your multiflite :frowning:

Have you continued trying to re flash the board?..

I believe if you get “cant contact boot loader”, it may mean you need to jump the boot pads and then try to flash it… I usually use a pair of tweezers, and have a family member/friend plug the USB port for me and then also have them click flash firmware while i hold the tweezers in place. Makes flashing 2 times easier than having to solder the boot jumper pads together IMO…

let me know if this helps!


#152

Cheers pal, I thought it was the button? And if so I have been pressing it
down. Yes I have tried loads of times.


#153

If you can connect to betaflight still , try typing DFU in cli, after you hit enter it should boot into DFU and then you can load the correct firmware and flash as usual. If you have to short the boot pins then select “flash on connect” in the flash page and all you need to do is short pins and plug usb.


#154

J wren, hopefully I am not mistaken but I believe the button is for binding the transmitter to the receiver… that’s the only time I used the button for the MultiFlite pico.

Are you on a windows or a Mac?

Also @Chaotix that is an amazing tip, thank you for sharing that.


#155

I have finaly got it to flash but now it wont arm, all end and mid points are set. soooo… im not sure @quadlifepro @Chaotix


#156

Quad level, accelerometer calibrated? No channels going too high, no failsafe active (icon next to armed icon in top panel) arm switch set correctly in configurator? Does the tick mark move into the correct area.


#157

@Chaotix On my pc everything looks OK but it keeps failsafing. And if I just normal
power up I does nothing


#158

Could you post up some pics of the quad and close ups of the fc. There may be something visible causing problems. It was a flying quad before this happened yes? What target did you flash with?


#159

Yes it was flying before, betaflight. Im I can’t currently get any pics. I
will upload some later. Cheers


#160

@Chaotix so it binds for like 2 seconds then it just failsafes repeatedly. i have no idea what to do.


#161

Did you flash MULTIFLITEPICO target specifically? Or was it the SPRACINGF3 one? Is really going into failsafe, the failsafe icon in configurator lit?


#162

yes i did the multiflitepico target and yes the icon is coming up. @Chaotix


#163

Ok, had to check.
Failsafe is triggered by loss of contact with tx or if the rx receives a pulse of the wrong length, either too long or short in usecs. Something from the tx through the rx to the fc is causing this to trigger, something that might have been changed. We need to try and isolate what part.
Start at the tx, are the batteries charged and in good condition? Is the antenna secure? Has anything been altered in the model you’re using? You could try setting up a new model and binding again to rule out any errors there. What tx is it?
Next the rx, is it a lemonrx? Is the antenna in good condition? Check the security of the plug and wiring. Do you have another sat you could substitute?