[FC] - MultiFlite PICO-B-FC: Cleanflight F3 Quad FC

fc
multiflite
quad
pico
brushed

#122

I pulled out the pins on the TX02 and the crimps are incompatible with the supplied cabling/connectors from mulltiflite. I really would like to take advantage of that 5v regulated output, but don’t know how to go about it at this point…

Should I de-solder the 3pin connector on the board and solder the tx02 pwr/gnd to the directly to the board?

OR

should I solder the pwr/gnd cables from the tx02 to the pwr/gnd cables on this connector, then cover up with heatshrink and call it a day?


#123

I’d go option 2 if you don’t have a crimper. the other option is to desolder the cables at the tx02 end of things then attach the cable that came with the FC to the tx02.


#124

THANK YOU! You are a multiflite saver lol I can only imagine how badly I may have hacked up my prestine new multiflite board with my mediocre/fair soldering skills lol

Plus this way with option number 2 If I want to fly it as a LOS unit I can always just unplug the camera :slight_smile:

Thanks again!


#125

Totally agree


#126

I very much prefer cameras attached with connectors, I’d take #2 as well.


#127

Hey you guys, just wanted to show off some pictures, I figured this may be a good thread for it…

Im proud of my nearly “plug and play” style multiflite board.

I had to de-pin the lemon rx, and solder the positive ground and signal wires accordingly. I also had to make my own plug for the tx02 camera, soldered 2 wires and some heat shrink. Easy peasy!

All components, RX, flight camera, and buzzer are now completely plug and play! :slight_smile:

I will be hooking it up to the Cook 110, with some 18 darkies! - for FPV Ihave a feeling this set up is going to rip! :smiley:


#129

I was getting ready to bind my multiflite pico FC while at work, and for some reason got distracted and ended up typing “Set_spektrum_sat_bind=9” “Save” in CLI and then powered down, then I realized that wasn’t part of the bind proceedure! :open_mouth: and then I remembered there was a bind button to be used and there was a user manual with a bind proceedure in it!

I powered up while holding the bind button just to see if the RX would start rapidly blinking indicating bind ready… but it did not.

So I changed it to “Set_spektrum_sat_bind=0” “Save” . Powered down, powered up while holding bind button, still no rapid flashing light on RX…

I then realized there was a “reset settings” button in the setup menu of cleanflight, so I clicked it to restore all settings back to default.

After resetting the settings I checked the dump and it said “Set_spektrum_sat_bind=5”… So I figured the setting reset must have worked. So I powered down, powered up while holding the bind button and still got no rapid flashing light on the RX…

Any ideas on why I cannot get the lemon rx to flash rapidly? Since I have reset the settings, everything should be back to default, so my beginning mistake of setting sat bind to 9 shouldn’t matter anymore right?..

Cleanflight/MULTIFLITEPICO 1.14.1 Nov 16 2016 / 19:24:21 (51ae22d)

is the version of cleanflight that came preflashed on the FC… I am at work with a crappy computer so I cannot update the firmware just yet, was going to do that when I got home… I wanted to try to fly the stock settings in cleanflight while i was bored waiting for the day to pass… Any suggestions would be much appriciated!


#130

DId you check the jumpers on the underside were shorted correctly or at all. One for sat/ppm another for 3.3/5v.
You can use either the bind button, held whilst plugging in battery or USB or cli command.


#131

hey chaotix, thanks for helping me out…

I did not think i had to solder a bridge on the bottom for the RX… I thought if i was using a spektrum sat dsmx rx and spektrum radio It was ready to go.

i see in the user manual it says

“SJ1 Note: The default setting for the receiver input is Spek Satellite. To change this to PPM, solder a bridge
between the right side and the centre pad.
SJ2 Note: The default setting for the receiver voltage is 3.3V. To change this to VBATT voltage (the voltage of the
battery), solder a bridge between the right side and the centre pad.”

Since I am not setting the RX to ppm, but using serial Rx for dsmx i believe i do not have to solder a bridge, and leave it set to the default?.. and then the RX requires 3.3v, and that is also the default setting…


#132

That is correct it should be set up default 3.3v and sat, but one of mine had no solder bridges leaving me stumped until I thought to flip the board over and check.


#133

If you reset to default it could be the standard target defaults rather than the multiflite ones so you may have to set up from scratch, ports, configuration tab, rx, etc. You could download the hex from multiflite site again. Shouldn’t matter your on a crappy computer if it can run Cleanflight.


#134

upon closer inspection, it seems that the solder bridges are up to par… actually really well done looking bridges! :wink: glad I didn’t have to do them because they would have turned out nastyyyy lol

The reason why I don’t mess around with firmware flashing on the windows computers at work is because they don’t have the STM32 driver installed (or properly at least :wink: ) and won’t flash boards… Me being a computer noob, I am scared to make any changes to try to install the stm32 driver without messing up any existing drivers installed, or somehow ruining something where my boss can blame me lol…

I usually just wait until I get off work, and go home to the mac, which for some reason just always seems to flash anything i’ve thrown at it so far, and strangely enough have never had to manually download drivers or configure anything… It just works. lol

I did not see multiflite pico on cleanflight or betaflight…


#135

Actually Betaflight has a Multiflitepico target now, check the dropdown menu. If you have a Mac at home then keep away from Windows :wink:
There are a few optimisations in the code to suit the boards architecture but it will run SPracingF3 quite happily, obviously no need now though.
The soldering job on these cards is really neat, some of the best I’ve seen, a quality product.


#136

wow yay betaflight target for multiflite pico!

thatll make set up so much easier than downloaded a hex.file from the site, or having to go through page 8 user manual instructions of setting up spracingf3 firmware.

When I go home I will flash the newest 3.1.6 on the board , and then follow the proper bind instructions… dammit I wish I read stuff before doing things. lol

and honestly, as much as I hate saying this I will certainly try to stick with mac, it has never let me down.

Thanks for all of the help!!! I have never been so excited to get off work!!! :smiley:


#137

I successfully reflashed the latest multiflite pico hex file from betaflight 3.1.6 i believe. and as soon as I did this, I tried the bind procedure again. This time, when powering up with the button held down I was able to get a rapid blinking light indicating ready for bind, but every time I would try and bind with my dx6 the bind fails… It is so discouraging because I am so ready to rip on these dark editions but I cannot until I can get this dang FC to bind to my tx…

So i noticed the stock setting for “set spektrum_sat_bind=” was 5 again. I changed it to 9 thinking since 9 is for dsmx and it would maybe bind this time. Nope. So then I changed it back to 5… I double checked to make sure serial rx under 3uart is active, and that it was set to spektrum 2048… checked in my tx that is is set to dsmx 22ms, even tried to bind at 11ms and still no luck…

I am going to go to the park to fly my first micro quad today. Hopefully that will take away some of the stress and sadness this bind situation is giving me…

if anyone has ANY ideas… please let me know…

UPDATE - my OCD said don’t stop trying… I reflashed the firmware again, tried it again. no luck. I then changed it to spektrum sat bind 0 , and then tried again. no luck. I then changed it back to the default which was spektrum sat bind 5, tried it again BINGO! I got it to bind. Thank goodness… I truly don’t know why it was so hard to bind off a brand new firmware flash, but I am going to chuck that up to possible wifi interference or something along those lines…

@chaotix - thank you again for all of the help. You are the man.

double edit - I thought everything was good with the bind, but I think I really need to bind off of 9, because now i have no TX input in the reciever tab lol I’ll try again… :frowning: hopefully she binds on 9

triple edit - I reflashed the firmware again and changed spektrum sat bind to 9, and now I cannot get the rapid light to flash when powering up and holding the bind button, i just get a brief “blip” of a light again… Definitely going to the park now. lol


#138

If you have a bind button on the board, you don’t need to use the CLI command. Set that back to Zero.

Make sure you have the correct port set up in BF. I haven’t played with this board, so not sure which port is used.

Make sure in the Config or receiver tab, its set as serial Speksat. Make sure you are using the proper 1024/2048 setting.


#139

I have a feeling the bind button is not always getting pressed properly as its worked once using it. Your settings sound ok but maybe post a dump just in case.
@giles are you available for comment?


#140

I noticed that the button is a little tricky sometimes… but I will give it some more tries that’s for sure… here is my dump as of now… spek sat bind set to 9, i will change it back to 5 to see if it allows me to bind again


#142

I am going to try to give it a few more attempts to bind today while at work… i have now 5 and a half hours to try to fly by lol

edit: now for some reason the bind button is working flawlessly today on this computer… I get a rapid blinking light indicating ready for bind whether it is in 5 or 9 for spek sat… i left it on 9 because i need it to connect via dsmx… but it just won’t bind… it keeps saying “bind failed”

because i had removed the connector for this lemon RX maybe I messed something up on the RX.it was a total pain in the butt to remove the connector, maybe I get the board too hot and fried something and that’s why it is not working… I will try a new RX wihout the connect desoldered to see if this helps.

edit from a few hours later :

okay so the rapid flashing bind light is always working now… but after multiple attemps to bind to 9, i cannot get it to bind to 9 to save my life. I tried binding to 8 because I know it is a slower version of DSMX, and it DOES bind to 8, but I get no TX input in the RX tab… its the same thing when it binds to 5 and 8, itll give me a solid bind light, and then say “bind complete, dsmx 22ms” but won’t give me any stick input… If I try to bind to 9 it just flat out says “Bind failed” constantly…

SO, i guess the next move would be to try to use a different RX. I highly doubt there is anything wrong with the board or my dx6, it must be the RX that is not working properly… I must have ruined something when trying to desolder the connector from the board…

I’ll post an update when I install the new lemon rx… Hopefully then I can get the board to bind under 9 dsmx 22ms and hopefully after that I can move on with my life.


#143

@chaotix - just wanted to give you and @giles an update. I have got a new lemon RX attached to the board and it had bound successfully under 9…

I feel like when taking off the connector of the lemon RX, i may have left the soldering iron on it for too long which caused it to burn out a nessecary component or something… The solder that comes on those pins from the factory is hard as hell to get melted to pull the connector out, so thats probably what happened…

Sorry for all of the crazy nonsense! I think its finally time I set up my crook 110 to do some real ripping! :slight_smile: i should be fine from here on out! thanks again chaotix for troubleshooting with me.