F4 1s a10 FC can't get it to go into bind mode

I just got the Betafpv f4 A10 flight controller for my Betafpv Meteor 75. I can’t get this FC in bind mode. The instructions say " connect battery and hold the bind button for 3 seconds and the green led will turn solid to indicate it is in bind mode" but that isn’t happening. I have tried:

  1. pushing bind button and connecting the battery but this does not put it in bind mode
    (green led completely off)
  2. Connecting the drone to betaflight and trying to bind there but there is no bind button in the receiver tab and the CLI command “bind_rx” is not recognized…

I also made sure that the battery I connected was fully charged… but I am out of ideas.
I am hoping someone has this FC and has dealt with this problem or has a suggestion.
Thanks!

Are you sure you have one with built in rx? If so you need to set receiver type as spi and the protocol of your choice in the configuration tab, then the bind button in the rx tab should reappear

Hi, thanks for the reply. I bought the no rx version and installed the rx myself. I solved the problem by going into Betaflight and in configurator specifying “spi rx” in the receiver window and “FRSKY D8” as the protocol. Live and learn. Thanks again for taking the time to respond!

Hi, awesome you solved it. However the solution leaves me a bit puzzled, usually an external rx is connected by serial connection with the rx type set to serial and in case of frsky the sbus protocol. Spi would only make sense if you connected it by directly soldering a spi rx to the miso, mosi and power pins. I didn’t even know those pins were broken out on the board.

Their no-rx version has pads (pinheaders) for connecting a receiver via SPI. Which means, if you managed to get Bayang SPI support into Betaflight, you could attach a XN297L or even an NRF24L01 to those SPI pins and fly your brushless on Bayang protocol

Nice, I did not see that, good to have the spi option available.