F3 brushed flight controller


#1

Hi guys, today arrived my new fc, bought it at a flash sale because i thought it would come handy to make a new tiny whoop…


So, i flashed it with BetaFlight, everything ok to this point, but now when i plug it to Betaflight it doesn’t connect… it says that opens the port but closes it at once and tell “port successfully closed”, so i can’t go any further from this point…
Did someone bought this fc board? Did this kind of situation happened to someone? How can i fix this, or what i’m doing wrong? Should i flash it again?


#2

I’ll reflash it, but make sure you putting in the right target file.


#3

I will reflash it. But i think that i did everything right… But it won’t hurt to do it again… will do it after work. Thanks.


#4

Make sure to put it in DFU mode


#5

Yes. I did it the first time. It shown on the top right corner DFU. Hope it won’t be a bad fc…


#6

Hi guys. Did all the proccess from the top, and the same thing happens. It uploads the newest firmware SP RACING F3 EVO 3.1.7 in DFU mode, all ok till this point. Removed the boot pads solder, tried to connect with BetaFlight, and it doesn’t connect. It says "serial port successfully closed with ID: (number)"
What i’m missing?!


I bought this fc to connect my SP09X DSMX receiver, and make use of the remanining UART ports for some other ideias that i have. And also because it can be used for 1S or 2S lipos. So i was thinking on making a 75mm tiny whoop on 2S lipos and 8520 motors…
But now i can’t go any further… dead end at the starting line…
I think this is a Fc from some brand called GoolSky.
What should i do now?


#7

Download the CP210x. Driver from Betaflight…
Boot your FC install that driver into the FC…
While still in boot mode re install F3 EVO…
Then connect in Betaflight


#8

Thats how I got my FCs to work when this happens.
Zadig also…
But mainly the CP Driver do me just fine


#9

Thank you Dnex1. I’ll try that after work. I’ll let you know how it work out.


#10

Hi guys. Downloaded cp210x, installed it, reflashed the board. But nothing, still making the same issue. I made a little video and contacted the seller. I think it may be a board issue. The board has two leds, a green and a red one. The green stays on, since i connect the board thru usb, must be power led. The red one flashes quickly a few times, and a couple of slow flashes. I don’t have any ideia of the meaning of those flashes, but it must be some board issue. I’m going to wait and see what the seller tells me…


#11

One more thing guys, i have just pluging the flight controller. No motors, no rx, nothing… just the board. Coul this be the problem?


#12

No thats not a problem… The lights are normal… Ok use zadig… Boot the FC… Go to zadig… Go to option… Go to list devices… U should see dfu or stm32… Replace driver with windowusb… If that one dont work…replace driver with usb serial… Srry for the late reply


#13

When u reply use @ then my name for it will alert me… Download zadig from BetaFlight


#14

@Dnex1 didn’t know about the @ :grinning: always learning.
I think i did that already, but i will try again, maybe i missed something. I’ll try as soon as i get home. Thanks.


#15

@Dnex1 you are the man… installed the usb serial thru zadig, and magic happens… i can now go thru with my tiny whoop build…
One thing, i didn’t soldered the boot pads when using zadig… but it worked anyways… you are the man.
Thank you…


#16

The ImpulseRC Driver Fixer utility is a very helpful tool. It usually fixes most FC connection issues for all the different chipsets and modes. Available here: https://impulserc.com/pages/downloads


#17

Wow I have been through the ringer with the updated version of this board.

Designation: F3_DPX-V11

It has a different version of the MP65 ?gyro? and an additional 1.25mm connector on top of the board adjacent to the boot pads.

I can connect, but no combination of Zadig, Impluse, or manual installation of drivers will allow the detection of the Bootloader. I either get a warning the device is not present(exclamation shield in device manager) it will load as an STM32 Bootloader, Bootloader in DFU, etc and fail to be recognized by Betaflight.