Eachine F3 minicube v1.1 ESC problem


#1

Hi,

i´m about to build my first brushless micro with a 4 in 1 ESC.
i´m talking about this one Eachine-Minicube-10A-BLHeli-ESC.
It´s a part of Eachine Minicube 20x20mm Kompatibel Frsky Flysky DSM RX F3 Blheli_S 10A that i´m trying to use for my little flyer.

Unfortunatly i must determine that ESC 3 is not shown in BLHeli if i check the 4 in 1 ESC.

Before flashing the newest Firmware all 4 ESC was responding to blheli so i think the Bootloader was broken at flashing.

Is there any way to reflash the Bootlaoder and bring the ESC back to life or is it finaly dead?

Hopefully not …thank you for your help in advance.


#2

I’ve used the Minicube several times now, and while not the greatest quality in build, I have not yet had trouble like you describe. At this point, I can only offer some debugging suggestions.

Check your signal wires between ESC and FC, the 6-pin cable that attaches to the connectors on each board. Besides the ground wire, there’s an unused power wire position, and then four signal wires, one per motor. Try swapping those pins to verify that it’s a problem with ESC 3 as opposed to a bad wire.

I’m unfamiliar with “m4wFCIntf”, which seems like the interface you chose in BLHeliSuite. I’ve used the Cleanflight interface. I have no idea yet the significance of those interfaces, but that looks different than I’ve done in the past.

Check your power, ensuring it’s as you expect and sufficient. I’ve had issues lately with ESCs acting erratically when I didn’t provide enough voltage. Also, when I received the Minicube, it had an LC filter, which I later learned was only a noise filter, not a voltage regulator. Can you tell more of what battery you are using, and give an image of your connections including ESC + FC + battery?

I don’t think it matters, but if you’re using USB “passthrough” (I think that’s how it’s referred to), where you connect to the ESCs by connecting the FC to USB, and then program through the 6-pin connector between the FC and ESC… try to downgrade the protocol that is selected in Betaflight to Oneshot42 or maybe even PWM.

Just some thoughts, hope those offer some things to poke at.


#3

I had the same issue with one of the minicubes… Here is the thread I followed to get it back running. It was awhile ago so I don’t remember the steps I took, but following this thread got me through it. I think I started a thread here when I had the trouble as well…

https://www.rcgroups.com/forums/showpost.php?p=36908650&postcount=627


#4

Thanx burtlo!

Have checked it so many times, any wire goes to the corresponding pwm signal of the FC.
Changed the cable to another that fine works on my other Micro with the same components.
I can exclude that.

About the “m4wFCIntf” interface i can only tell that i have chosen Silabs BlHeli Bootloader (Cleanflight) but the Atmel BlHeli SKBootloader (Cleanflight) works also and i can succesfully connect with this Interface.
I´m unfamiliar with all this protocols but According to the manual is the silabs to select for this ESC.
MINICUBE 4IN1 ESC QUICK USER GUIDE

Anyway, thx again for this thoughts…:+1:


#5

Hi bubbak,

thanx for the link, looks like that can be work hopefully.

I will give it a try and testing them out.
I know i have a Arduino Nano lying somewhere :face_with_raised_eyebrow:

Edit:
Ok it works ! wooOOt! :+1:

The ESC is back but unfortunatly i ran into a new problem…

If i try to test the motors in Betaflight or BlHeli on the motortab the slider for the Motor one and two control the same motor.
If i push motorslider “1” the motor spin clockwise and if i push slider “2” the same motor spin counterclockwise.

If pushed the master slider only three motors spin up…

Damn, i´m confused…never running in such problem before…

Any Idea.???

Thx in advice


#6

@eXzez - Glad that took care of it. Your new problem however is something I’ve never heard of… Did you flash the FC with updated firmware? I may be getting my FC’s mixed up, but I thought the original minicube had custom firmware and I don’t think you are supposed to reflash it with a stock firmware. I’ve never messed with some of the settings in BF, but if you post your CLI dump, there may be a way to reassign the motor ports.


#7

Hi bubbak,
yes i have reflashed the FC with newest Betaflight firmware but my other build that uses the same minicube works fine after update. The only difference is that this version iss the Anniversary Special Edition.
It´s realy annoying that the more expensive version have so much problems.

Here is a [video] that clarifies the problem.
But anyway if it is realy the flashed firmware that makes things wrong, is there a way to get back the original firmware?
Again thanx for ya help !

>>My Betaflight Dump<<


#8

OMG…

Ok, after checking all the connection again and again and again i have solved the problem!

The wrongdoer was the connecting cable from the ESC to the FC. The connector on the cable side have some closed holes and so the pins on the FC connector was bending to another pwm connector. Thereby two pwm pins where bricked and send the same signal of one ESC to two different motors.

Unbeliveable that i have make this mistake… :confounded:

Anyway thanx everyone for helping with.


#9

Great find. Thats definitely one for the story books. Take any pictures?


#10

Unfortunatly i did not take any photo of them.
I dont know if any other will ran in such problem but here is a skribble that shows it detailed.

My lesson about this…
Before you stick them together check always your connectors that all look´s like it should be !

:smirk: