E011 stock tx diagram channels

does anyone have the channel diagram for the e011 stock tx channels? i know ive seen it around before, but have been looking for an hour already and still havnt found it, so if anyone has that diagram that they can send me or if you know which button corresponds to which channel off the top of your head, that would be really helpfull. thanks

Should be same as h8 mini, if I remember correctly.
Ch 1 - Roll
Ch 2 - Pitch
Ch 3 - Throttle
Ch 4 - Yaw
Ch 6 - Flip
Ch 9 - Headless
Ch 10 - RTH

(@NotFastEnuf, @Chaotix)

1 Like

What abt channel 7?

I guess what I’m really asking is how to use racemode

In defines.h, I see the following mapping for the stock Tx:

 #ifdef USE_STOCK_TX
 #define CHAN_5 CH_EXPERT
 #define CHAN_6 CH_AUX1
 #define CHAN_7 CH_HEADFREE
 #define CHAN_8 CH_RLL_TRIM
 #define CHAN_9 CH_PIT_TRIM
 #define CHAN_10 CH_OFF
 #define CHAN_ON CH_ON
 #define CHAN_OFF CH_OFF
 #endif

From that, it looks like you can use Channels 5, 7, 8, and 9 - those are mapped to buttons on the stock Tx. Channel 6 is mapped to the AUX1 gesture-switched channel. (Note: the E011 stock Tx doesn’t use all of the Bayang channels, so you can’t use any channel you want)

That mapping is different than what chrisdo posted, but there may be something I’m forgetting. If you give it a try, come back here and post what you come up with :- )

You can use racemode (or other features) by remapping the channels in config.h, then compiling and flashing. You can set the features you need to any aux channel - you can shuffle them around. Note, to save channels, you can do things like:

  • Assign multiple features to the same channel
  • Assign a feature always on with CHAN_ON
  • Assign a feature always off with CHAN_OFF

If you assign each channel to the LEDS_ON feature (one at a time, flashing in between), you can easily determine which button on your Tx controls which channel.

2 Likes

Hi… It works perfectly with command lines in mixes and logic switch options. It was not so easy to setup but I have now on my taranis a switch that arms my spinning immediately after arming quad.

prototype pcb

Your quad just spins when you arm it?

That’s probably because you have the “normal” motor/propeller configuration called “props in.” NFE Silverware runs “props out” by default.

You can do a simple stick gesture (right stick) to reverse the motor configuration: Down-Up-Down, then Down-Down-Down to save. The quad will blink its LEDs to confirm the commands.

i do this sequence, but motor still running, and comment out #define INVERT_YAW_PID. I use E011C board. I dont know why but when compiling there is message : *** Warning: You are compiling one or more files of source type C++ and have selected ‘use MicroLIB’. MicroLIB does not support C++!

any one can help me?

That warning is nothing to worry about - it is normal.

I don’t understand what problem you’re having. Is the quad the spinning after arming or just the motors?

Please describe, step by step, what you are doing and what you observe at each step and what problem you are seeing. If you can post and link a YouTube video, that could help, too.

If the quad is spinning in circles, try changing the props in/props out setting. That fixed it for me. If it’s just the props that are spinning, that’s normal, it’s just the idle. If it’s lifting the quad off the ground you can lower it in config.h where all the channels are defined, or if u want to turn it off completely u just set it to 0.

or i have to put all the motor with prop on frame?

normal? so if i want non spinning motor when arming i should change
#define MOTOR_MIN_COMMAND 5.0 to 0?

im new in drone, so can u explain to me why people need motor spinning when arming by default? before i change the code maybe with your explanation i can change my habit in drone first.

edit : i still have same behavior with #define MOTOR_MIN_COMMAND 0.0

It just looks like normal idle-up behaviour (motors spin on arm). People use it so they don’t lose control at zero throttle, for example in a flip. If you don’t want it change #define IDLE_THR 0.05f to #define IDLE_THR 0.00f . That will make it arm and have no motor spin.

1 Like

solid explanation for a newbie like me, thanks, ill change my behavior rather than the code after i get used to it.

1 Like

Ohhh. Lol gonna turn it back on. That’ll prob help. I was thinking it did something like that but was to lazy to turn it back on

so what #define MOTOR_MIN_COMMAND 5.0 means?

im not using camera yet so my drone is very light, i got my throttle very very low and my quad just flown away to the moon, what should i change to avoid that?

i will set up my mixer to throttle to compensate that, but beside throttle mixer any setting that i can do?

Change
#define IDLE_THR 0.05f
To
#define IDLE_THR 0.01f

i use IDL_THR 0.00f. because my quad is very light and fly when arming.

now im dealing with very low throttle to fly

Get rid of this compensation

Should trim button solve this problem? I found along with the battery drop i get my comfort throttle position